Some ESX Hosts not discovered

Unleash the power of System Center for vSphere and Hyper-V | Veeam Task Manager for Hyper-V

Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Mon Mar 11, 2013 9:19 am

All the ESX Hosts have been added to the nWorks Management and all the test connections are succefull and showing all the object counts from nWorks Manager , but in SCOM all of the are discovered except 2 !

First i had connected to vCenter and everything showed , then I removed the vCenter and connected to the ESX Hosts.

Proxy mode is set for the collector, tried removing and adding the 2 ESX Hosts not showing in SCOM , tried rebuilding topology with no luck.

nWorks logs are not showing any errors.

PS: Using SCOM 2012.

Anyone can help ?
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby sergey.g » Mon Mar 11, 2013 10:59 am

Hello,

What I would recommend is to connect only the server which cannot be discovered and check collector logs for errors. To me this looks like a permissions issue, most likely an account that you are using to connect to ESX hosts doesn't have necessary permissions for some components of virtual infrastructure (VMs, Datastores, etc.), this may be enough to discover hosts via vCenter, but could result in a discovery malfunction in case of direct connection to ESX host.

I beleive our support team should help you with this issue. Try to collect as much information as you have (colelctor logs, event logs) along with detailed information about your configuration and send it to our support team. We have excellent professionals there.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Mon Mar 11, 2013 5:55 pm

Hi Sergey ,

Thank you for your reply , I'm using the root account to connect to the ESX Hosts and I'm not receiving any errors or warning in the activity logs.

I will try connecting only these 2 hosts and will get back to you with the feedback.
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Tue Mar 12, 2013 7:15 am

I added only those 2 ESX hosts and its showing in scom in nworks collector commection state as both healthy but still not showing in ESX hosts. and no errors in the log and permission for the account is root.
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby sergey.g » Tue Mar 12, 2013 7:27 am

Hi Saeid,

Could you check the topology.xml file in the collector logs folder? If you have these servers and VMs from them in the topology file there really should not be any obstacles for SCOM to discover them. If you don't have them in topology.xml - this means that there is an issue with connecting to ESX, in this case I would recommend you to open a support ticket, we should be able to analyze all necessary logs from your collector server to find the root cause.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Tue Mar 12, 2013 7:33 am

Just checked topplogy.xml and they are both there with information.
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby sergey.g » Tue Mar 12, 2013 7:58 am

Hi Saeid,

In this case something should be happening with SCOM Agent when it tries to process the topology file. Could you do the following:

1. Restart the collector service
2. Wait for Event with 70 ID in the nworks event log.
3. Check Operations Manager event log for any issues reported by it.

Could you also let us know why you need to connect to those ESX hosts directly if there is a vCenter option? Connection via vCenter is more reliable provides way more information, doesn't require root access to all server or maintaining dedicated collection account on each server and also vCenter connection is highly scalable, any new host added to vCenter will be automatically monitored by our product.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Tue Mar 12, 2013 8:25 am

I got event id 70 and did not get any errors. yet they are not showing in SCOM the hosts. we prefere connecting to hosts for availability issues.

if you can help furthermore it will be appreciated.
Thank you
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby sergey.g » Tue Mar 12, 2013 8:44 am

Hi Saeid,

First of all, this is really strange issue, not something we see from time to time during the deployment.
Secondly, I'm afraid I wasn't clear enough in my last message - you need to check Operations Manager log on the collector service, not on the server, although I would check both, but you've already checked one, so please - make sure you've checked the agent log. Could you also check that you have ID:999 event in this SCOM agent log? If you have it - let us know what's in it.

Also it would help us if you can do "Export Logs" in the nworks UI (Help menu) and send us the bundle it produces, you can send it via direct message in this forum.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Tue Mar 12, 2013 9:31 am

I already checked both logs collector and scom , regarding ID 999 it shows 2 api connections discovered , 0 hosts discovered. 0 datastore And 0 cluster.
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby sergey.g » Tue Mar 12, 2013 9:39 am

Hi Saeid,

In this case something wrong with topology which has been collected from ESX servers and we need full bundle of files located in the collector logs folder. As I mentioned previously you can get the whole bundle directly in the UI with "Export Logs" function.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Wed Mar 13, 2013 9:05 am

this is the log and the same message is just repeating

2013-03-13 09:27:08.928 [0009] INFO CM Poll from REP.removed.com. ID: 0
2013-03-13 09:27:08.933 [0009] INFO CM Getting TopoNow option value for collector ID 0: False
2013-03-13 09:28:08.933 [0009] INFO CM Poll from REP.removed.com. ID: 0
2013-03-13 09:28:08.939 [0009] INFO CM Getting TopoNow option value for collector ID 0: False
2013-03-13 09:29:08.933 [0009] INFO CM Poll from REP.removed.com. ID: 0
2013-03-13 09:29:08.939 [0009] INFO CM Getting TopoNow option value for collector ID 0: False
2013-03-13 09:30:08.936 [0009] INFO CM Poll from REP.removed.com. ID: 0
2013-03-13 09:30:08.941 [0009] INFO CM Getting TopoNow option value for collector ID 0: False
2013-03-13 09:31:08.957 [0009] INFO CM Poll from REP.removed.com. ID: 0
2013-03-13 09:31:08.962 [0009] INFO CM Getting TopoNow option value for collector ID 0: False
2013-03-13 09:32:08.976 [0009] INFO CM Poll from REP.removed.com. ID: 0
2013-03-13 09:32:08.982 [0009] INFO CM Getting TopoNow option value for collector ID 0: False
2013-03-13 09:32:51.194 [0004] INFO IMon Query 100.50.2.105 for changes.
2013-03-13 09:32:51.194 [0008] INFO IMon Query 100.50.2.106 for changes.
2013-03-13 09:32:51.203 [0004] WARN SS25 Skip SSL error with certificate: RemoteCertificateNameMismatch, RemoteCertificateChainErrors
2013-03-13 09:32:51.203 [0008] WARN SS25 Skip SSL error with certificate: RemoteCertificateNameMismatch, RemoteCertificateChainErrors
2013-03-13 09:32:51.563 [0008] INFO ViT VMware server: "100.50.2.106".
Cluster: "ESX05.removed.com". MOR: ha-compute-res.
ESX: "ESX05.removed.com". MOR: ha-host. CpuPakages: 4.

2013-03-13 09:32:51.563 [0004] INFO ViT VMware server: "100.50.2.105".
Cluster: "ESX04.removed.com". MOR: ha-compute-res.
ESX: "ESX04.removed.com". MOR: ha-host. CpuPakages: 4.
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Re: Some ESX Hosts not discovered

Veeam Logoby sergey.g » Wed Mar 13, 2013 10:48 am

Hi Saeid,

I'm afraid we need more information, we can't see what exactly doesn't work using this section of the log. Try restarting the collector server, then send the full vmspi log file to us.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Some ESX Hosts not discovered

Veeam Logoby Yan Skoursky » Tue Mar 26, 2013 11:34 am

Hi Saeid,

Your hosts have upper-case letters in the name, please check this link http://cp.veeam.com/knowledgebase/article/KB1655

Thanks.
Yan Skoursky
Novice
 
Posts: 7
Liked: never
Joined: Tue Apr 26, 2011 2:12 pm

Re: Some ESX Hosts not discovered

Veeam Logoby SaeidJ » Wed Mar 27, 2013 5:35 am

Thanks for the reply. I dropped the ESX Host idea already and connected to the vCenter.
but now the issue is that not all the VMs' performance can be monitored
SaeidJ
Novice
 
Posts: 8
Liked: never
Joined: Mon Mar 11, 2013 9:15 am
Full Name: Saeid J

Next

Return to Veeam Management Pack for Microsoft System Center



Who is online

Users browsing this forum: No registered users and 3 guests