Veeam Backup MP

Unleash the power of System Center for vSphere and Hyper-V | Veeam Task Manager for Hyper-V

Veeam Backup MP

Veeam Logoby felyjos » Thu Oct 31, 2013 3:01 pm

Hello,

I trying to run the Veeam Backup reports from the MP in SCOM.

Veeam Backup is version 7.0

Veeam Backup MP 6.5.0.1549

any incompatibilty?

- Capacity Planning. Protected VMs, Top/Bottom Backup Proxies are okay

- Backup and Replication Status is failing with the following error:

An error has occurred during report processing.
Query execution failed for dataset "AnalysisDS'
The EXECUTE permission was denied on the object 'Veeam_Backup_BRJobStatusGet', database 'OperationsManagerDW', schema 'dbo'.

The Backup Copy Job Overview is failing with another error:
an error occurred during report processing

any idea?

Thanks,
Dom
System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN

Re: Veeam Backup MP

Veeam Logoby Vitaliy S. » Thu Oct 31, 2013 6:45 pm 1 person likes this post

Hi Dom,

felyjos wrote:Veeam Backup is version 7.0

Veeam Backup MP 6.5.0.1549

any incompatibilty?

Actually this is the only supported configuration. Veeam MP for backup supports only Veeam B&R v7.

felyjos wrote:- Backup and Replication Status is failing with the following error:

An error has occurred during report processing.
Query execution failed for dataset "AnalysisDS'
The EXECUTE permission was denied on the object 'Veeam_Backup_BRJobStatusGet', database 'OperationsManagerDW', schema 'dbo'.

The Backup Copy Job Overview is failing with another error:
an error occurred during report processing

What about other parts of the MP? Job Views etc? Does everything work? Do you have a case ID, so I could check the reason of the failures with the dev team?

Thanks!
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Veeam Backup MP

Veeam Logoby Vitaliy S. » Thu Oct 31, 2013 7:45 pm 1 person likes this post

BTW, can you please tell me how much time did pass since Backup MP has been deployed? Do you have any data in the Reporting warehouse yet? Also can you please confirm that Veeam MP was deployed successfully with no errors in Operations Manager log?
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Veeam Backup MP

Veeam Logoby felyjos » Fri Nov 01, 2013 12:41 am

Hello Vitaly,

"What about other parts of the MP? Job Views etc? Does everything work? Do you have a case ID, so I could check the reason of the failures with the dev team?"

Other parts seem working fine Vies, Jobs etc... no ticket opened yet as I have already two on-going!!! Veeam Backup and Veeam One...

Thanks,
Dom
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN

Re: Veeam Backup MP

Veeam Logoby felyjos » Fri Nov 01, 2013 12:46 am

can you please tell me how much time did pass since Backup MP has been deployed? Do you have any data in the Reporting warehouse yet? Also can you please confirm that Veeam MP was deployed successfully with no errors in Operations Manager log?
Veeam Backup MP installed last week 10/24
Other reports are showing data do you have a specific to check?
Let me review the operation log again
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN

Re: Veeam Backup MP

Veeam Logoby Vitaliy S. » Fri Nov 01, 2013 9:14 am 1 person likes this post

Dom,

felyjos wrote:Veeam Backup MP installed last week 10/24

Ok, thanks! This time period is enough to have some data in all reports.
felyjos wrote:Other reports are showing data do you have a specific to check?

It was just a health check. If other reports show the correct data, then it must be something with these particular ones.
felyjos wrote:Let me review the operation log again

If you do not see any errors, then contact our technical team for further investigation.

Also I would check the permissions for the dataset in question. Here is a similar example of how to do that.

Thank you!
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Veeam Backup MP

Veeam Logoby Alec King » Fri Nov 01, 2013 9:16 am 1 person likes this post

Dom,

Could you also confirm your version of SCOM, and especially your version of SQL server?

Thanks
Alec
Alec King
Veeam Software
 
Posts: 700
Liked: 116 times
Joined: Sun Jan 01, 2006 1:01 am

Re: Veeam Backup MP

Veeam Logoby felyjos » Fri Nov 01, 2013 12:06 pm

Vitaly, Alec,

SCOM 2007 R2 - 6.1.7221.110
Windows Server 2008 Enterprise Service Pack 2 - 6.0.6001.18005
SQL Server 2008 SP1 - 10.0.2531

Thanks,
Dom
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN

Re: Veeam Backup MP

Veeam Logoby sergey.g » Fri Nov 01, 2013 1:42 pm 1 person likes this post

Ho Dom,

Thank you very much for this information, we think we are getting closer to the root cause.

Is it possible that you are runing failing reports from within SCOM console which is launched under account with weaker permissions? Also could you check that Protected VMs report correctly display VMs which really have backups?

Also could you please try to run Verified VMs report and let me know if you encounter same error as with B&R Status?

This looks like something weird thing with your SQL permissions or SQL schemas, and I'm afraid this issue will require additional investigation, we might need to check SQL profiler and run some troubleshooting queries.

But first, your help with questions above would be highly appreciated.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Veeam Backup MP

Veeam Logoby felyjos » Fri Nov 01, 2013 5:34 pm

Hello,

"Is it possible that you are runing failing reports from within SCOM console which is launched under account with weaker permissions?"
- Which account is supposed to be used for the VeeamBackup reports? Is it a Veeam Account? a SCOM Account?
- Which permissions it should have?

"Also could you check that Protected VMs report correctly display VMs which really have backups?"
- Protected VMs report is working but reporting all VMs as unprotected...
Unprotected (754)
No Backup (754)
No RestorePoints (754)

"Also could you please try to run Verified VMs report and let me know if you encounter same error as with B&R Status?"
- Yes Same error ...
An error occured during report processing
Query execution failed for dataset 'AnalysisDS'
The EXECUTE permission was denied on the object 'Veeam_Backup_VmsVerification', database 'OperationsManagerDW', schema 'dbo'

This looks like something weird thing with your SQL permissions or SQL schemas, and I'm afraid this issue will require additional investigation, we might need to check SQL profiler and run some troubleshooting queries.
- It is okay to run SQL Profiler after we verified we have the correct account in question 1.

Thanks,
Dom
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN

Re: Veeam Backup MP

Veeam Logoby felyjos » Sat Nov 02, 2013 7:28 pm

Hello,

Last question:
if it is SQL Permissions
Which database is involved? OperationsManagerDW? OperationsManager? vSphere41?
Which account? MomDatawarehouseAccount? MomActionAccount? a Veeam account?

Thanks,
Dom
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN

Re: Veeam Backup MP

Veeam Logoby sergey.g » Sat Nov 02, 2013 7:44 pm 1 person likes this post

Hi Dom,

We think something strange is happening with your configuration. We need specifi permissions for running SQl stored procedures in OperationsManagerDW database and these permissions should be applied during the MP deployment, but the fact that some of you reports are working means that necessary permissions are there. We think that there is a differences in how and which SPs are called from certain reports and looks like this is causing an issue in your environment.

We really appreciate all of your help with the issue and your patience. We've built those reports to work, not to produce errors and we think we understand the root cause of these errors. We need some time to understand how to quickly solve the issue for you and then we'll investigate what happened in your environment.

The specific permission that is required is "Execute" for all Veeam Backup stored procedures (Veeam_Backup_BRJobStatusGet for instance). We think that if you are runing reports under database admin - everything should work for your environment.

I'll update your with more details.

Thanks.
sergey.g
Veeam Software
 
Posts: 453
Liked: 75 times
Joined: Wed May 02, 2012 1:49 pm
Full Name: Sergey Goncharenko

Re: Veeam Backup MP

Veeam Logoby Vitaliy S. » Sun Nov 03, 2013 9:26 am

Dom, also please include your support case ID, as it is required by our forum rules. Thanks.
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Veeam Backup MP

Veeam Logoby felyjos » Sun Nov 03, 2013 5:40 pm 1 person likes this post

Vitaly,

Case Number just opened:
00471238

Thanks,
DOm
felyjos
Expert
 
Posts: 285
Liked: 3 times
Joined: Wed Jun 08, 2011 5:46 pm
Full Name: Dominique DUCHEMIN


Return to Veeam Management Pack for Microsoft System Center



Who is online

Users browsing this forum: No registered users and 3 guests