Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V
Post Reply
bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

installation error V1 ver 11

Post by bkain1 »

if you look at Case #04751535 — win 32 error on install, you'll see that when you install V1 ver 11 not as the "run as" service account, but as a person, the install goes almost all the through, then fails with a win32 error. When I went to rerun the install as the service account, I can't, because the permissions of the service account, as defined here "https://helpcenter.veeam.com/docs/one/d ... ml?ver=110" does not give that account "delete" permissions" just create so I have to wait for a SQL admin to swing by and delete the database so I can redo the install. I'd like to report this as a bug. thanks

becki kain

wishr
Veeam Software
Posts: 2468
Liked: 322 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: installation error V1 ver 11

Post by wishr »

Hi Becki,

Delete permissions on the SQL database are not required for installing Veeam ONE regardless of whether it's a clean installation or installation on top of an existing database.

I would recommend reporting all bugs/issues directly to our support team as this is the only way we can collect all the required information to fix them. Currently, it's unclear from the support case what was the root cause and why that happened. You may escalate the case and ask engineers for diving deeper into the issue when required.

Thanks

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 »

as I said in the case, installing as the proxy account solved the issue, 2 weeks ago. Now I have a new backend SQL box and I'm trying the install again and it's failing the same way, even when installing as the proxy account. I'll try with a new iso and if i get the same error, i'll open a new support case.

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 » 1 person likes this post

case is Case #04772750 with images from the error

wishr
Veeam Software
Posts: 2468
Liked: 322 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: installation error V1 ver 11

Post by wishr »

Hi Becki,

Thanks for sharing the case ID. Let's see what our tech. support engineers will find out.

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 »

so far, only that they thought my back end box was part of an HA pair, which it's not

wishr
Veeam Software
Posts: 2468
Liked: 322 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: installation error V1 ver 11

Post by wishr »

I've pinged our support managers to make sure your case gets the required level of attention. Keep in mind that you also have the ability to escalate the case to T2-T3 by pressing the "Talk to manager" button.

Thanks

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 »

Can there be two different accounts, one that is the "run as" (service account) for VeeamOne and one that is for connecting to the back end SQL? I'm trying to install with the second one for "SQL server auth" in the install, where we were using "use windows auth", in our version 10 install. I don't see, in the required permissions list here - https://helpcenter.veeam.com/docs/one/d ... ml?ver=110, that the permissions for the VeeamOne service account are anything more than being in local administrators and the instructions are not clear if these are two different accounts.

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 »

i did open it as sev 3 too. Ian said he can meet with me tomorrow at 3:30, at the earliest.

wishr
Veeam Software
Posts: 2468
Liked: 322 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: installation error V1 ver 11

Post by wishr »

As you can see from this page, SQL database account permissions and VONE service account permissions are different. It's up to you whether these permissions should be assigned to the same account or not. However, according to security best practices (SoD), these should be two different independent accounts.

Please, try launching the setup on behalf of the service account and then specify SQL database account when the setup will ask you for database credentials. If that does not work, the best bet would be to let our tech. support engineers check what's going on there during a call.

Thanks

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 »

i did do that, and it failed. I tried the install as me, $me, the veeam one service account, the sql veeam one account, everything. Because we have to use windows auth, for sql, there is no way to have two different accounts. I closed the ticket with Veeam Support

wishr
Veeam Software
Posts: 2468
Liked: 322 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: installation error V1 ver 11

Post by wishr »

Thank you for the update.

This is expected with windows authentication as it means that the service account you used to run the setup will be used for authenticating in the database. Since your service account did not have these permissions, it was impossible to do so. If you would like to use separate accounts, you should select SQL server authentication option and specify the credentials for SQL database-specific account for authenticating via SQL server authentication mode.

Anyway, glad to see it is resolved now.

bkain1
Expert
Posts: 120
Liked: 7 times
Joined: Dec 23, 2020 4:43 pm
Full Name: Becki Kain
Contact:

Re: installation error V1 ver 11

Post by bkain1 » 1 person likes this post

Within Ford, I can't do that, the way SQL is set up. I don't know why it's set up that way. I guess any database created after a box is built gets the same recovery mode as "model" database, which is FULL and the veeam sql account didn't have enough permissions to change it either, to SIMPLE, in the installation.

In the end,it was an experiment to install V1 version 11 with an account with greatly reduced permissions. And I'm getting a crash course in SQL

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests