Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V
jtweath
Novice
Posts: 7
Liked: 1 time
Joined: Jul 21, 2015 7:03 pm
Full Name: Jay W
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by jtweath » Jul 27, 2015 3:33 pm

Has anybody been able to successfully get the automated services to work via batch files/scripts?

Vitaliy S.
Veeam Software
Posts: 21543
Liked: 1283 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Vitaliy S. » Jul 27, 2015 4:58 pm

Jay, do you still have this problem with scripts not being triggered? What did your support engineer say on this?

jtweath
Novice
Posts: 7
Liked: 1 time
Joined: Jul 21, 2015 7:03 pm
Full Name: Jay W
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by jtweath » Jul 28, 2015 2:25 pm

Vitaliy S. wrote:Jay, do you still have this problem with scripts not being triggered? What did your support engineer say on this?
This issue has not been resolved. My support engineer said they are testing it within their lab.

Shestakov
Veeam Software
Posts: 5970
Liked: 521 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Shestakov » Aug 22, 2015 8:44 pm

Hello Jay, could you provide your support case number for us to follow the investigation? Thanks

Vitaliy S.
Veeam Software
Posts: 21543
Liked: 1283 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Vitaliy S. » Aug 23, 2015 6:29 pm

Nikita, it's this one # 00975173.

john.wood
Service Provider
Posts: 21
Liked: 2 times
Joined: Nov 21, 2016 10:00 pm
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by john.wood » Mar 28, 2017 9:13 pm

The scripts seem to be unavailable. Is there another location to access the scripts from?
VMCE

Vitaliy S.
Veeam Software
Posts: 21543
Liked: 1283 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Vitaliy S. » Mar 29, 2017 11:54 am

Hi John,

This his link. Meanwhile I will ask our support team to create a KB for that.

Thanks!

Vitaliy S.
Veeam Software
Posts: 21543
Liked: 1283 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Vitaliy S. » Mar 30, 2017 8:41 pm

Quick update! We've decided to create a dedicated KB article due to large number of requests for these scripts: https://www.veeam.com/kb2270

john.wood
Service Provider
Posts: 21
Liked: 2 times
Joined: Nov 21, 2016 10:00 pm
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by john.wood » Jul 23, 2017 11:48 pm

Hi,

Anyone else getting an issue for the VMs with No backup.

The batch script that is executed from VeeamOne populates the VMswithNoBackups.txt with a "Echo is On"

I've modified the batch script with @ECHO Off but it isnt passing the Vm Object name into the txt file.

Regards

John
VMCE

john.wood
Service Provider
Posts: 21
Liked: 2 times
Joined: Nov 21, 2016 10:00 pm
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by john.wood » Jul 24, 2017 4:49 am 1 person likes this post

Found the answer.

It doesn't really explain that you need to pass the parameters from the alarm in the script field.

For anyone looking the script field needs to pass the %2 "c:\scripts\01.VMswithNoBackups.bat %2"
VMCE

Shestakov
Veeam Software
Posts: 5970
Liked: 521 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Shestakov » Jul 24, 2017 9:55 am

We are working on alarms automation feature for the next releases, so if you have any feedback, requests, please let us know.
Thanks!

lahad
Novice
Posts: 3
Liked: 1 time
Joined: Nov 29, 2017 9:42 pm
Full Name: Abdou Lahad SYLLA
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by lahad » Dec 02, 2017 7:28 pm

Hello everyone,
I am doing test for my thesis with Veeam ONE.
But when I try to run the 02.TerminateJobAfterXhours scripts, 04.AutoFailover, 03.Orphaned_snapshots I have these following errors:

Le terme «Get-VBRJob» is not recognized as a cmdlet name, function, script file, or executable program. Check the spelling of the name,
or if a path exists, check that the path is correct and try again.
+ CategoryInfo : ObjectNotFound: (Get-VBRJob:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException
+ PSComputerName : localhost
+ PSComputerName : localhost





add-pssnapin :No snap-ins have been registered for Windows PowerShell version 4.
Au caractère C:\Scripts\03.Orphaned_snapshots.ps1:6 : 1
+ add-pssnapin VMware.VimAutomation.Core
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidArgument : (VMware.VimAutomation.Core:String) [Add-PSSnapin], PSArgumentException
+ FullyQualifiedErrorId : AddPSSnapInRead,Microsoft.PowerShell.Commands.AddPSSnapinCommand


Set-PowerCLIConfiguration : The term "Set-PowerCLIConfiguration" is not recognized as a cmdlet name, function, script file, or program
executable. Check the spelling of the name, or if a path exists, check that the path is correct and try again.
Au caractère C:\Scripts\03.Orphaned_snapshots.ps1:7 : 1
+ Set-PowerCLIConfiguration -InvalidCertificateAction Ignore -WarningAction Silent ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (Set-PowerCLIConfiguration:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException


Can someone help me

lahad
Novice
Posts: 3
Liked: 1 time
Joined: Nov 29, 2017 9:42 pm
Full Name: Abdou Lahad SYLLA
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by lahad » Dec 03, 2017 7:25 pm

Thanks finally I was able to fix the errors by adding the Veeam cmd applet and installing PowerCLi from VMware.
But I still have the following error for the script:

Can not validate the argument on the "Job" parameter. The argument is null. Specify a valid value for the argument and try again.
     + CategoryInfo: InvalidData: (:) [Stop-VBRJob], ParameterBindingValidationException
     + FullyQualifiedErrorId: ParameterArgumentValidationError, Veeam.Backup.PowerShell.Cmdlets.StopVBRJob
     + PSComputerName: localhost

Vitaliy S.
Veeam Software
Posts: 21543
Liked: 1283 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by Vitaliy S. » Dec 04, 2017 10:50 am

Abdou, what job name do you set as a part of the script? It seems like the parameter is not specified, that's why you see this error message.

lahad
Novice
Posts: 3
Liked: 1 time
Joined: Nov 29, 2017 9:42 pm
Full Name: Abdou Lahad SYLLA
Contact:

Re: ONEbelievable tricks: Veeam ONE and Automation Services

Post by lahad » Dec 07, 2017 8:42 pm 1 person likes this post

Thank you Vitaliy, your help allowed me to solve the problem.
In fact I had not given the right argument on the parameters #jobname.

It's works!

Post Reply

Who is online

Users browsing this forum: Bing [Bot], mamadou.bah and 6 guests