Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V
Post Reply
pirx
Expert
Posts: 128
Liked: 12 times
Joined: Dec 20, 2015 6:24 pm
Contact:

Tag collection broken?

Post by pirx »

Hi,

#04473149

We are having problems with collecting tags by VeeamOne from vCenter (6.7). Support asked me to try a regkey that changes the collection method to powershell, but this doesn't work either. I tested Get-TagAssignment in powershell and it's broken. Get-Tag is working fine. Get-TagAssignment is working if I use a script that is only collecting a small bunch of tags. Seems this tag stuff is broken for some time in vSphere [1], I changed the vmware-vapi-endpoint value, no difference either. I've a case open at VMware too, without anything useful other than they have lost my uploaded logs. Is the root cause that collecting tags is not working with native Veeam method and powershell method the same? Is this a known problem with VeeamOne? For me it seems that this problem does exist for some time in vSphere, I was surprised that I did not find anything here in the forum.

[1] https://communities.vmware.com/t5/VMwar ... rue#M10704

Vitaliy S.
Product Manager
Posts: 24566
Liked: 1979 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Tag collection broken?

Post by Vitaliy S. »

Hi pirx,

Yes, this is not a known issue for Veeam ONE. To isolate the problem, can you please double-check if you can use tags from vSphere using Veeam B&R when configuring a new backup job?

Thanks!

pirx
Expert
Posts: 128
Liked: 12 times
Joined: Dec 20, 2015 6:24 pm
Contact:

Re: Tag collection broken?

Post by pirx » 1 person likes this post

After deleting all tags in vCenter that were created by Veeam One, Get-TagAssignment and data collection is now working again. At the moment I cannot reproduce the problem, finally light at the end of the tunnel after chasing this so many weeks :)

Vitaliy S.
Product Manager
Posts: 24566
Liked: 1979 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Tag collection broken?

Post by Vitaliy S. »

Ah, good! We could not reproduce it either; thus, I've wanted to verify how tags collection is done via VBR. Good to know that it is now working for you again!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest