Time difference too large when trying to install

Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V

Time difference too large when trying to install

Veeam Logoby tholyoak » Thu Nov 01, 2012 5:40 pm

We just bought the Essentials bundle, and I downloaded Veeam ONE and am attempting to install it. I'm getting an error message when I try to connect to the vCenter Server that says "Time difference between Veeam service host and VC host is too large. Please make sure remote and local time is in sync. Consider using NTP."

I just checked the 3 hosts that are connected to vCenter, and set up NTP on them. They're all within a couple minutes of the Windows server I'm trying to install Veeam ONE on. I can't seem to figure out what the problem is? I do notice that the "Recent Tasks" pane in vCenter has timestamps that appear to be in UTC time (about 7 hours different from us).
tholyoak
Influencer
 
Posts: 24
Liked: never
Joined: Wed Sep 12, 2012 5:12 pm

Re: Time difference too large when trying to install

Veeam Logoby Vitaly.Mzokov » Thu Nov 01, 2012 5:52 pm

Hello,

Veeam ONE v6 can have not more than 10 minutes time difference between Veeam ONE Server and ESX(I) hosts. Looks like you've got incorrect date/time configuration somewhere within your vCenter server. Check out host's "Configuration" -> "Time Configuration" section and make sure it has correct date/time settings.

Let me now if it does not help.

-VM.
Vitaly.Mzokov
Expert
 
Posts: 173
Liked: 25 times
Joined: Mon Aug 23, 2010 8:30 am
Full Name: Vitaliy Mzokov

Re: Time difference too large when trying to install

Veeam Logoby tholyoak » Thu Nov 01, 2012 9:27 pm

That is what I have done. It didn't make any difference.
tholyoak
Influencer
 
Posts: 24
Liked: never
Joined: Wed Sep 12, 2012 5:12 pm

Re: Time difference too large when trying to install

Veeam Logoby Vitaliy S. » Thu Nov 01, 2012 9:39 pm

What about the Windows machine where vCenter Server is deployed? What time zone do you have there?
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Time difference too large when trying to install

Veeam Logoby Vitaly.Mzokov » Thu Nov 01, 2012 9:43 pm

tholyoak wrote:That is what I have done. It didn't make any difference.

Well, it's really hard to investigate or troubleshoot the problem via Community Forums. I would recommend you opening a support case with our technical team then, so we can take a further look at your problem online and get it resolved quickly.

-VM.
Vitaly.Mzokov
Expert
 
Posts: 173
Liked: 25 times
Joined: Mon Aug 23, 2010 8:30 am
Full Name: Vitaliy Mzokov

Re: Time difference too large when trying to install

Veeam Logoby Vitaly.Mzokov » Thu Nov 01, 2012 9:54 pm

tholyoak wrote:I do notice that the "Recent Tasks" pane in vCenter has timestamps that appear to be in UTC time (about 7 hours different from us).

Also, could you please try opening a vSphere Client from a machine where you have Veeam ONE deployed, and then check host's "Time configuration" section once again? VMware always translates host's time values into the local time of currently running vSphere client.

Let me know what you find out.

-VM.
Vitaly.Mzokov
Expert
 
Posts: 173
Liked: 25 times
Joined: Mon Aug 23, 2010 8:30 am
Full Name: Vitaliy Mzokov

Re: Time difference too large when trying to install

Veeam Logoby tholyoak » Fri Nov 02, 2012 11:19 pm

I've rechecked, and everything looks good. And the vCenter appliance and the Windows server where I'm trying to install Veeam ONE are actually on the *same* host...
tholyoak
Influencer
 
Posts: 24
Liked: never
Joined: Wed Sep 12, 2012 5:12 pm

Re: Time difference too large when trying to install

Veeam Logoby Vitaly.Mzokov » Sat Nov 03, 2012 12:02 am

Hm...Looks very strange to me, as in most cases I've seen with that type of issue all the problems were related to improper time configuration on VMware host. As for now, I've got only one idea for you => change the default timeout (which I have already mentioned above) to work around this issue:

    1) Install Veeam ONE v6 without adding a Virtual Server. Simply skip that step.
    2) Once done, on Veeam ONE machine open Registry Editor and navigate to this key:
    Code: Select all
    HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam ONE Monitor\Service
    3) Create a new DWORD value with the following parameters:
    Code: Select all
    Value name = MaxTimeDiff
    Value data (in DECIMAL format) = 43200
    This will set maximum time difference timeout to 12 hours. According to your first post, that would be more than enough.
    4) Restart Veeam ONE Monitor Server service and try to add a vCenter Server into Veeam ONE configuration one again.

On top of that, I would strongly recommend you contacting our support team, so we can assist you online.

-VM.
Vitaly.Mzokov
Expert
 
Posts: 173
Liked: 25 times
Joined: Mon Aug 23, 2010 8:30 am
Full Name: Vitaliy Mzokov

Re: Time difference too large when trying to install

Veeam Logoby Vitaly.Mzokov » Sat Nov 03, 2012 12:08 am

And on a side note, since you do not have any data inside current Veeam ONE instance, why not to deploy a brand new Veeam ONE v6.5.
It will not cost you even a cent/penny/euro :) See product's page for more details.

-VM.
Vitaly.Mzokov
Expert
 
Posts: 173
Liked: 25 times
Joined: Mon Aug 23, 2010 8:30 am
Full Name: Vitaliy Mzokov

Re: Time difference too large when trying to install

Veeam Logoby tholyoak » Mon Nov 05, 2012 9:39 pm

Thanks, the registry change allowed me to add it.

Incidentally, this was actually version 6.5. Sorry I didn't mention that to begin with. :)
tholyoak
Influencer
 
Posts: 24
Liked: never
Joined: Wed Sep 12, 2012 5:12 pm


Return to Veeam ONE



Who is online

Users browsing this forum: Bing [Bot], max.che and 9 guests