Simplify and orchestrate VPN networking and configuration tasks.
Post Reply
LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

Hi,

I have received the following error several times while trying to deploy the Veeam PN Network Hub in Microsoft Azure: The virtual machine reported an error processing the "LinuxCSExtension" Extension. I have created a new resource group in Europe, West. Does anyone know the problem or a solution?

HannesK
Veeam Software
Posts: 6068
Liked: 876 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by HannesK »

Hello,
and welcome to the forums.

I just tried it out and I get the same error. The VM is running and I can login with SSH. I also see errors in /var/log/Veeam/veeampn/azure_init.log - I need to check why they exist. That can take some time...

As workaround I did the following:
- login to the machine with SSH
- add the missing GPG key

Code: Select all

curl -L https://packages.microsoft.com/keys/microsoft.asc | sudo apt-key add –
apt update
apt upgrade
- follow the installation process https://helpcenter.veeam.com/docs/veeam ... tml?ver=21


Best regards,
Hannes

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

Hi and Thanks for the answer,

the veeamadmin user does not have the necessary rights. Do I need the root user? if yes, where can I find the password?

HannesK
Veeam Software
Posts: 6068
Liked: 876 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by HannesK »

Code: Select all

sudo su
the password is the one from deployment process

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

I have benn loged in withe the User who was generated at the deployment process an i got the following Errors:

login as: veeamadmin
veeamadmin@10.0.0.4's password:

veeamadmin@veeampn:~$ curl -L https://packages.microsoft.com/keys/microsoft.asc | sudo su apt-key add – No passwd entry for user 'apt-key'
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 983 100 983 0 0 11430 0 --:--:-- --:--:-- --:--:-- 11564
(23) Failed writing body
veeamadmin@veeampn:~$ curl -L https://packages.microsoft.com/keys/microsoft.asc | sudo apt-key add –
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 983 100 983 0 0 37807 0 --:--:-- --:--:-- --:--:-- 37807
gpg: can't open '–': No such file or directory

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

Hi Hannes,

it works. I change the User with sudo su root...

Thanks

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

Hi Hannes,

now i miss the azure Setup in the Network Hub. Can you help me?

HannesK
Veeam Software
Posts: 6068
Liked: 876 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by HannesK »

the user guide should be able to help you... https://helpcenter.veeam.com/docs/veeam ... tml?ver=21

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

After the Login in the Network Hub there is no Azure Setup wizard. So I have to configure Azure manually. In the User Guide is no Section how to do that...

HannesK
Veeam Software
Posts: 6068
Liked: 876 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by HannesK »

good point... are you trying to configure client-to site or site-to-site VPN?

For client-to-site, I don't believe that the Azure Setup is required (I have not seen it and my setup works). The only thing you need is adding the Azure network as HUB-site (veeam-tools-for-microsoft-azure-f36/rem ... ml#p365195)

For site-to-site: I remember when I installed OpenVPN manually some time ago, there I had to add the on-prem network in the Azure route table

Image

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

Now i can reache the onprem network from Azure:

C:\Users\adminazr>tracert 192.168.170.53
Tracing route to 192.168.170.53 over a maximum of 30 hops
1 1 ms <1 ms <1 ms 10.0.0.4
2 * * * Request timed out.
3 18 ms 17 ms 19 ms 192.168.170.53

But i can not reach the Azure network from onprem

C:\Users\stefa>tracert 10.0.0.5
Routenverfolgung zu 10.0.0.5 über maximal 30 Hops
1 1 ms 1 ms 1 ms fritz.box [192.168.170.1]
2 fritz.box [192.168.170.1] meldet: Zielhost nicht erreichbar.
Ablaufverfolgung beendet.

I have set the required route on the default gateway [192.168.170.1]. I have the same behavior on two sides. The Network Hub on Azure works properly. How can that be?

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

I think the Veeam PN appliance onprem sends the ping back to the default gateway in the network...

AVasilyev
Veeam Software
Posts: 70
Liked: 14 times
Joined: Jan 01, 2006 1:01 am
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by AVasilyev »

Dear all,

please hold on for day or so more - we pushed an updated version of installation script to Azure Marketplace, hopefully it is going to be updated early next week.

AVasilyev
Veeam Software
Posts: 70
Liked: 14 times
Joined: Jan 01, 2006 1:01 am
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by AVasilyev »

To reach Azure-located servers from onprem you should add a special client type "HUB site" as it is explained here: https://helpcenter.veeam.com/docs/veeam ... tml?ver=21

Also make sure that VeeamPN appliance is installed in the same network as your Azure-located servers.

HannesK
Veeam Software
Posts: 6068
Liked: 876 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by HannesK »

I just tried a deployment in Europe west and it worked fine including the Azure setup wizard

LutzSte
Novice
Posts: 9
Liked: never
Joined: Mar 26, 2020 6:59 pm
Full Name: Stefan Lutz
Contact:

Re: Network Hub deployment in Microsoft Azure fails

Post by LutzSte »

I deployed the Azure VeeamPN again and it works. But there is no option to add a client type "HUB site"

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest