Direct Restore to Microsoft Azure | VeeamPN software-defined networking
Post Reply
f0st3r
Novice
Posts: 7
Liked: never
Joined: Aug 26, 2016 2:45 pm
Full Name: Bryan Foster
Contact:

Veeam PN in Azure deployment failed

Post by f0st3r » May 31, 2017 7:26 pm

I have tried deploying the Veeam PN appliance in azure several times and keep getting the same failure(See Below). I have tried different billing models(except Credit Card), data centers, etc. Any ideas?

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.","details":[{"code":"BadRequest","message":"{\r\n \"error\": {\r\n \"code\": \"ResourcePurchaseValidationFailed\",\r\n \"message\": \"User failed validation to purchase resources. Error message: '{\\\"ErrorDescription\\\":\\\"[\\\\\\\"CustomerDeniedServicePlanAccess The Offer is not sold in the account market (US).\\\\\\\"]\\\",\\\"CultureInvariantErrorCode\\\":\\\"BadRequest\\\",\\\"ActivityId\\\":\\\"\\\"}'\"\r\n }\r\n}"}]}

Mike Resseler
Product Manager
Posts: 5597
Liked: 585 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Veeam PN in Azure deployment failed

Post by Mike Resseler » Jun 01, 2017 3:34 am

Hi Bryan,

First: Welcome to the forums

From the error message it seems that for some reason you can not purchase it with your billing model. It actually looks like the offer is not available in your market but since it says US as a market that seems not correct.

Are you using a dreamspark subscription?

Mike Resseler
Product Manager
Posts: 5597
Liked: 585 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Veeam PN in Azure deployment failed

Post by Mike Resseler » Jun 01, 2017 10:06 am

Hi Bryan,

It seems there is something else wrong. Probably after republishing the appliance (after request of Microsoft) something must have failed. Our teams will investigate what is wrong

Sorry about this

Mike

f0st3r
Novice
Posts: 7
Liked: never
Joined: Aug 26, 2016 2:45 pm
Full Name: Bryan Foster
Contact:

Re: Veeam PN in Azure deployment failed

Post by f0st3r » Jun 01, 2017 11:03 am

Thanks Mike.

AVasilyev
Veeam Software
Posts: 57
Liked: 12 times
Joined: Jan 01, 2006 1:01 am
Contact:

Re: Veeam PN in Azure deployment failed

Post by AVasilyev » Jun 02, 2017 3:18 pm

The issue is resolved.

There must be a glitch in work of MS Azure portal.
As a rule Veeam PN (as other Azure solution templates) is allowed to be installed either in a new resource group or existing but completely empty resource group.

So the verification failed because MS Azure Portal allowed to use non-empty resource group.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests