Direct Restore to Microsoft Azure | VeeamPN software-defined networking
Post Reply
kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

VeeamPN deployment fails at Azure Setup

Post by kylecpcs » Apr 17, 2019 7:58 am

What level of support is provided for free tools such as VeeamPN? Can a regular support ticket be opened?

After deploying from the marketplace with all brand new resource groups, networks, etc (created through VeeamPN deployment wizard), the "phase 2" configuration of Azure connectivity/integration/setup fails at "Creating AAD application." This is after going through the device connection prompt and authenticating against my account successfully.

I've attempted other possible solutions found in the forums, such as logging into the appliance with SSH and making sure the correct subscription was listed as the default, trying different browsers, rebooting the appliance, waiting a day, etc.

If I cancel past this screen/setup, I can still configure individual endpoints and such, and even connect to the VPN, but the Azure integration services that allow for auto-creating routes, etc have a red X and say disabled.

Any insight would be appreciated.
The error I'm getting at "Creating AAD application" is as follows:

Code: Select all

Veeam PNbu-veeampn1
Running
Running
Stopped
()
Selecting subscription ... done
Getting account info ... done
Creating AAD application ...
Azure:cfgSetupStatus failed: Azure config failed on stage ec_AzCfg_2AppCreate: "command azure ad app create -n "bu-veeampn1-rg_application" -p "RiVQaKpvtpYmL07hSvaB5CZtzy43sB6i" -m "somehomepage" -i "bu-veeampn1-rg_service_principal" --end-date "2020-04-16" --json failed with status 1. Details: { \n "request": { \n "rawResponse": false, \n "queryString": {}, \n "url": "https://graph.windows.net/0d3bed37-548d-4fb4-90dc-6dc91a6ed5d9/applications?api-version=1.6", \n "method": "POST", \n "headers": { \n "x-ms-client-request-id": "c7bdeb74-ee04-45e1-ae60-d68550b7bc0e", \n "accept-language": "en-US", \n "Content-Type": "application/json; charset=utf-8", \n "x-ms-command-name": "ad app create", \n "x-ms-parameter-set-name": "****** -n ************************** -p ******************************** -m ************ -i ******************************** --end-date ********** --json", \n "user-agent": "AzureXplatCLI/0.10.17;osType:Linux;osVersion:4.11.0-1016-azure;nodeVersion:v4.2.6;installationType:NPM;userType:user;macAddressHash:60910fdd4d6ea405ba556b4744520132a8b49f63c49e8e1c96626c31cf82b00d" \n }, \n "body": "{\"availableToOtherTenants\":false,\"displayName\":\"bu-veeampn1-rg_application\",\"homepage\":\"somehomepage\",\"identifierUris\":[\"bu-veeampn1-rg_service_principal\"],\"passwordCredentials\":[{\"startDate\":\"2019-04-17T07:53:21.301Z\",\"endDate\":\"2020-04-16T00:00:00.000Z\",\"keyId\":\"c6840a30-eee3-4e83-a59a-b6e4a8e08edd\",\"value\":\"RiVQaKpvtpYmL07hSvaB5CZtzy43sB6i\"}]}" \n }, \n "rawStack": "Error\n at /usr/local/lib/node_modules/azure-cli/node_modules/azure-graph/lib/operations/applications.js:137:19\n at retryCallback (/usr/local/lib/node_modules/azure-cli/node_modules/ms-rest/lib/filters/systemErrorRetryPolicyFilter.js:89:9)\n at retryCallback (/usr/local/lib/node_modules/azure-cli/node_modules/ms-rest/lib/filters/exponentialRetryPolicyFilter.js:140:9)\n at handleRedirect (/usr/local/lib/node_modules/azure-cli/node_modules/ms-rest/lib/filters/redirectFilter.js:39:9)\n at /usr/local/lib/node_modules/azure-cli/node_modules/ms-rest-azure/lib/filters/rpRegistrationFilter.js:59:14\n at /usr/local/lib/node_modules/azure-cli/lib/util/utils.js:611:7\n at handleRedirect (/usr/local/lib/node_modules/azure-cli/lib/util/utils.js:588:9)\n at /usr/local/lib/node_modules/azure-cli/lib/util/logging.js:331:7\n at Request._callback (/usr/local/lib/node_modules/azure-cli/node_modules/ms-rest/lib/requestPipeline.js:125:16)\n at Request.self.callback (/usr/local/lib/node_modules/azure-cli/node_modules/ms-rest/node_modules/request/request.js:186:22)", \n "response": { \n "body": "{\"odata.error\":{\"code\":\"Request_BadRequest\",\"message\":{\"lang\":\"en\",\"value\":\"Url is malformed paramName: WwwHomepage, paramValue: somehomepage, objectType: Microsoft.Online.DirectoryServices.Application\"},\"requestId\":\"7cb14752-42d8-4158-97da-252f50833e5e\",\"date\":\"2019-04-17T07:53:21\",\"values\":[{\"item\":\"PropertyName\",\"value\":\"homepage\"},{\"item\":\"PropertyErrorCode\",\"value\":\"NotAWellFormedUrl\"}]}}", \n "headers": { \n "cache-control": "no-cache", \n "pragma": "no-cache", \n "content-type": "application/json; odata=minimalmetadata; streaming=true; charset=utf-8", \n "expires": "-1", \n "ocp-aad-diagnostics-server-name": "mgU/LDQoZtCMfAf7DHvoAt+wXe1cA1R3qcakrutD2/M=", \n "request-id": "7cb14752-42d8-4158-97da-252f50833e5e", \n "client-request-id": "c7bdeb74-ee04-45e1-ae60-d68550b7bc0e", \n "x-ms-dirapi-data-contract-version": "1.6", \n "ocp-aad-session-key": "lNcK211kg7ErrR1vr_XC3byzLTwHbiVjmemRjce4xSe2KSPa-_CRFSjKPPbxqCpMbkoDZ591_o_SIQGLhGN22YkjsrO_MgofY5G8AEnenT496vG5IMlxQoFWFrovqX4S.UHamyM_7ZIvBSc3M49vpAMMMY4wBizilW4EOcwCFFas", \n "dataserviceversion": "3.0;", \n "strict-transport-security": "max-age=31536000; includeSubDomains", \n "access-control-allow-origin": "*", \n "x-aspnet-version": "4.0.30319", \n "x-powered-by": "ASP.NET", \n "duration": "608674", \n "date": "Wed, 17 Apr 2019 07:53:21 GMT", \n "connection": "close", \n "content-length": "396" \n }, \n "statusCode": 400 \n }, \n "statusCode": 400, \n "body": { \n "code": "Request_BadRequest", \n "message": "Url is malformed paramName: WwwHomepage, paramValue: somehomepage, objectType: Microsoft.Online.DirectoryServices.Application" \n }, \n "__frame": { \n "name": "__1", \n "line": 117, \n "file": "/usr/local/lib/node_modules/azure-cli/lib/commands/arm/ad/adUtils.js", \n "prev": { \n "name": "exports_createApplicationWithParameters__2", \n "line": 111, \n "file": "/usr/local/lib/node_modules/azure-cli/lib/commands/arm/ad/adUtils.js", \n "prev": { \n "name": "exports_createApplication__1", \n "line": 28, \n "file": "/usr/local/lib/node_modules/azure-cli/lib/commands/arm/ad/adUtils.js", \n "prev": { \n "name": "__1", \n "line": 46, \n "file": "/usr/local/lib/node_modules/azure-cli/lib/commands/arm/ad/ad.application.js", \n "calls": 1, \n "active": false, \n "offset": 1, \n "col": 32 \n }, \n "calls": 1, \n "active": false, \n "offset": 79, \n "col": 28 \n }, \n "calls": 1, \n "active": false, \n "offset": 5, \n "col": 18 \n }, \n "calls": 0, \n "active": false, \n "offset": 1, \n "col": 35 \n } \n } \n error: Error information has been recorded to /root/.azure/azure.err \n error: ad app create command failed \n \n "

nielsengelen
Veeam Software
Posts: 2710
Liked: 566 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by nielsengelen » Apr 17, 2019 8:01 am

VeeamPN will receive best effort support as it is a free product. Please open up a support case and let us know the case ID for future reference. Keep in mind, it isn't allowed to paste log snippets on the forums as issues can be very specific to your case.
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » Apr 17, 2019 8:18 am

Excellent, sorry about that. Support case is 03517705.

nielsengelen
Veeam Software
Posts: 2710
Liked: 566 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by nielsengelen » Apr 17, 2019 8:30 am

No problem. I'm sure support will be able to resolve this for you.
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

taytecksze
Veeam Software
Posts: 8
Liked: never
Joined: Nov 01, 2018 3:31 am
Full Name: Teck Sze
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by taytecksze » Apr 22, 2019 7:30 am

Hi Kyle,

Did you get any reply from support on your case? I have similar issue that you are facing and had log a support case ID 03512671.

BR,
Teck Sze

veremin
Product Manager
Posts: 17021
Liked: 1462 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by veremin » Apr 22, 2019 12:11 pm

The investigation is still going on, so, work with your support engineer directly to address the issue. Thanks!

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » Apr 22, 2019 5:35 pm

Teck, they asked for logs last week, I sent them, and they just responded a few minutes ago with a Senior Engineer saying he's taking over and researching it for me.

llyr95
Novice
Posts: 6
Liked: 1 time
Joined: Apr 23, 2019 12:40 pm
Full Name: Robin Wilmet
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by llyr95 » Apr 25, 2019 6:37 am

Hi, do you have any update ? I'm having the same problem. Thanks

wishr
Veeam Software
Posts: 1268
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by wishr » Apr 25, 2019 9:38 am

Hi Robin,

Welcome to Veeam Community Forums!

R&D team is working hard to address this issue (the root cause is related to the recent Microsoft changes on Azure end). Please open your own support case to get a solution once it is ready.

Thanks

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » Apr 25, 2019 10:53 am

Fedor, I did not receive this update via email or my ticket, only your response here. Is this the official findings on my case? Any ETA on the fix?

wishr
Veeam Software
Posts: 1268
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by wishr » Apr 25, 2019 10:57 am

Hi Kyle,

That was an official response from the Product Management team. Unfortunately, no ETA for the fix yet.

The support team will respond independently, as a part of the common ticket handling process.

Thank you

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » Apr 26, 2019 3:15 am 1 person likes this post

Latest update:

I contacted our QA department about this issue. The issue happens because Microsoft changed some policies in Azure so now they are checking the validity of the homepage when we create an AAD application. This issue will be fixed in the next version of the Veeam PN appliance which is expected to be out released the first half of May.

llyr95
Novice
Posts: 6
Liked: 1 time
Joined: Apr 23, 2019 12:40 pm
Full Name: Robin Wilmet
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by llyr95 » Apr 26, 2019 7:14 am 1 person likes this post

Hi,
Thanks to both of you for the updates on this issue, I'm happy to know that a fix is on the way.
I'll open a support case to see if there could be a manual solution. If any, I'll be sure to post any update I have here.
Thanks

lsantoro
Lurker
Posts: 1
Liked: never
Joined: May 11, 2019 3:28 pm
Full Name: Letterino Santoro
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by lsantoro » May 11, 2019 3:32 pm

I'm facing the same problem. I'll wait for the new version of Veeam PN, and I hope the client, which I'm presenting a PoC, has patience.

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » May 14, 2019 9:16 pm

It's now May 14th, so I'd call that "first half of May" gone. No word or new info from support.

wishr
Veeam Software
Posts: 1268
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by wishr » May 15, 2019 12:51 pm

Hi everyone,

Finally, good news!

Veeam PN v2 is now available!
Download link: Click here
Release notes: Click here

Please let us know how it goes.

Thanks

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » May 16, 2019 10:45 am

Thanks for the update. Will try out ASAP.
EDIT: It says that OpenVPN has been "ripped out" in favor of WireGuard. Does that mean that all my clients who have OpenVPN installed on their desktops for point-to-site have to have a different client pushed out to them now? Please clarify the desktop client piece.
EDIT2: Has the Azure Marketplace appliance been updated as well? I can't tell by looking at the placeholder, and there's no revision date.

wishr
Veeam Software
Posts: 1268
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by wishr » May 16, 2019 11:33 am

Hi Kyle,

The endpoint client is still OpenVPN in this version. The new PN bundle was published in Azure Marketplace yesterday and should be already replicated across all the regions.

Please pay attention to the limitation section in the release notes. We do plan to support upgrades in future versions.

Thanks

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » May 16, 2019 11:05 pm

Thanks. Will there be paid support later? Is there something better than "best available" that can be used?

AVasilyev
Veeam Software
Posts: 60
Liked: 14 times
Joined: Jan 01, 2006 1:01 am
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by AVasilyev » May 17, 2019 12:08 pm

MS Azure Marketplace image is not updated yet - some delays in "going to live" procedure on Azure side.
I'll update everybody as soon as the image gets ready

llyr95
Novice
Posts: 6
Liked: 1 time
Joined: Apr 23, 2019 12:40 pm
Full Name: Robin Wilmet
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by llyr95 » May 22, 2019 6:40 am

Hi, is it updated on Azure now or do you know when it will be ?
Thanks

kylecpcs
Influencer
Posts: 17
Liked: 2 times
Joined: Jan 03, 2017 8:58 pm
Full Name: Kyle Kennedy
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by kylecpcs » May 23, 2019 5:40 pm

Nope. They said in this thread it had been published back on the 16th, but that's not the case even as of today. This is the email I just got from support on my open case:

The next version of the Veeam PN appliance is ready and you could read about that in the weekly Gostev's digest (if you are getting them), but there is still the old version of the appliance deployed in Azure. It is a temporary issue which we are currently fixing. The new version should be available in Azure shortly. I will let you know once it's there.


Best regards,
Andrey Zainutdinov
Veeam Support Tier 2

wishr
Veeam Software
Posts: 1268
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by wishr » May 23, 2019 5:58 pm

Hello gentlemen,

I can confirm that there is an organizational issue on the Azure end. We are working on it in cooperation with Azure Resource Management and will let you know once the new version is available in Azure Marketplace. Hope for your understanding.

Thanks

sunking989
Novice
Posts: 6
Liked: never
Joined: Apr 27, 2016 4:06 pm
Full Name: David Hofreiter
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by sunking989 » May 24, 2019 3:14 pm

Good morning all! I am having the same issue with deploying VeeamPN in Azure where it fails in the "Creating AAD Application" step of the configuration process. I opened a ticket for this yesterday and still have not heard back from anyone. The case number is 03581132.

I can see from the posts above that this is a known issue and that the Veeam support team is currently working on it. It is not clear to me if the issue is a version issue (looks like V1 is still in the market place) or an Azure issue. Can anyone elaborate?

Additionally, I see that VeeamPN V2 is available for download from Veeam. Is there a process that allows us to download it and use it for an Azure installation or are we forced to wait until V2 is made available in the Azure marketplace?

Will be following this closely and hope for a resolution soon!

wishr
Veeam Software
Posts: 1268
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by wishr » May 24, 2019 3:56 pm

Hi David,

Please review the comments above - it should answer most of your questions. We'll let everybody know once Azure Marketplace is updated with the new appliance version that is required for Azure installations.

Regards,
Fedor

nielsengelen
Veeam Software
Posts: 2710
Liked: 566 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by nielsengelen » May 29, 2019 10:04 am 2 people like this post

Update: the Azure Marketplace is now updated with the new appliance version.
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

asdffdsa6131
Enthusiast
Posts: 32
Liked: 3 times
Joined: Sep 30, 2018 9:03 pm
Contact:

Re: VeeamPN deployment fails at Azure Setup

Post by asdffdsa6131 » May 29, 2019 1:29 pm 1 person likes this post

to all,
finally, in azure i was able to create the virtual machine, without errors.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests