Direct Restore to Microsoft Azure | VeeamPN software-defined networking
Post Reply
davidl
Influencer
Posts: 11
Liked: never
Joined: Jul 23, 2011 6:23 am
Full Name: David Lee
Contact:

VeeamPN Site Gateway on Hyper-V

Post by davidl » Jun 22, 2018 2:43 am

Hi ,

Has anyone managed to get the Site Gateway appliance running on Hyper-V 2016 ?

I have a customer with a Hyper-V environment ( no ESX on Site) and would like to deploy a Site Gateway. The only thing that seems to be preventing this is the fact that the gateway is only provided in an OVF format

I have already tried to convert the VMDK Files to a VHDX file and that works fine however when the Ubuntu 16.04 host boots it has no network

Tried legacy network adaptors as well as standard and it just doesn't show up

I know I can inject drivers and bring the interface online but I have no idea what this will do in regards to impacting the Site Gateway appliance so before spending any time on it I was wondering if someone had the appliance working for Hyper-V or if someone from Veeam could point me in the direction of a deployment method that works for Hyper-V

Thank you to anyone who can assist in advance

AVasilyev
Veeam Software
Posts: 50
Liked: 11 times
Joined: Jan 01, 2006 1:01 am
Contact:

Re: VeeamPN Site Gateway on Hyper-V

Post by AVasilyev » Jul 02, 2018 8:02 pm 2 people like this post

Hi David!

As least troublesome and fastest solution for Hyper-V I would recommend to install the appliance directly from Veeam Linux repository as it is explained here: https://anthonyspiteri.net/quick-look-i ... inux-repo/

Hope this will help,
Alexey

davidl
Influencer
Posts: 11
Liked: never
Joined: Jul 23, 2011 6:23 am
Full Name: David Lee
Contact:

Re: VeeamPN Site Gateway on Hyper-V

Post by davidl » Jul 25, 2018 3:13 am

That's a fantastic solution thank you very much

I did actually get it working by logging into the console and manually defining the addapter that I added , I have had it in production for a few weeks now without issue

However I was not happy to see so many patches and security updates missing from the appliance ! Particularly considering it was still using the 2016 LTS Release I was planning on doing an distribution upgrade just to see what broke not that 18.04 is out :shock: :shock: but now I don't have to take the chance ! lol

Thank you very much for the link , I have to say I was a little surprised that Veeam didn't make alternate options for setting up the appliance easier to find particularly considering deploying to an on-premise Hyper-V Server is basicly the same process as running up a VM in Azure

Anyway , thank you again. I have to say all said and done I love the convenience of not needing to setup a VPN on the gateways at some customer sites :D :D

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest