Page 1 of 1

SQL DB backup not working on one server

Veeam LogoPosted: Wed Nov 08, 2017 8:36 pm
by dsegel
It's not finding any databases on one particular server:

Code: Select all
11/8/2017 12:19:25 PM :: New transaction log backup interval started at 11/8/2017 12:19:25 PM
11/8/2017 12:19:25 PM :: Enumerating SQL Server databases
11/8/2017 12:19:33 PM :: Starting SQL Server transaction log backup retention processing
11/8/2017 12:19:33 PM :: Deleted 2 SQL Server transaction log backups for time period from 11/1/2017 12:16:10 PM to 11/1/2017 12:16:11 PM
11/8/2017 12:19:33 PM :: SQL Server transaction log backup retention processing completed
11/8/2017 12:19:34 PM :: Transaction log backup completed at 0.0 KB/s with bottleneck: N/A


I've tried turning guest processing off and on, rebooting the VBR server, checking permissions, etc. but nothing makes it work. It used to work, then stopped a few days ago.

Any tips on how to fix or debug this?

Re: SQL DB backup not working on one server

Veeam LogoPosted: Thu Nov 09, 2017 10:50 am
by PTide
Hi,

The log that you've provided is related to transaction log backup, not to DB backup. What are the settings of the backup job that you use to backup your DB server (schedule, transaction log processing settings)?

Thanks

Re: SQL DB backup not working on one server

Veeam LogoPosted: Thu Nov 09, 2017 3:20 pm
by dsegel
Sorry, I may have the terminology wrong. The VM itself is backed up every night around 7pm. The VM backup itself completes without any errors.

I have Guest Processing turned on with these options:

Enable application-aware processing is checked.

For Application-Aware Processing Options,
Under General:
Require successful processing
Process transaction logs with this backup

Under SQL:
Backup logs periodically (every 15 minutes)
Keep only last 7 days of log backups

Guest OS Credential is using an account that is in the local Administrators group, and has been added to the database in question as a dbo and sysadmin.

The guest interaction proxy test completes successfully.

Re: SQL DB backup not working on one server

Veeam LogoPosted: Thu Nov 09, 2017 4:48 pm
by dsegel
Aaaaand it's working again. I changed the Guest interaction proxy from 'Automatic' to all but one specific server that's on a different subnet and on the other side of a WAN VPN tunnel, and it works now. I noticed somewhere that it was trying to use that server as a proxy, which doesn't make sense since the bandwidth to it is so much slower than all the others, so I removed it from the options.