Page 1 of 1

File lock message

Posted: Jul 02, 2018 1:35 pm
by gudmundo
I did have a few jobs that fails every other day with the ": Error: The process cannot access the file because it is being used by another process."-message.
Veeam Support solved the issue, but I still would like a better message in the first place. The message is of little use next day when the job has failed.

VBR knows the filname, so why not use this info to find and list the filelocking process while the lock is still active? Either by internal code or maybe calling SysInternals handle.exe wih the filename to search for?

Re: File lock message

Posted: Jul 02, 2018 3:36 pm
by Gostev
Hi, we need to understand where exactly do you see this message (context), as this can be the standard system error message we're just passing on based on error code received - so not something we can control/enhance from our side. Thanks!

Re: File lock message

Posted: Jul 03, 2018 7:24 am
by gudmundo
Context: Backup job status. One or more vm's in a PrVM-job with this detail summary:

Removing VM snapshot
Error: The process cannot access the file because it is being used by another process.
Network traffic verification detected no corrupted blocks

Overall job status is failed.
Am I correct assuming that the file refered to is the vmxxx.vib on the repository?

Re: File lock message

Posted: Jul 03, 2018 2:57 pm
by Mgamerz
I got this exact message last night on a few backups. I realized that I did not have antivirus exclusions on - I don't know if this is the issue (its been almost a year without any exclusions), just applied them, hope the message goes away.

Re: File lock message

Posted: Jul 09, 2018 6:08 pm
by dntfmn
How did Veeam Support solve your issue? I opened a case with Veeam Support who told me to disable anti-virus (we uninstalled it) and still get it randomly on copy jobs. From there they just told us something else was accessing the file and it was on us to figure out.

Re: File lock message

Posted: Jul 09, 2018 10:20 pm
by Gostev

Re: File lock message

Posted: Jan 24, 2019 10:03 am
by DDIT
I'm getting this issue too on Hyper-v. Running Veeam 9.5 U3 (9.5.0.1922).

I recently re-installed a Hyper-v host from fresh, previously 2008 R2, now 2016. No AV installed on the server. No applications installed that should mess with files. sometimes the job completes successfully, sometimes not - its about 50/50. When it fails I'm stuck with cleaning up the mess and manually merging checkpoints - Hyper-V manager never shows any checkpoints.

The target storage is iSCSI from a dumb NAS. Volume formatted in ReFS. I opened case #03376406 yesterday, but the only response so far was to disable AV.

As also suggested in my reply on the support case, I cannot run Resource Monitor as its not included with Hyper-V. Nor can it be run locally and targeted at a remote computer. I have tried Process Monitor and Handle.exe (both tools from SysInternals) run locally on the server, but most of the processes shows as 'Access Denied' (I have tried running under both domain and local admin accounts). Perhaps 2016 has a new security model?

The overnight backup failed again, so I need to wait until that site (in another time zone, thankfully) go home for the day tp tidy up the snapshots (which means downtime). I can manually kick off a backup and check Handle.exe whilst the checkpoint is created to try to see which process grabs the file, but based on the 'access denied' messages above, I'm not hopeful I'll find anything meaningful. I will update this post again shortly.

If anyone else can suggest a clever way of finding out who has open files, then please let me know.

Re: File lock message

Posted: Jan 24, 2019 3:42 pm
by dntfmn
We had problems with this on a lot of our servers and found the root cause to be the defrag service locking files somehow. We had to disable defrag on the volume as well as disable the "Optimize drives" service.

Support was able to help us correlate the time this was happening with events in the event log of the Veeam host to narrow it down. It did take getting our support case escalated so we definitely went through the whole "disable A/V" process first.

I'll be curious to see if this helps on other folks' cases as well.

Re: File lock message

Posted: Jan 28, 2019 8:57 am
by DDIT
Support suggested I send them the Event Viewer logs under Hyper-V-VMMS\Admin. There was a ton of warnings under there. I googled a few and found the following discussions...

https://social.technet.microsoft.com/Fo ... rverhyperv
https://social.technet.microsoft.com/Fo ... rverhyperv

and this really long discussion on the Veeam forums…

microsoft-hyper-v-f25/9-5-hyper-v-known ... 7-330.html (pages 20+ refer to similar issues).

The last few updates on that Veeam discussion were from mid-2018 discussing the latest patches. I had just installed a fresh Hyper-v 2016 server full patched, so up-to-date as of January 2019, so assumed my patches had included the fixes. I therefore focused on the other suggestions and did the following...
  • Disabled UAC
  • Removed any GPO from specifying any accounts under ‘logon as a service’.
  • Rebooted the host
Nearly a week of backups later, and I have not experienced a single backup failure.