Page 1 of 1

Trying Linux file restore FLR Helper Appliance

Posted: Aug 08, 2018 8:40 pm
by pasha
Hi, I'm new to Veeam so please excuse my ignorance here:

Trying to test file-level restore to a Linux VM. I am able to spin up the FLR Helper Appliance successfully, however, I keep getting prompted for credentials. To make sure there were no issues with credentials or connectivity, I was able to log directly into the appliance and connect successfully to the target VM with the same credentials I put in the GUI. The log files on the appliance aren't giving me any indication of an error when I attempt a restore. Is there somewhere else I can look to see what is going on? Is there something else I can check or something I'm missing?

Thanks very much in advance.

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 09, 2018 12:30 pm
by PTide
Hi,

It is not quite clear what went wrong - did you input guest OS credentials in UI but it didn't work? If so then please check if the password authentication via ssh is enabled on the guest OS.

Thanks

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 09, 2018 12:35 pm
by pasha
Thank you for responding. Wouldn't being able to ssh to the VM w/ a password, directly from the appliance shell, indicate that password authentication via ssh is enabled on the VM?

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 09, 2018 3:07 pm
by PTide
Wouldn't being able to ssh to the VM w/ a password, directly from the appliance shell, indicate that password authentication via ssh is enabled on the VM?
Sorry, I missed the part where you explicitly mentioned that you successfully connected from the appliance. So, did I get it right - after you entered the credentials in the UI nothing happens and no errors are shown neither on VBR, nor in the appliance? Are there any failed login attempts messages on the VM where you're attempting to restore the files?

Thanks

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 09, 2018 3:21 pm
by pasha
I apologize for lack of clarity:

When I try to restore a file (on a linux VM) from the GUI, I select the root account (with credentials set correctly), and I get an error saying "Unable to establish connection with the vm. check credentials and try again"

When I log onto the FLR appliance, I can ssh (and scp files) to the VM using the same root credentials just fine.

I'm trying to figure out why the GUI is returning the error that it is. The VM nor the FLR appliance are logging any fail attempts when I use the GUI.

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 10, 2018 9:48 am
by PTide
Could you confirm that the mount server can actually access the VM via Network, please?

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 10, 2018 1:38 pm
by pasha
Yes, I've verified that the mount server/proxy server is able to communicate with the target VM via the NFS ports specified in the parameters for the backup job.

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 10, 2018 3:10 pm
by PTide
Well, in this case kindly contact the support team directly and post your case ID here.

Thanks

Re: Trying Linux file restore FLR Helper Appliance

Posted: Aug 10, 2018 3:13 pm
by pasha
thanks for your help. Case ID is: 03142140