Page 1 of 3

Restore to Azure

Posted: Jul 28, 2017 3:57 am
by krisso
Hi,

I am trying to restore a backed up VM to Azure using the Restore to Azure option within Veeam.

I get to the point of validating the Azure Subscription and then get presented with the following error when the location option is being enumerated.

Error:

Code: Select all

Failed to process requests: (Forbidden) The client 'GUID' with object id 'GUID' does not have authorization to perform action 'Microsoft.Resources/subscriptions/locations/read' over scope 'subscriptions/SubscriptionGIUD'. The remote server returned an error: (403) Forbidden.
Any assistance you can muster on this would be greatly appreciated.

Kris.

Re: Restore to Azure

Posted: Jul 28, 2017 11:45 am
by v.Eremin
What role does your account have? Thanks.

Re: Restore to Azure

Posted: Jul 28, 2017 12:30 pm
by TheNev
hi v.Eremin
Krisso is one of my colleagues.

We identified that this issue only occurred in Azure Tenants with CSP subscriptions.
Are AzureCSP tenants not supported ?

Re: Restore to Azure

Posted: Jul 28, 2017 1:06 pm
by v.Eremin
Do you mind opening a ticket and providing us with the debug logs? We'd like to take a closer look at how our solution interacts with such subscriptions, and where the cause of failure might be present. Thanks.

Re: Restore to Azure

Posted: Aug 02, 2017 5:55 pm
by jschulz1980
I have run into the same issue. Has anyone found a solution yet? I am using a CSP subscription as well.

Re: Restore to Azure

Posted: Aug 03, 2017 11:53 am
by v.Eremin
We cannot solve the issue, unless someone opens a ticket with our support team and provide debug logs needed to investigate the problem thoroughly.

May I ask you to reach our support team and share the ticket number with us?

Thanks.

Re: Restore to Azure

Posted: Aug 23, 2017 8:10 am
by SBarrett847
I've tested this too - I get that error on my own Azure account, but not with my admin account that has full permissions to Azure. My account is a contributor account.

Re: Restore to Azure

Posted: Aug 23, 2017 9:53 am
by v.Eremin
Do you mind opening a ticket with our support team and posting its number here? Thanks.

Re: Restore to Azure

Posted: Aug 23, 2017 10:11 am
by SBarrett847
Case #02289238 created

Re: Restore to Azure

Posted: Aug 23, 2017 10:43 am
by SBarrett847
It's correct behavior it seems - see last post in this thread

veeam-tools-for-microsoft-azure-f36/wha ... 41597.html

Re: Restore to Azure

Posted: Aug 23, 2017 10:54 am
by v.Eremin
We need to dig deeper into this issue to find what in particular is missing in our code to make it work with such subscription. Kindly, keep the case open, I will ask QA team to take a look at it. Thanks.

Re: Restore to Azure

Posted: Aug 24, 2017 8:43 am
by SBarrett847
Seems I was too hasty - I had applied the Service administrator role to my Contributor account in Azure yesterday and waited for permissions to propagate - testing today yields the same error.

Re: Restore to Azure

Posted: Sep 06, 2017 5:37 pm
by frankive
whats the news here? all our Azure customer is now CSP!

Re: Restore to Azure

Posted: Sep 07, 2017 8:34 am
by SBarrett847
Still working with support for now, slow going, as I've to try to make time for testing.

Re: Restore to Azure

Posted: Sep 19, 2017 2:19 pm
by SBarrett847
Just finished with support - it looks like only a Full Azure admin account can restore to Azure CSP - any limited admin /contributor does not have the necessary abilities within azure for Veeam to hook into.