Page 1 of 1

Can't install veeamsnap rpm becouse of kernel version

Posted: Dec 05, 2016 10:56 am
by B0ris
I want to install Veeam Linux agent (beta version) to a CentOS 7.2 machine.
During rpm installation I got an error:

Building for 3.10.0-229.7.2.el7.x86_64
Module build for kernel 3.10.0-229.7.2.el7.x86_64 was skipped since the
kernel headers for this kernel does not seem to be installed.
WARNING: Package not configured! See output!
warning: %post(veeamsnap-1.0.0.678-1.noarch) scriptlet failed, exit status 1

I have newest kernel installed on my machine (version 3.10.0.327).

Any suggestions ?

Re: Can't install veeamsnap rpm becouse of kernel version

Posted: Dec 05, 2016 11:22 am
by vmniels
You will need to install the kernel headers as they are a requirement. These can be installed by using:
yum install kernel-devel

[MERGED] Agent Problem install on Centos 6.5

Posted: Dec 05, 2016 2:25 pm
by o0BackupDude0o
I cannot install VEEAm agent.. getting error:

[root@www veeam]# rpm -ivh veeamsnap-1.0.0.678-1.noarch.rpm
Preparing... ########################################### [100%]
1:veeamsnap ########################################### [100%]
Loading new veeamsnap-1.0.0.678 DKMS files...
Building for 3.10.104-1.el6.elrepo.x86_64
Module build for kernel 3.10.104-1.el6.elrepo.x86_64 was skipped since the
kernel headers for this kernel does not seem to be installed.
WARNING: Package not configured! See output!
warning: %post(veeamsnap-1.0.0.678-1.noarch) scriptlet failed, exit status 1

[root@www veeam]# uname -r
3.10.104-1.el6.elrepo.x86_64
[root@www veeam]#

any advice?

Re: Can't install veeamsnap rpm becouse of kernel version

Posted: Dec 05, 2016 10:33 pm
by o0BackupDude0o
did that
[root@www ~]# yum install kernel-devel
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
Setting up Install Process
Package kernel-devel-2.6.32-642.11.1.el6.x86_64 already installed and latest version
Nothing to do

still getting the same error. What's next?

Re: Can't install veeamsnap rpm becouse of kernel version

Posted: Dec 05, 2016 10:51 pm
by vmniels
You have the wrong kernel headers installed. Your kernel is 3.10.104-1.el6.elrepo.x86_64 and you don't have these headers. You can find the matching rpm's for them via http://ftp.colocall.net/pub/elrepo/kern ... 6_64/RPMS/

Install elrepo-release rpm:
rpm -Uvh elrepo-release*rpm
Install kernel-lt-headers rpm package:
yum --enablerepo=elrepo-kernel install kernel-lt-headers

Re: Can't install veeamsnap rpm becouse of kernel version

Posted: Dec 06, 2016 10:04 am
by B0ris
Solved the problem !
When updating kernel to newest version, there was not enough disk space on /boot partition, so new kernel-headers was sucessfully installed, and kernel wasn't. There was difference between current kernel and updated kernel-headers.
Now I have both on same version and it's OK.