Page 1 of 1

Veeam Agent for Linux and RHEL 7.6 Support

Posted: Nov 15, 2018 1:37 pm
by hajek
We have upgraded a few Red Hat Enterprise Linux servers to RHEL 7.6.

Initially after upgrading from RHEL 7.5 to RHEL 7.6 backups failed with the following error message.

Code: Select all

[error] Failed to create volume snapshot                                                                       
[error] Failed to perform backup
[error] Unable to load module. Accurate kernel version =  3.10.0-957.el7.x86_64
[error] Same release kernel version =  3.10.0-957.el7.x86_64
[error] Failed to find suitable veeamsnap kernel module
[error] Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0]
[error] Processing finished with errors at 2018-11-08 21:30:21 EST
I could manually load the old kernel module via modprobe veeamsnap and the module loaded and backups seemed to work as expected. I tested restore points from before and after upgrading and it seems that the data is recoverable.

I'm wondering if there is any ETA on official support for the Veeam Agent for Linux for RHEL 7.6 or if anyone has run into issues with running Veeam 2.0.1.665 with the kmod-veeamsnap-2.0.1.665-1 kernel modules on kernel version 3.10.0-957.el7.x86_64. Any feedback or comments are appreciated. I did open a support request and it sounds like support for 7.6 will possibly come with the release of VAL v3 but no ETA was given.

Any additional information would be much appreciated.
thanks,

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Nov 15, 2018 3:36 pm
by PTide
Hi,

The next version of Agent is undergoing the final stages of testing against RedHat 7.6, looks good so far, however you should wait until the official announcement.

Regarding 2.0.1 on 7.6 - this hasn't been tested as only GA versions that have been released before the current version of Veeam Agent for Linux are supported, unless it is said otherwise in the User Guide.

Thanks!

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Nov 20, 2018 8:43 pm
by pj888888888888
Is there an ETA on the release of this? I've recently been hit by this incompatibility issue after a recent round of OS patching and really don't like the fact we are going to have to tell our OS owners to either stay compliant from a patching prospective, and not have the ability to restore/recover the systems, or have backups and have non-compliant systems.

This is really putting us in a bad spot as our patching cycles are all automated, so now we are going to have to break our automation for a few systems that will be put in harms way if they are patched.

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Nov 21, 2018 11:59 am
by PTide
Hi Paul,

We plan to ship RTM code in December 2018.

Thanks!

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Nov 26, 2018 2:13 pm
by pj888888888888
That's good to know, I'll make note of that.
Thanks for following up.

Will the RPMs be released to put into the master Veeam server to allow it to be updated that way? (Silly question....but had to ask :) )

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Nov 26, 2018 8:41 pm
by PTide
The upcoming VBR release will allow to distribute updated agents' (both VAW and VAL) packages in the same way as it can be done with the current U3a. Moreover, the new VBR version will also include updated agents' packages, so there will be no need to put them there manually if you upgrade the VBR first (which is a recommended course of action).

Thanks!

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Dec 06, 2018 8:50 am
by priet
Can we opt-in for early access? I'm running into the exact same issue on CentOS 7.

Re: Veeam Agent for Linux and RHEL 7.6 Support

Posted: Dec 06, 2018 12:39 pm
by PTide
Peter,

Kindly contact your sales representative for that.

Thanks!