Page 1 of 1

Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 16, 2017 11:30 am
by MarksJHF
Hi,

I've just upgraded Veeam Backup for Microsoft Office 365 to version 1.5.0.1099 and now i cant perform the upgrade to the Backup Repository or add a new Repository.

When i upgrade i get the following error in the log file

10/16/2017 1:20:32 PM 1 (3948) Upgrading repository: Default Backup Repository...
10/16/2017 1:20:32 PM 3 (7696) Error: Cannot access a disposed object.
Object name: 'Veeam.Archiver.Proxy.Wcf.ProxyDuplexServiceConnection`2[[Veeam.Archiver.Interfaces.Upgrade.IUpgradeService, Veeam.Archiver.Interfaces, Version=9.6.0.1099, Culture=neutral, PublicKeyToken=null],[Veeam.Archiver.Interfaces.Upgrade.IUpgradeServiceCallback, Veeam.Archiver.Interfaces, Version=9.6.0.1099, Culture=neutral, PublicKeyToken=null]]'.
10/16/2017 1:20:32 PM 3 (7696) Stack:
10/16/2017 1:20:32 PM 3 (7696)
Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Veeam.Archiver.Interfaces.IArchiverAdmin.StartRepositoryUpgrade(Guid repositoryId)
at Veeam.Archiver.Client.ArchiverAdminConnection.StartRepositoryUpgrade(Guid repositoryId)
at Veeam.Archiver.Shell.MainWindow.Proxies.Tasks.AsyncUpgradeRepositoryTask.Run(IProcessObserver observer)
at Veeam.Presentation.Async.VisualAsyncTask.Execute(IProcessObserver observer)
10/16/2017 1:20:38 PM 1 (3948) Failed
10/16/2017 1:20:42 PM 1 (3948) Upgrading repository: Default Backup Repository...
10/16/2017 1:20:42 PM 3 (7696) Error: Cannot access a disposed object.



When I try to add a new Repository i get the error SMB Connection is 0.0 Minimum Required version is 3.0
i checked with powershell and SMB version is 3.02
Any idea on how to fix this?

I tried running as Admin and restarting all the services

With regards,

Mark

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 16, 2017 7:03 pm
by vmniels
Hi Mark, please contact support for assistance. If possible post the support case ID for future references.

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 17, 2017 7:04 am
by MarksJHF
I've contacted support and this is the support case 02348061

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 17, 2017 7:18 am
by Nieuwenhuis
Please keep us updated on the solution, i have the same problem on one of our "test" customers.

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 17, 2017 10:56 am
by johncduffy
Hi.
To upgrade the repository you go into the software and then go to back infrastructure and upgrade.
It doesn't do it with the installer.
regards
John

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 17, 2017 11:19 am
by MarksJHF
Dear John,

that doesn't work for me thats why i've opened a support case to help me with this.
When i go in to the software and go to Backup Infrastructure , then to Backup Repositories and click Upgrade Repository i get the error as mentionend in my opening post.

I've got some suggestion from support

ensure, that Veeam Backup for Microsoft Office 365 Service and Veeam Backup Proxy for Microsoft Office 365 Service are running under Local System user
Then we need to add the account of the computer(not the user account) to the ACL list on our NAS/Windows and grant it full permissions. Computer account looks like DOMAIN\SERVERNAME$
If any further errors, we may need to re-create the VBO365 configuration database.
To do so, stop above-mentioned services, remove c:\programdata\veeam\backup365\ folder, and start the services again. Then you will need to re-add O365 organization/repository/backup jobs again.


I am unable to grant a computer account permission in the ACL of our NAS so i can't do these steps but maybe it will help others

Regards,
Mark

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 17, 2017 11:45 am
by Nieuwenhuis
For me the sollution was to:
stop above-mentioned services, remove c:\programdata\veeam\backup365\ folder, and start the services again. Then you will need to re-add O365 organization/repository/backup jobs again.
after that the repo update went successfull.

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 18, 2017 9:35 am
by DimaRo
Nieuwenhuis wrote:For me the sollution was to:
stop above-mentioned services, remove c:\programdata\veeam\backup365\ folder, and start the services again. Then you will need to re-add O365 organization/repository/backup jobs again.
after that the repo update went successfull.
Deleting a configuration database will result in the loss of recovery points, as their configuration information will be no longer available, and restore will be impossible. The best way to solve this problem is to move the repository to an accessible storage(Like iSCSI). Then add it as a new repository in VBO console 1.5. and upgrade the repository. After the upgrade, the corresponding configuration data for these restore points will be transferred from the existing configuration database to the repository, and these restore points will be available for restore.

Regards, Dmitry

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 19, 2017 2:22 pm
by MarksJHF
I've decided to roll back to the previous version of Backup for office 365 so the back-ups will work again.
will keep an eye out for upcoming updates to see if it will work again

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 19, 2017 2:26 pm
by Mike Resseler
Hi Mark,

I'm a bit confused now. Did you do the upgrade from version 1 to 1.5 or from the beta to 1.5? (Makes a big difference)

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 23, 2017 2:44 am
by dustinn3
I put in a support case as well as I can't get it to connect to my DataDomain CIFS share. They gave me a few things to try that didn't work and said my only option was to setup a Linux front end and connect via NFS. I wasn't real happy with that solution since it worked fine in 1.0.

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 23, 2017 6:30 am
by Mike Resseler
Dustin,

Did you previously connected to that CIFS share with a username? Or did you added the computer account of the VBO server (or proxy) to that CIFS share as authentication?

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 23, 2017 5:19 pm
by dustinn3
Mike,

I previously used an AD Group with the user account it was installed under as part of the group. I tried using the computer account, *, adding the computer to a group in AD and giving the group rights, but nothing worked. When trying to add a new repository on the same DataDomain it gives an SMB connection version: 2.10. Minimum required version is 3.0.

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Oct 24, 2017 7:19 am
by Mike Resseler
Yes, we require SMB 3.0 in version 1.5. Does the DD not support SMB 3 (Not an expert in DD so...)

Re: Can't upgrade repositorie after upgrade to 1.5

Posted: Nov 02, 2017 5:04 pm
by dustinn3
After doing some digging I finally found this in the security guide.

CIFS (SMB 2.x only) Microsoft network file sharing protocol

So it does appear that Data Domains do not support SMB 3.0 as of yet.

Thanks,