Discussions specific to the VMware vSphere hypervisor
Post Reply
champ_
Enthusiast
Posts: 26
Liked: never
Joined: Aug 18, 2014 9:20 am
Full Name: Roger
Contact:

All SQL server not showing up

Post by champ_ » Feb 19, 2015 7:10 am

Hello,

When trying to do a application restore of a SQL server I don't see it when I choose Restore - vmware - application item - SQL server. I see a couple of SQL servers but not all SQL servers in the environment. Instead I have to check the box "show all vm (think this was the name)" in order to select the SQL server I want to do a restore from. How come I don't see that server unless I check the box?

Regards

Roger

Vitaliy S.
Product Manager
Posts: 22991
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: All SQL server not showing up

Post by Vitaliy S. » Feb 19, 2015 10:17 am

Hi Roger,

Did you use application-aware image processing for all SQL Server VMs?

Thanks!

champ_
Enthusiast
Posts: 26
Liked: never
Joined: Aug 18, 2014 9:20 am
Full Name: Roger
Contact:

Re: All SQL server not showing up

Post by champ_ » Feb 19, 2015 10:19 am

Yes, I use application-aware image processing on all the sql servers.

regards

Vitaliy S.
Product Manager
Posts: 22991
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: All SQL server not showing up

Post by Vitaliy S. » Feb 19, 2015 11:46 am

Thanks, one more quick question to make sure we are on the same page. You're talking about this wizard where you only see a couple of VMs hosting SQL Server, correct?

champ_
Enthusiast
Posts: 26
Liked: never
Joined: Aug 18, 2014 9:20 am
Full Name: Roger
Contact:

Re: All SQL server not showing up

Post by champ_ » Feb 19, 2015 12:16 pm

Yes, that's correct.

Regards

Vitaliy S.
Product Manager
Posts: 22991
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: All SQL server not showing up

Post by Vitaliy S. » Feb 19, 2015 4:28 pm 1 person likes this post

Can you confirm that AAIP has no warning messages for the VMs that are missing in that list?

veremin
Product Manager
Posts: 16897
Liked: 1437 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: All SQL server not showing up

Post by veremin » Feb 19, 2015 4:33 pm 1 person likes this post

Is there anything specific about SQL servers not showing in the said wizard? Also, are you positive that account used to backup those SQL servers has necessary permissions? In other words, you won't get any issues, if you click "Test credentials" button on "Guest Processing" tab? Thanks.

alanbolte
Expert
Posts: 635
Liked: 172 times
Joined: Jun 18, 2012 8:58 pm
Full Name: Alan Bolte
Contact:

Re: All SQL server not showing up

Post by alanbolte » Feb 19, 2015 5:36 pm 1 person likes this post

You may also need to make sure that the account in question has permissions within MS SQL Server itself and not just the OS; there are some known issues with detecting that kind of permissions issue at the moment so you may not see a warning.

Vitaliy S.
Product Manager
Posts: 22991
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: All SQL server not showing up

Post by Vitaliy S. » Feb 19, 2015 7:20 pm 1 person likes this post

And here is the list of permissions required.

champ_
Enthusiast
Posts: 26
Liked: never
Joined: Aug 18, 2014 9:20 am
Full Name: Roger
Contact:

Re: All SQL server not showing up

Post by champ_ » Feb 20, 2015 8:04 am

Hi all,

I guess it has to do with UAC on the vm's....

geraldb
Enthusiast
Posts: 30
Liked: 2 times
Joined: Mar 14, 2012 3:56 pm
Contact:

[MERGED] : sql explorer detects only one instance

Post by geraldb » Feb 24, 2015 1:00 pm

Hi all,

yesterday we have updated to version 8 (latest patch).
When we try to restore application items from our database-server with 4 instances (2x SQL2005, SQL2008 R2 and SQL2012) we just see one SQL2005 Instance in the veeam sql explorer.

if we try to restore sql application items from version 7 backups (from the same database-server) we see all (4) instances in the veeam sql explorer ..

is this a bug ?

regards
Gerald

veremin
Product Manager
Posts: 16897
Liked: 1437 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: All SQL server not showing up

Post by veremin » Feb 24, 2015 2:37 pm

Hi, Gerald,

Kindly, check the answers provided above. Usual suspects include AAIP disabled for specific VM and account having insufficient privileges within SQL server.

Thanks.

Post Reply

Who is online

Users browsing this forum: backupquestions and 23 guests