Discussions specific to the VMware vSphere hypervisor
Post Reply
shaharr
Novice
Posts: 4
Liked: never
Joined: Jan 11, 2015 8:26 pm
Full Name: shahar r
Contact:

Backup from Netapp snapmirror changed in 9.5?

Post by shaharr » Dec 19, 2016 9:56 am

Hi all
We have an issue (case 02009188 ) backing up from Netapp Snapmirror destination after upgrading to version 9.5.
After investigation i think that in version 9.5 the Netapp Snapshot used as source for backup was changed:
* Old method: veeam creates a Storage snapshot with the name of the job (for example - "VeeamSourceSnapshot_<job_name>_<timestamp>") , Snapmirror the Vol to the DR netapp and then backup from that job snapshot.

* New method: veeam server use the Netapp baseline snapshot as the source snapshot. After creating the vmware snapshot veeam server initiate Snapmirror update and backup from that Snapmirror relationship snapshot (snapshot name will be "<netapp_name><volume_name><update_serial>").

It seems that our problem happens since we have hourly snapmirror updates and in the new method, veeam lose the snapmirror snapshot used to backup and generates the error "Error File netapp(0536912050)_NFS01_1.11142 doesn't exist (Veeam.Backup.Common.CCppComponentException)"

Did anyone else got the same issue? did anyone found a workaround rather than disable the snapmirror updates during backup to disk time? im having a hard time explain to support what exactly is the issue...

thanks!

foggy
Veeam Software
Posts: 18239
Liked: 1557 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Backup from Netapp snapmirror changed in 9.5?

Post by foggy » Dec 19, 2016 4:51 pm

The only change in behavior during backup from SnapMirror in v9.5 was the fact that now source snapshots are removed right after the backup job completes. Chance are the failure is caused by the fact that SnapMirror is being performed at the moment of backup. If you make sure they don't overlap, the backup should work.

shaharr
Novice
Posts: 4
Liked: never
Joined: Jan 11, 2015 8:26 pm
Full Name: shahar r
Contact:

Re: Backup from Netapp snapmirror changed in 9.5?

Post by shaharr » Dec 21, 2016 3:45 pm

Hi Foggy.
Thanks for the replay. So it's sounds like we have a bug - i see that the job does not create a snapshot with the job name and only use the snapmirror snapshot as the source .I also see that the snapmirror happens only an hour and a half into the job and only then i get the NFS file not found error.
I will ask support to escalate the case to Dev team...
thanks again,
Shahar

foggy
Veeam Software
Posts: 18239
Liked: 1557 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Backup from Netapp snapmirror changed in 9.5?

Post by foggy » Dec 22, 2016 11:38 am

Yes, good idea to ask support to verify the behavior you're seeing.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 20 guests