Discussions specific to the VMware vSphere hypervisor
Post Reply
MJeB
Influencer
Posts: 19
Liked: 5 times
Joined: Mar 10, 2014 5:37 pm
Contact:

Backups failing with message Backup Console version is not compatible

Post by MJeB »

Hello,

till yesterday Veamm B&R 9.5 Enterprise Edition was working fine.
Now we get several jobs backing to repository 1 failing with massage "Backup Console version '9.5.0.1922' is not compatible with Installer service on host X"
All jobs backing to repository 2 are working fine.

I checked version of 'Master'server (where Veeam Backup & Replication is installed to [9.5.0.711], all other versions [Transport, vPowerNFS, Distribution Service, Installer Service, Mount Service]are 9.5.0.1922)
Versions on still working repository 1 for "Transport, vPowerNFS, Distribution Service, Mount Service" are 9.5.0.1922 and for installer Service version is 9.5.0.1491
Versions on not working repository 2 for "Transport, vPowerNFS, Distribution Service, Mount Service" are 9.5.0.1922 and for installer Service version is 9.5.0.1491 too.

I don't see why one repo is working fine and the other repo with the same versions is considered "not compatible".

License is not expired and is valid for another 144 days.

wishr
Veeam Software
Posts: 1685
Liked: 186 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Backups failing with massage Backup Console version is not compatible

Post by wishr »

Hi MJeB,

I'd recommend reaching out to our technical support team directly to get it sorted. Please let us know your case ID once you get it so could keep an eye on it.

That topic may also give a few hints.

Thanks!

MJeB
Influencer
Posts: 19
Liked: 5 times
Joined: Mar 10, 2014 5:37 pm
Contact:

Re: Backups failing with massage Backup Console version is not compatible

Post by MJeB »

could the repository be removed and readded or would that cause the backup chain to be disrupted?

wishr
Veeam Software
Posts: 1685
Liked: 186 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Backups failing with massage Backup Console version is not compatible

Post by wishr »

You should uninstall all the Veeam components from "host X" manually (using "Programs and Features") and then redeploy them by going through the backup infrastructure component deployment wizard within Console UI. Meaning, after removal edit the existing "host Х" using UI and complete all the wizard steps - all the components will be redeployed automatically. The backup chain should not be affected.

If any issues arise during the process - please raise a support case for a detailed look. Also, keep in mind for the future that you should add a case ID when posting about any technical issue/error on Veeam Community Forums.

Thank you!

MJeB
Influencer
Posts: 19
Liked: 5 times
Joined: Mar 10, 2014 5:37 pm
Contact:

Re: Backups failing with massage Backup Console version is not compatible

Post by MJeB » 1 person likes this post

After deinstalling all components manually using "Programs and Features", I had to first edit the servers properties under Managed Servers to trigger veeam to install the Install Service and Backup Transport anew, after that I could rescan the repository. Backup jobs and copy jobs to repository 2 are working again, without destroying the backup chain.

Thank you for your help.

DGrinev
Expert
Posts: 1943
Liked: 248 times
Joined: Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev
Location: St.Petersburg
Contact:

Re: Backups failing with message Backup Console version is not compatible

Post by DGrinev »

BTW, why are you using different builds of Veeam B&R?
It's crucial to keep all the components on the same patch\build level.

Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests