Discussions specific to the VMware vSphere hypervisor
Post Reply
yuljk
Novice
Posts: 4
Liked: 1 time
Joined: Mar 17, 2016 1:18 pm
Full Name: Chris Gregson

Configuration Backups Fail After Moving SQL Database

Post by yuljk » Jan 24, 2019 5:34 pm

Hi guys - I am running Veeam B&R 9.5a. I have recently moved my SQL database from SQL Express to a dedicated SQL 2017 VM.

I stopped all Veeam services, used SQL Management Studio to detach the database and then attached on my SQL 2017 VM. I then ran the Database connection utility to specify the new server. All working and my jobs process successfully.

However - my scheduled configuration backups now fail with the following message.

Encryption is disabled, credentials will not be included in the backup

Code: Select all

24/01/2019 17:24:41 Error Unable to write to configuration backup file.
24/01/2019 17:24:41 Error Processing configuration VeeamBackup at newSQLSERVER
24/01/2019 17:24:41 Error Compressing database VeeamBackup
24/01/2019 17:24:41 Error Could not load file or assembly 'Microsoft.SqlServer.BatchParser, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.
The configuration backup repository hasn't been modified or moved.

Any help greatly appreciated.

Chris

yuljk
Novice
Posts: 4
Liked: 1 time
Joined: Mar 17, 2016 1:18 pm
Full Name: Chris Gregson

Re: Configuration Backups Fail After Moving SQL Database

Post by yuljk » Jan 24, 2019 7:24 pm

Do I need to re-install Veeam after moving the database?

veremin
Product Manager
Posts: 16879
Liked: 1429 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Configuration Backups Fail After Moving SQL Database

Post by veremin » Jan 25, 2019 5:22 pm

We haven't seen this issue before. So, please, open a ticket and provide us with its number. Thanks!

yuljk
Novice
Posts: 4
Liked: 1 time
Joined: Mar 17, 2016 1:18 pm
Full Name: Chris Gregson

Re: Configuration Backups Fail After Moving SQL Database

Post by yuljk » Jan 27, 2019 7:56 pm 1 person likes this post

I've resolved this issue by performing a Configuration Restore and using the most recent configuration backup. After completing the process my configuration backups are now working correctly again.

This issue can be marked as resolved.

veremin
Product Manager
Posts: 16879
Liked: 1429 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Configuration Backups Fail After Moving SQL Database

Post by veremin » Jan 28, 2019 1:57 pm

Great! Thanks for coming back and updating the topic with the found resolution; appreciated!

dlapointe
Influencer
Posts: 14
Liked: 2 times
Joined: Jan 08, 2019 2:47 pm
Full Name: Dominic Lapointe
Contact:

Re: Configuration Backups Fail After Moving SQL Database

Post by dlapointe » Feb 14, 2019 5:47 pm

Hi,

I am facing the same issue. However, it looks like the configuration backup have been failed for about a year.. so I can't use your work arround.

Did you get an official fix for this?

dlapointe
Influencer
Posts: 14
Liked: 2 times
Joined: Jan 08, 2019 2:47 pm
Full Name: Dominic Lapointe
Contact:

Re: Configuration Backups Fail After Moving SQL Database

Post by dlapointe » Feb 14, 2019 6:21 pm 1 person likes this post

Actually, I have just fixed the issue by doing this on the SQL server that contain Veeam database:

https://social.technet.microsoft.com/wi ... arser.aspx


I had to install both sql server 2008 package and sql server 2014 package:

x64\SharedManagementObjects.msi
x64\SQLSysClrTypes.msi

https://www.microsoft.com/en-us/downloa ... x?id=27596
https://www.microsoft.com/en-us/downloa ... x?id=42295


I believe the root cause of the issue was because we upgraded our SQL server from 2008 to 2014.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 10 guests