Failed to Index with Indexing Disabled

VMware specific discussions

Failed to Index with Indexing Disabled

Veeam Logoby ChuckS42 » Thu Jan 21, 2016 6:18 pm

Here's an odd one. I recently turned off guest indexing for my backup jobs. Since then one VM has been giving me a warning for failing to index the guest OS. The error is:

"Failed to index guest file system. STDERR: SCP sudo STDERR: SCP : STDERR: SCP no tty present and no askpass program specified STDERR: SCP "

The VM in question is a small Linux appliance. Any ideas?
ChuckS42
Enthusiast
 
Posts: 66
Liked: 5 times
Joined: Wed Apr 24, 2013 8:53 pm
Full Name: Chuck Stevens

Re: Failed to Index with Indexing Disabled

Veeam Logoby foggy » Thu Jan 21, 2016 8:55 pm

Chuck, how have you turned indexing off? Have you just cleared the 'Enable guest file system indexing' check box at the Guest Processing step of the job wizard? Have you contacted support with this?
foggy
Veeam Software
 
Posts: 14753
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Failed to Index with Indexing Disabled

Veeam Logoby ChuckS42 » Thu Jan 21, 2016 11:01 pm

Yes, just unchecked that box. No, I haven't yet contacted support; seemed a bit trivial.
ChuckS42
Enthusiast
 
Posts: 66
Liked: 5 times
Joined: Wed Apr 24, 2013 8:53 pm
Full Name: Chuck Stevens

Re: Failed to Index with Indexing Disabled

Veeam Logoby foggy » Fri Jan 22, 2016 11:05 am

Please open a case, since logs review is required. There were similar issues in v8, however all were addressed in the latest v9.
foggy
Veeam Software
 
Posts: 14753
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

[MERGED] bug? Guest filesystem indexing warning after upgrad

Veeam Logoby hyvokar » Sat Jan 23, 2016 11:03 am

Hi!
(ticket # 01675860 )


I just upgraded from v8 to v9.
After upgrading I started to get errors from my Linux vm backup:

Failed to index guest file system. STDERR: SCP sudo: sorry, you must have a tty to run sudo

The funny thing is, I dont want to do guest file system indexing and for that I have had that option deselected in guest processing tab.
Bed?! Beds for sleepy people! Lets get a kebab and go to a disco!
MS MCSA, MCITP, MCTS, MCP
VMWare VCP5-DCV
Veeam VMCE
hyvokar
Service Provider
 
Posts: 254
Liked: 15 times
Joined: Fri Nov 21, 2014 10:05 pm

Re: bug? Guest filesystem indexing warning after upgrading t

Veeam Logoby Gostev » Sat Jan 23, 2016 1:03 pm

Hi. Do you have application-aware processing enabled? This will also result in guest logon attempts. You can disable it in the advanced settings on the same step for this specific VM. Regardless, the actual error message is misleading, so at least this is a bug for sure. Thanks!
Gostev
Veeam Software
 
Posts: 21396
Liked: 2350 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: bug? Guest filesystem indexing warning after upgrading t

Veeam Logoby hyvokar » Sat Jan 23, 2016 6:45 pm

HI!

Yes, I have aaip enabled. Any idea why this worked with v8, but started giving me errors after upgrade?
I will disable aaip on monday.
Bed?! Beds for sleepy people! Lets get a kebab and go to a disco!
MS MCSA, MCITP, MCTS, MCP
VMWare VCP5-DCV
Veeam VMCE
hyvokar
Service Provider
 
Posts: 254
Liked: 15 times
Joined: Fri Nov 21, 2014 10:05 pm

Re: bug? Guest filesystem indexing warning after upgrading t

Veeam Logoby alanbolte » Sat Jan 23, 2016 9:30 pm

I would guess it has something to do with our implementation of transaction log backup for Oracle on Linux, but I'm not sure.
alanbolte
Expert
 
Posts: 635
Liked: 170 times
Joined: Mon Jun 18, 2012 8:58 pm
Full Name: Alan Bolte

Re: bug? Guest filesystem indexing warning after upgrading t

Veeam Logoby Gostev » Sat Jan 23, 2016 10:34 pm

Correct, most likely this is the reason.
Gostev
Veeam Software
 
Posts: 21396
Liked: 2350 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Failed to Index with Indexing Disabled

Veeam Logoby eneko.anorga@um.si » Fri Jul 22, 2016 8:34 am 1 person likes this post

Hi,

we solved this issue by checking in oracle credentials under "Non-root account":

Elevate specified account to root
Add account to sudoers file automatically

After running the job you will notice that the next 2 lines are added to "/etc/sudoers" file:

Defaults:oracle !requiretty
oracle ALL=(root) NOPASSWD: ALL

Later, there will not be more warnings and it is safe to uncheck the option "Add account to sudoers file automatically".

Hope this will help ;)
eneko.anorga@um.si
Novice
 
Posts: 4
Liked: 1 time
Joined: Fri Jul 22, 2016 8:27 am
Full Name: Eneko


Return to VMware vSphere



Who is online

Users browsing this forum: Bing [Bot] and 27 guests