Discussions specific to the VMware vSphere hypervisor
Post Reply
mikolee
Novice
Posts: 5
Liked: never
Joined: Sep 04, 2012 7:29 am
Full Name: Miko Lee
Contact:

HELP:A hard drive is missing when perform file restore of VM

Post by mikolee » Sep 04, 2012 7:40 am

Hi all,

We are having a situation here that needs your help.

We are trying to restore a file from our file server, which is the D: drive on a virtual machine called FileServer running Windows 2003 in vSphere 4.1 environment. FileServer has 2 drives: C (OS - 50GB) and D(Data -1.2TB).
However, when performing File-Level Restore (Windows) from Veeam B&R v5.0, and follow the wizard, we can not see the D: drive in Browser Window, only C: is there.
All the backups were done successfully and we know that D: has been backed-up (by the size of the backup)

Please advice if we are doing anything wrong or any other method to restore the FileServer.
And help would be highly appreciated.

Cheers.

dellock6
Veeam Software
Posts: 5734
Liked: 1625 times
Joined: Jul 26, 2009 3:39 pm
Full Name: Luca Dell'Oca
Location: Varese, Italy
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by dellock6 » Sep 04, 2012 8:55 am

It's surely a dynamic disk, they are supported but not using FLR, you will need to use other restore methods.
Luca Dell'Oca
Principal EMEA Cloud Architect @ Veeam Software

@dellock6
https://www.virtualtothecore.com/
vExpert 2011 -> 2019
Veeam VMCE #1

foggy
Veeam Software
Posts: 18257
Liked: 1559 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by foggy » Sep 04, 2012 9:49 am

Yes, FLR from dynamic disks is not supported as per Release Notes. If this is the case, please use "Other OS" wizard to perform a FLR from this disk.

mikolee
Novice
Posts: 5
Liked: never
Joined: Sep 04, 2012 7:29 am
Full Name: Miko Lee
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by mikolee » Sep 04, 2012 10:57 pm

Thanks for the quick responses, however i have checked the disks and they are all Basic.

Gostev
SVP, Product Management
Posts: 24789
Liked: 3523 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by Gostev » Sep 05, 2012 12:40 am

Is it possibly GPT disk then? FLR from those is only supported in B&R v6 or later.

mikolee
Novice
Posts: 5
Liked: never
Joined: Sep 04, 2012 7:29 am
Full Name: Miko Lee
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by mikolee » Sep 06, 2012 5:39 am

Yes guys, it is a GPT disk.

However i tried to Instant VM Recovery that FileServer (which has a 1TB drive) to recover a file and always got the Mount Failed error. Why? Is it because the drive that holds the Veeam backup is low on space?

Thanks for all the responses.

foggy
Veeam Software
Posts: 18257
Liked: 1559 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by foggy » Sep 06, 2012 9:01 am

For any technical issues it's always better to contact support directly, as explained when you click New Topic. However, I would assume that you have no VMkernel interface configured on your host and connection to vPower NFS server cannot be established (typical for mount errors).

mikolee
Novice
Posts: 5
Liked: never
Joined: Sep 04, 2012 7:29 am
Full Name: Miko Lee
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by mikolee » Sep 16, 2012 11:01 pm

Thanks you very much people. I might have to contact support directly.

lcaller
Novice
Posts: 6
Liked: never
Joined: Oct 14, 2011 9:38 am
Full Name: Lee Caller
Contact:

[MERGED] Restore of windows guest files - Not all drives are

Post by lcaller » Jan 11, 2013 3:36 pm

Just wanted to throw this out before i raised a case (hence no case ID)

I've got to restore some users mail. No problem just do it as I have done before. Except this time when i select the backup (below) and the backup mounts i don't see all drives.

Image

I've checked and the size of the backup matches the size of the drives in use and there are no drive exclusions in the job. It appears the "C" drive is showing as D and the "C" is a system partition. I'm missing the 3 other discs with my mail stores on.

Image

Anyone seen this ? Without looking to maybe restore the whole VM just to get the machine mounted i'm hoping i'm having a Friday afternoon brain fade.

lcaller
Novice
Posts: 6
Liked: never
Joined: Oct 14, 2011 9:38 am
Full Name: Lee Caller
Contact:

Re: Restore of windows guest files - Not all drives are show

Post by lcaller » Jan 11, 2013 3:45 pm

Quick update :

I've started a restore of other guest files and it can see the drives . That's good news at least i know they are there, however i can't explore these using Exchange explorer.

Image

foggy
Veeam Software
Posts: 18257
Liked: 1559 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by foggy » Jan 11, 2013 3:56 pm

Lee, I bet you are not using the latest Veeam B&R version. Please see above regarding the missing disks. As for the deranged drive letters, it is also a known issue (mentioned in the release notes) for versions prior to v6.5 where Backup Browser could show different drive letters than in the actual VM as they were auto-assigned in the sequential order. With v6.5, actual drive letters are pulled directly from the OS settings. Thanks!

kaskm
Novice
Posts: 3
Liked: 1 time
Joined: Jan 18, 2013 8:16 pm
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by kaskm » Jan 21, 2013 3:56 pm

I have the same issue. When looking at the logs, all windows disks are being backed up. They are all basic disks. When I open the Guest Files (Windows) restore wizard, only the C drive shows up. If I select (Other OS), I am able to restore from the D:\ (or whatever other drive there is). I am on 6.5 with the latest patch. If I use the Enterprise manager web interface for One-Click, I am able to select files from the D:\ drive to restore, but the actual restore fails with the error "Error: No matching paths found."

As I said, it all works perfectly when I do the Other OS option.

Vitaliy S.
Product Manager
Posts: 22984
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by Vitaliy S. » Jan 21, 2013 7:03 pm

If all these disks are basic with no extra configuration, then please open a support ticket with our technical team to investigate this issue further. Thanks!

rawtaz
Enthusiast
Posts: 85
Liked: 15 times
Joined: Jan 27, 2012 4:42 pm
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by rawtaz » Jun 27, 2013 2:16 pm

Hello,

I just now had a case where I needed to restore a single file from the E: (second out of two VMDKs) of a Windows 2008r2 VM which is reverse incrementally backed up using Veeam B&R 6.5.0.144. But just as previous posts in this thread mentions, the FLR for "Guest files (Windows)" only showed C:, even though both disks are backed up for sure.

After finding this thread I tried the "Guest files (other OS)", and was successfully able to restore the file, thank god. But the E: should definately show in the Windows FLR dialog, as I see it.

Please see the following screenshot to see what the E: disk looks like. It's a regular basic one.

I should also mention that I have two backup repositories, and on one of them the backups were created from scratch using the aforementioned Veeam B&R version, so it shouldn't be a case of the backups having been created in a pre-6.5 version or such, as the FLR dialog is missing E: for both backup repositories.

Given the screenshot below, is it expected that E: isn't listed?

Image

foggy
Veeam Software
Posts: 18257
Liked: 1559 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by foggy » Jun 27, 2013 3:07 pm

rawtaz wrote:Given the screenshot below, is it expected that E: isn't listed?
I would say no and suggest contacting support for closer investigation.

leonjehae
Lurker
Posts: 2
Liked: never
Joined: Jan 18, 2011 2:42 pm
Full Name: Leon Jehae
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by leonjehae » Sep 12, 2014 8:31 am

Same issue here, backups are succesfull but when restoring there is only one (the first) drive visible?
I'm using Veeam 7.0 00690.....................

Solution :
Upgraded tot the latest 7.0 patch...............backups made with 690 are fully restorable again.

Best regards, :D
Léon

Vitaliy S.
Product Manager
Posts: 22984
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: HELP:A hard drive is missing when perform file restore o

Post by Vitaliy S. » Sep 12, 2014 8:38 am

I believe you're referring to Native File Level Recovery wizard and not Multi-OS FLR engine? If it is the first one, then doing FLRs with Multi-OS FLR wizard should allow you to restore from other drives as well. Yes, it is always a best practice to be on the latest patch level. Glad that your issue has been resolved.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 16 guests