Missing Disks after instant revocery

VMware specific discussions

Missing Disks after instant revocery

Veeam Logoby mma » Tue Aug 16, 2016 6:52 am 1 person likes this post

Hello

I'm not sure if I did something wrong in my restore process - but something went totally wrong!

I had to restore a VM which had about 20 independent disk. I know that Veeam does not backup independent disk by design, which is ok. So where is the Problem?

My Idea was to do instant recovery (with the same name), migrate the VM and reattach the disks.
As the VM already existed, the restore process deleted the VM – and all the disks…
I was aware that the job will delete the original VM, I even confirmed it. But deleting all the disks is a bit hard…
mma
Service Provider
 
Posts: 58
Liked: 10 times
Joined: Thu Dec 22, 2011 9:12 am
Location: Lucerne, Switzerland
Full Name: Marcel

Re: Missing Disks after instant revocery

Veeam Logoby Gostev » Tue Aug 16, 2016 2:13 pm 1 person likes this post

Hello Marcel, thanks for the heads up. We will look into this restore scenario and see what can be done to prevent such operational mistakes in future. Thanks!
Gostev
Veeam Software
 
Posts: 21396
Liked: 2350 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Missing Disks after instant revocery

Veeam Logoby mma » Tue Aug 16, 2016 3:42 pm 1 person likes this post

Think before you click ;-)

Not a big thing in our case, we "just" lost some backups.
If you could change the message from "Original VM still exists, and will be deleted. Proceed?" to something like "Original VM still exists. Machine and all disks will be deleted. Proceed?" already might help in some cases.

I don't blame the application, totally my fault.

Regards
Marcel
mma
Service Provider
 
Posts: 58
Liked: 10 times
Joined: Thu Dec 22, 2011 9:12 am
Location: Lucerne, Switzerland
Full Name: Marcel


Return to VMware vSphere



Who is online

Users browsing this forum: Yahoo [Bot] and 16 guests