msg.snapshot.error-QUIESCINGERROR

VMware specific discussions

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby tommyv » Tue Jun 02, 2015 9:50 am

Interesting that a few people are having the same issues on SLES.

Foggy,v.Eremin, Ive just tried a few test runs with disk.enableUUID=false and it the backup went fine without any issues. When setting disk.enableUUID=true we encounter the error and the VM crashes. I imagine this setting gives us a crash consistent backup so is the equivalent of having quiesence disabled?
tommyv
Influencer
 
Posts: 19
Liked: 1 time
Joined: Wed Dec 17, 2014 10:47 am
Location: England
Full Name: Tom Vernon

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby foggy » Tue Jun 02, 2015 10:35 am

Right, "true" (default) means application-consistent backup, "false" - crash-consistent, however the setting applies to Windows guests only, so no need to bother with Linux VMs. We are still investigating the issue.
foggy
Veeam Software
 
Posts: 14741
Liked: 1079 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby tommyv » Tue Jun 02, 2015 10:51 am

foggy wrote:Right, "true" (default) means application-consistent backup, "false" - crash-consistent, however the setting applies to Windows guests only, so no need to bother with Linux VMs. We are still investigating the issue.

Are you sure about that? The test shows very different results in Linux when toggling the flag. I can't find much documentation around disk.EnableUUID but I'm guessing it enables ID disk presentation to the OS. Can anyone elaborate?
tommyv
Influencer
 
Posts: 19
Liked: 1 time
Joined: Wed Dec 17, 2014 10:47 am
Location: England
Full Name: Tom Vernon

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby zerina » Wed Jun 17, 2015 8:20 am

In our case, the test failed, we had an crash this weekend during backup.
The Test was made with the vmx setting disk.enableUUID, false
zerina
Novice
 
Posts: 3
Liked: never
Joined: Tue Jun 02, 2015 7:39 am

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby Wocka » Wed Jul 01, 2015 10:47 pm

Hello,

I'm also experiencing this issue in a hosted Datacentre on 7 RedHat servers after upgrading VMware Tools to 9.0.5.21789 (build-1065307). Perviously we were on open vmware tools 8.3.7.4937 (build-381511).

The hoster sent me this error:
An error occured while taking a snapshot: msg.snapshot.error-QUIESCINGERROR
An error occured while saving a snapshot: msg.snapshot.error-QUIESCINGERROR

Environment:
Vmware: 5.5 - I don't know the patch level as it's a hosted server
OS: RedHat Enterprise Linux Server release 6.6 (Santiago)
Backup Software: CommVault 10

Manual Tests I have performed with VMWare tools logging on:
(http://kb.vmware.com/selfservice/micros ... Id=1007873 )
1. Snapshot through vCentre (no Quiesce) = no error or crash
2. Snapshot through vCentre (with Quiesce) = no error or crash
3. Snapshot through CommVault = no error or crash

I could not reproduce the error, but we are still experiencing it randomly over our 7 servers at least one server per night, sometimes up to 3.
When the issue occurs, I can still PING the server, I can SSh to it and enter in root and my password. The prompt never comes back after entering the password. A hard reset is the only way to resolve this.

Interesting, on our internal UAT environment we have not seen this issue:
Vmware: 5.1.0 no patches
OS: RedHat Enterprise Linux Server release 6.6 (Santiago)
All Yum Updates are the same between Dev, Test, UAT and Production
Backup Software: vRanger 6.1.0.35402 (still trying to get mgmt approval for my Veeam solution)

I have found the following articles for Linux, this talks about changing the "disk.enableUUID=false" as perviously mentioned.
http://kb.vmware.com/selfservice/micros ... Id=2038606
http://kb.vmware.com/selfservice/micros ... Id=2079220

I'm about to make these changes today.
Wocka
Enthusiast
 
Posts: 30
Liked: 2 times
Joined: Wed Oct 01, 2014 12:04 am
Full Name: Warwick Ferguson

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby v.Eremin » Thu Jul 02, 2015 9:33 am

Kindly, keep us updated about the results you get. Based on the experience of previous posters, the mentioned setting should be a way to go, indeed.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby Wocka » Tue Jul 07, 2015 1:00 am 1 person likes this post

A follow up from my post above.

After making the required changes to the .vmx files by our hosting provider and myself making the changes in the VMWare Tools (tools.conf) file. We have not had a server become unresponsive during a snapshot for the past 5 nights. The above KB2079220 from VMWare has resolved the issue.
Wocka
Enthusiast
 
Posts: 30
Liked: 2 times
Joined: Wed Oct 01, 2014 12:04 am
Full Name: Warwick Ferguson

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby v.Eremin » Tue Jul 07, 2015 5:20 am

Thank you for confirming that setting disk.EnableUUID parameter in the .vmx file to false resolves the problem for you; much appreciated.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby tommyv » Mon Jul 13, 2015 7:30 am 1 person likes this post

Thanks for the update Wocka. Interestingly KB2079220 claims to be fixed in ESXi5.5u2 however we still see the issue running on the latest version. Setting disk.EnableUUID to false or disabling VMware tools quiesce does work as a fix though.
tommyv
Influencer
 
Posts: 19
Liked: 1 time
Joined: Wed Dec 17, 2014 10:47 am
Location: England
Full Name: Tom Vernon

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby jspeicher » Wed Sep 28, 2016 7:35 pm

we're seeing the same issue with vcenter/veeam. esxi 5.5.0 3568722

We're getting random issues as described in this thread. When can keep retrying the jobs, and eventually get the job to complete all the vm's. Was any resolution found for anyone?
jspeicher
Service Provider
 
Posts: 7
Liked: never
Joined: Thu May 09, 2013 7:49 pm
Full Name: Jason

Re: msg.snapshot.error-QUIESCINGERROR

Veeam Logoby stuartmacgreen » Thu Sep 29, 2016 1:15 pm 1 person likes this post

I had this issue and was given a fix by VMware. Here is the environment and versions I am running.

VM Guest OS: SUSE Linux Enterprise Server 11 SP4
ESXi: 5.5 U3
VirtualCenter Server: 5.5 U3e

The VM's were updated to VMware Tools 10.x from 9.x and got a load of VM backup failures "msg.snapshot.error-QUIESCINGERROR"
But the VM's would sometimes backup, and then sometimes fail. VERY inconsistent but consistent to fail on the v10.x tools compared to v9.x

I reverted back my VM's to v9.x
Logged a case with VMware to report the issue.
Several VMware Tools in the 10.x stream have been released and all applied to a sample VM but exhibited the same "msg.snapshot.error-QUIESCINGERROR" every now and again.

Now these VM's had configured in the OS via /etc/vmware-tools/tools.conf the following setting:

[vmbackup]
enableSyncDriver = false

This was set after a recommendation from VMware in v9.x tools as without it this HUNG the whole filesystem of the OS - even more severe, than the current predicament of just not quiescing and at least you got the OS back!

VMware recommended to install VMware Tools 10.x and set tools.conf

Code: Select all
[vmbackup]
enableSyncDriver = true


Now we are getting successful VM backups without any QUIESCE errors.
Backup Infrastructure: Veeam B&R 9.5 • vSphere 5.5 U3e • HP MSA 2040 [FC] (Backup Storage) • HP MSL6480 LTO-6 (Tape Storage)
(Veeam Endpoint Backup protecting Veeam Proxy / Tape / Repository servers)
stuartmacgreen
Enthusiast
 
Posts: 87
Liked: 16 times
Joined: Tue May 01, 2012 11:56 am
Full Name: Stuart Green

Previous

Return to VMware vSphere



Who is online

Users browsing this forum: JonSD, mcconmw and 17 guests