Discussions specific to the VMware vSphere hypervisor
Post Reply
lwarner
Influencer
Posts: 23
Liked: 2 times
Joined: May 29, 2011 6:05 pm
Full Name: Leigh Warner
Contact:

Network bottleneck with HotAdd

Post by lwarner » Jan 28, 2013 9:30 pm

We have two sites connected with 50Mbps fiber. I have my Veeam B&R server on Site 1. I'm backing up guests on Site 2; I have a proxy on Site 2 located on the same host as the backup target. Repository is a separate Windows server on Site 2, connected to the local Site 2 network via GB.

When I back up a guest on Site 2 with hot add, using the Site 2 proxy and the Site 2 repository, I'm getting really slow speeds. It's showing Network as the bottleneck with processing speeds of ~10 MB/s. If I stand up a Veeam server on Site 2, and run it all locally, I get normal processing speeds (way over 100 MB/s).

I don't have any traffic throttling rules. Repository selection is set to Automatic for the Site 2 proxy. Shouldn't I be getting full speed backups with this setup, is my config wrong? It's almost like the traffic is going between Site 1 and Site 2.

dellock6
Veeam Software
Posts: 5628
Liked: 1575 times
Joined: Jul 26, 2009 3:39 pm
Full Name: Luca Dell'Oca
Location: Varese, Italy
Contact:

Re: Network bottleneck with HotAdd

Post by dellock6 » Jan 28, 2013 11:21 pm

Have you try to avoid any automatic selection and configure backup job to use proxy2? Repository cannot be automatic in a backup job, but proxy can, my doubt is the job is using veeam server on site1 as proxy...

Luca
Luca Dell'Oca
EMEA Cloud Architect @ Veeam Software

@dellock6
https://www.virtualtothecore.com/
vExpert 2011 -> 2019
Veeam VMCE #1

vmJoe
Veeam Software
Posts: 296
Liked: 55 times
Joined: Aug 02, 2011 1:06 pm
Full Name: Joe Gremillion
Location: Dallas, TX USA
Contact:

Re: Network bottleneck with HotAdd

Post by vmJoe » Jan 28, 2013 11:35 pm

Is your proxy failing over to network mode?
Joe Gremillion
NA Core Solutions Architect - Central region

lwarner
Influencer
Posts: 23
Liked: 2 times
Joined: May 29, 2011 6:05 pm
Full Name: Leigh Warner
Contact:

Re: Network bottleneck with HotAdd

Post by lwarner » Jan 29, 2013 12:00 am

It's definitely using the correct proxy, you can even see the virtual disks added to the correct proxy appliance. And according to the live statistics, it's using hot add (unless it's lying to me).

The job itself is manually configured to use Proxy2. On that proxy, I manually selected the datastores, and disabled the "failover to network mode..." although I left the Transport Mode on Automatic.

Also ran traffic monitor on the fiber, and there's no backup data going between the two sites, so at least that's ruled out.

Vitaliy S.
Product Manager
Posts: 22289
Liked: 1412 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Network bottleneck with HotAdd

Post by Vitaliy S. » Jan 30, 2013 1:29 pm

Hi Leigh,

Can you please tell me what processing rate do you receive if you configure your proxy server on Site 2 to run in network mode? Also when you install another Veeam B&R server what proxy server are you using to run the job? The default one?

Thanks!

lwarner
Influencer
Posts: 23
Liked: 2 times
Joined: May 29, 2011 6:05 pm
Full Name: Leigh Warner
Contact:

Re: Network bottleneck with HotAdd

Post by lwarner » Jan 31, 2013 10:40 pm

Hi Vitaliy, when I set Proxy2 to network mode, I get fast processing... 300+ MB/s, interesting. Bottleneck also now shows more normal numbers, it shows Target ~80%, which is expected because my repository on Site2 is a bit on the slow side.

When I had installed Veeam B&R server on Site 2 for testing, Veeam B&R server was on a separate machine, so I used a separate proxy just like Proxy2, which was a VM on the same ESXi host as the guest VMs (and same host as Proxy2 now).

Vitaliy S.
Product Manager
Posts: 22289
Liked: 1412 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Network bottleneck with HotAdd

Post by Vitaliy S. » Feb 03, 2013 2:22 pm

That's what I've thought...Can you please install any other proxy server on the remote site and give it a try with a HotAdd backup job triggered by the backup server on the main site? This should help us to narrow down the cause of your initial problem.

jpoling
Novice
Posts: 3
Liked: never
Joined: Jan 14, 2013 2:42 pm
Contact:

Re: Network bottleneck with HotAdd

Post by jpoling » Dec 04, 2013 5:22 pm

Was there ever a resolution to this issue? I have a very similar setup and see slow transfer rates like the original poster. Any insight is greatly appreciated.

My environment is:

Site 1: Veeam B&R server
Site 2: Backup Proxy and Backup Repository

Backup mode is hotadd

The bottleneck shows as network and the processing rate is 50 MB/s

I have a case open related to some network issues we are seeing (00485578) but so far no real solution.

Thanks,

Jeff

Vitaliy S.
Product Manager
Posts: 22289
Liked: 1412 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Network bottleneck with HotAdd

Post by Vitaliy S. » Dec 05, 2013 2:28 pm

Hi Jeff,
jpoling wrote:The bottleneck shows as network and the processing rate is 50 MB/s
Is it for incremental or full job pass?
jpoling wrote:Site 1: Veeam B&R server
Site 2: Backup Proxy and Backup Repository
Do you backup VMs that reside on the secondary site only?

Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests