Discussions specific to the VMware vSphere hypervisor
Post Reply
DaveWatkins
Expert
Posts: 348
Liked: 92 times
Joined: Dec 13, 2015 11:33 pm
Contact:

New vCenter plugin for 9.5U1 for Enterprise Manager

Post by DaveWatkins » Jan 25, 2017 10:18 pm

Hi

Is there a new vCenter plugin from Enterprise Manager for 9.5U1? I've done the upgrade and my EM reports as 9.5.0.823 but after removing and installing the plugin on my vCenter servers they all still report 9.5.0.711.

Is the old plugin not uninstalling properly or is that still the correct version?

Thanks

foggy
Veeam Software
Posts: 18158
Liked: 1542 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by foggy » Jan 26, 2017 11:04 am

Plug-in version should reflect the new version. Please try to re-install the plug-in (this procedure and this KB might help) and contact support if required.

DaveWatkins
Expert
Posts: 348
Liked: 92 times
Joined: Dec 13, 2015 11:33 pm
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by DaveWatkins » Jan 26, 2017 7:11 pm

Hi Foggy

Yeah, I'm aware of them sadly, this will be the second full uninstall and reinstall of EM (had to do the same to get the v9 EM plugin working). Just gone through the KB and cleared out the files on our Windows VC and no joy. Also this is across 2 VC's so it's the EM server actually sending the old plugin.

Thanks
Dave

DaveWatkins
Expert
Posts: 348
Liked: 92 times
Joined: Dec 13, 2015 11:33 pm
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by DaveWatkins » Jan 26, 2017 7:33 pm

Hi Foggy

Can you double check this is the case with 9.5U1? I've just extracted the 9.5U1 update to a temp folder and it doesn't appear to include a new VC plugin at all. No .WAR or .JAR files, no *vsphere-plugin*.zip. If it's built as par tof the install I wouldn't expect that but I figured there would be something in there that would at least be the base of it.

Thanks
Dave

foggy
Veeam Software
Posts: 18158
Liked: 1542 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by foggy » Jan 27, 2017 10:32 am

Dave, you can check the WebApp\static\static\vcplugin\vsphere-plugin.zip (or vsphere-plugin-6.zip) file on the Enterprise Manager server itself. The plugin-package.xml file inside should contain the correct version="9.5.0.823" property.

McClane
Expert
Posts: 106
Liked: 11 times
Joined: Jun 20, 2009 12:47 pm
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by McClane » Jan 27, 2017 2:12 pm

The plugin-package.xml in my updated server has 9.5.0.711

foggy
Veeam Software
Posts: 18158
Liked: 1542 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by foggy » Jan 27, 2017 2:27 pm

That means the file was not replaced for some reason (file could be locked or something). I'd recommend opening a case for the setup logs review.

McClane
Expert
Posts: 106
Liked: 11 times
Joined: Jun 20, 2009 12:47 pm
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by McClane » Jan 27, 2017 2:34 pm

Are you sure the file is being replaced with the update? I also just looked into the 902 files inside the update package, and there is nothing in there for the vsphere plugin. No zip file or other packages.

And I remember that was also the case for one of the 9.0 versions. The plugin had an older build number.

tsightler
VP, Product Management
Posts: 5405
Liked: 2230 times
Joined: Jun 05, 2009 12:57 pm
Full Name: Tom Sightler
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by tsightler » Jan 27, 2017 6:57 pm

I just checked my 9.5U1 lab instance and my plugins are the old version as well.

DaveWatkins
Expert
Posts: 348
Liked: 92 times
Joined: Dec 13, 2015 11:33 pm
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by DaveWatkins » Jan 27, 2017 10:05 pm

foggy wrote:Dave, you can check the WebApp\static\static\vcplugin\vsphere-plugin.zip (or vsphere-plugin-6.zip) file on the Enterprise Manager server itself. The plugin-package.xml file inside should contain the correct version="9.5.0.823" property.
Nope, it's 711 in the XML file, that's what got me extracting the update files to see if there was an updated zip file included. It sounds like either it's not supposed to be updated at all, or it wasn't included in the U1 update by mistake.

Given U1 adds the VMWare 6.5 support I imagine there should be a new plugin, but maybe not

foggy
Veeam Software
Posts: 18158
Liked: 1542 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by foggy » Jan 30, 2017 12:11 pm

I've checked with devs once again, it was supposed to be updated, but was not. The intended changes will be included in Update 2. This shouldn't affect vSphere 6.5 support in any way. Sorry for confusion.

Kev Parr
Novice
Posts: 7
Liked: 1 time
Joined: Nov 17, 2015 2:29 pm
Full Name: Kevin Parr
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by Kev Parr » Jan 30, 2017 4:58 pm

Foggy - any idea when this will be available? I've followed all the advice on the articles and deleted all things Veeam from the VC servers and now they are taking a long time to log on via the web client. They also fail when trying to use the plug-in.

Gostev
SVP, Product Management
Posts: 24658
Liked: 3471 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by Gostev » Jan 30, 2017 5:13 pm

Update 2 should be available in about 3 months based on our standard update cadence.

DaveWatkins
Expert
Posts: 348
Liked: 92 times
Joined: Dec 13, 2015 11:33 pm
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by DaveWatkins » Jan 31, 2017 1:52 am

Kev Parr wrote:Foggy - any idea when this will be available? I've followed all the advice on the articles and deleted all things Veeam from the VC servers and now they are taking a long time to log on via the web client. They also fail when trying to use the plug-in.
Mine also took a long time to login after manually cleaning out the files, but that only seemed to be the first login, subsequent logins seem fine. I'm assuming the plugin only being 711 should continue to work without issue until update 2, at least if we're still using 6U2?

Thanks

Kev Parr
Novice
Posts: 7
Liked: 1 time
Joined: Nov 17, 2015 2:29 pm
Full Name: Kevin Parr
Contact:

Re: New vCenter plugin for 9.5U1 for Enterprise Manager

Post by Kev Parr » Feb 01, 2017 2:33 pm 1 person likes this post

Dave - for my environment we had to completely remove and re-install the plugin using the Veeam instructions supplied by foggy above. It did eventually work but i had to restart the web client services several times on all of my VC servers for it to eventually work. Perseverance is the key!!

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests