Discussions specific to the VMware vSphere hypervisor
Post Reply
grokit
Novice
Posts: 7
Liked: never
Joined: Mar 07, 2013 12:50 pm
Full Name: Daniel
Contact:

Problem with Installation on Server 2012 (Case 00209782)

Post by grokit » May 24, 2013 2:33 pm

I am trying to move a Veeam installation from one Windows Server 2012 (HP ML110) to another Windows Server 2012 (ML350G5). Unfortunately, I am not able to install Veeam Backup on that new Windows Server 2012.
I'm a bit surprised, since the installation worked fine on the first Server 2012.

The only difference between the servers, beside the HW, is that on the second server Hyper-V was installed. I uninstalled it but the Veeam installation still fails.

The error is related to SQL: "The setup was unable to install new instance of Microsoft SQL Server. Make sure this server meets minimum system requirements, or try installing it manually."

According to my check, the server meets all the criteria for SQL Server. Unfortunately I did not find instructions how to install the SQL Server manually.

Anyone has an idea how to proceed? Support was online on the system but was not able to find the problem.

Thanks

Dan

Vitaliy S.
Product Manager
Posts: 23300
Liked: 1630 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Problem with Installation on Server 2012 (Case 00209782)

Post by Vitaliy S. » May 24, 2013 2:36 pm 1 person likes this post

Hi Dan,

You may want to download SQL Server Express 2012 via this link and then start the setup process as you would normally do for any other application. Keep all the settings to their default values. Once you finish the installation process, try to install Veeam B&R once again (pointing to existing SQL Server at the database creation step of the setup wizard).

Thanks!

grokit
Novice
Posts: 7
Liked: never
Joined: Mar 07, 2013 12:50 pm
Full Name: Daniel
Contact:

Re: Problem with Installation on Server 2012 (Case 00209782)

Post by grokit » May 24, 2013 2:51 pm

Hello Vitaliy,
Thanks for the reply. I already tried that. It looks like I have an issue with regional settings. The server is set to "Deutsch-Schweiz" (German-Switzerland). I know there is a known problem of SQL Server not installing if the regional settings are not matching. I am currently trying to figure out how to install anyway. The usual workaround, temporarily setting the locale to Deutsch-Deutschland and English-USA, does not work on Server 2012 as it neems (it usually works on Windows 2008 R2).

For reference, here is the error message when I install the SQL Express 2012:
Image

Any help is appreciated.

Thanks
Dan

Vitaliy S.
Product Manager
Posts: 23300
Liked: 1630 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Problem with Installation on Server 2012 (Case 00209782)

Post by Vitaliy S. » May 24, 2013 3:29 pm

Dan, have you tried to install the MUI package or this is not an option for you? Thanks!

grokit
Novice
Posts: 7
Liked: never
Joined: Mar 07, 2013 12:50 pm
Full Name: Daniel
Contact:

Re: Problem with Installation on Server 2012 (Case 00209782)

Post by grokit » May 24, 2013 4:36 pm

Bo, that was not an option. Thanks for the pointer.

Actually, I was able to install now. The solution was to configure regional settings to Deutsch-Deutschland, AND make sure that the registry entry
HKEY_CURRENT_USER\CONTROL PANEL\INTERNATIONAL\LOCALE
was set to “00000407” (Deutschland).
Mine was set to “00000807” (which is Switzerland) for whatever reason, ever after changing the regional setting to Germany.

After that, Veeam would still not install (probably becasue the embedded SQL setup routine does not handle regional settings the same way), but SQL Express 2012 installed without problems.
After SQL Express 2012 was installed, Veam Backup installed without additional issues.

I still have another problem with Enterprise Server not connecting to the right backup server. But that is another issue.

Thanks a lot for your help.

Regards
Dan

Vitaliy S.
Product Manager
Posts: 23300
Liked: 1630 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Problem with Installation on Server 2012 (Case 00209782)

Post by Vitaliy S. » May 24, 2013 4:40 pm

Thanks for sharing the solution with the community, much appreciated. As to the EM connection issue, then our technical team would be glad to assist you with this.

Post Reply

Who is online

Users browsing this forum: Paul.Loewenkamp and 37 guests