Discussions specific to the VMware vSphere hypervisor
Post Reply
Vejete
Technology Partner
Posts: 65
Liked: 2 times
Joined: Apr 06, 2017 6:23 pm
Full Name: Jim Turner
Location: Edmond, OK
Contact:

Received an unexpected EOF or 0 bytes form the transport stream.

Post by Vejete »

Home Lab with nested virtualization:
VBR 11 on Server 2019 VM 192.168.122.12 (bart)
ESXi 7.0.0 on VM at 192.168.122.14 (buddy)
Both VMs are on OpenSUSE Leap 15.2 KVM hypervisor 192.168.122.1 (mongo)

Image

bart can ping buddy. buddy can ping bart. mongo can ping both bart and buddy. Everyone can ping everyone. Good layer 3 all around for 192.168.122.0/24, a virtual KVM LAN segment.

I think something's dodgy with the SSL cert on buddy. When I try to add buddy as a vSphere server in VBR, I get the following error after saying OK to the untrusted cert:
Add Server > VMware vSphere > vSphere > buddy.blazing.local > [provide root creds ] > Apply > Cert Sec Alert - Continue > *boom*

Image

So it's getting the cert from buddy but not liking it. Funny thing is, I can login to ESXi on buddy via browser (Brave) from mongo (OpenSUSE Leap 15.2). No problem.

Image

But from bart (Server 2019) using Firefox I cannot get a login page from buddy. After bypassing warnings about the SSL cert, I get this in Firefox:

Image

Checking the ESXi cert from within Veeam when trying to add the host ... seems to look okay.

Image Image

So Firefox browser access and VBR access from bart are a no-go. Could it be a Server 2019 thing? Why can I login to bart from a Brave browser on Linux but not a Firefox browser on Server 2019?

FYI, I did check system times, time zones, DNS name resolution, etc. Nothing obvious popped up. Also re-gen'd the SSL cert on buddy and restarted the host. No help. Same symptoms.

Thanks in advance for all guidance and assistance!
=====
Jim Turner, VMCE 2020
Master Technologist & BURA Evangelist
Hewlett Packard Enterprise

HannesK
Veeam Software
Posts: 8828
Liked: 1586 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Received an unexpected EOF or 0 bytes form the transport stream.

Post by HannesK »

Hello,
I searched a little bit and normally that issue seems to be related to DNS / port / anti-virus / firewalls.
Funny thing is, I can login to ESXi on buddy via browser (Brave) from mongo (OpenSUSE Leap 15.2)
I don't get that sentence. But you need to be able to access from bart to buddy directly. see https://helpcenter.veeam.com/docs/backu ... ml?ver=110

For further investigations please provide a support case ID for this issue, as requested when you click New Topic.

I also use unsigned certificates in my lab since "always" and it works fine.

Best regards,
Hannes

Vejete
Technology Partner
Posts: 65
Liked: 2 times
Joined: Apr 06, 2017 6:23 pm
Full Name: Jim Turner
Location: Edmond, OK
Contact:

Re: Received an unexpected EOF or 0 bytes form the transport stream.

Post by Vejete »

Thank you @HannesK for your response. Are we allowed to open a support case for home lab issues? If so, I certainly will.

DNS is solid, I'm using the standard port (443), and I have disabled all firewalls and AV.

Sorry my sentence was confusing. Brave is a browser, basically a de-Googled Chrome. I can login to my ESXi host using Brave running on Linux. But I cannot login to my ESXi host using Firefox running on Server 2019 where VBR resides. That's the distinction I was trying to draw. It appears Server 2019 and/or Firefox doesn't like something about the ESXi cert. Whatever it is, it seems to be irritating Veeam, too.

Here's what I see in Svc.VeeamBackup.log when I try to add my ESXi server:

Code: Select all

[04.03.2021 09:05:18] <25> Error        Failed to retrieve service content for host: 00000000-0000-0000-0000-000000000000:buddy.blazing.local:443:19943383-0a1a-45e3-a895-3db51f82ac05
[04.03.2021 09:05:18] <25> Error        Failed to login to "buddy.blazing.local", port 443, user "veeam", proxy srv: port:0 (System.Exception)
[04.03.2021 09:05:18] <25> Error        Server stack trace: 
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CServiceSession.Create(CServiceConnSpec connSpec, CSpsServiceHolder spsServiceHolder, CPbmServiceHolder pbmServiceHolder, CInventoryServiceHolder invServiceHolder, CRawSoapInvokerHolder rawSoapInvokerHolder)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CSoapService..ctor(Guid hostId, String host, CServiceConnSpec connSpec, IHierarchyContentLoader contentLoader, RemoteCertificateValidationCallback validationCallback)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CSoapConnection.Connect(Guid dbHostId, String host, Int32 port, String user, String password, Boolean useProxy, String proxyHost, Int32 proxyPort, IHierarchyContentLoader contentLoader, RemoteCertificateValidationCallback validationCallback)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CSoapConnection..ctor(Guid dbHostId, String host, Int32 port, String user, String password, Boolean useProxy, String proxyHost, Int32 proxyPort, IHierarchyContentLoader contentLoader, RemoteCertificateValidationCallback validationCallback, Boolean useCache)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CSoapConnection..ctor(Guid dbHostId, String hostName, CDBSoapCreds soapCreds, IHierarchyContentLoader contentLoader, Boolean useCache)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.Satellite.CSoapConnectionHolder.Connect(String hostId)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.Satellite.CSatelliteViSoapConnectorServiceStub.GetServiceContent(String hostId)
[04.03.2021 09:05:18] <25> Error           at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
[04.03.2021 09:05:18] <25> Error           at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
[04.03.2021 09:05:18] <25> Error        Exception rethrown at [0]: 
[04.03.2021 09:05:18] <25> Error           at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
[04.03.2021 09:05:18] <25> Error           at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.IViSoapConnector.GetServiceContent(String hostId)
[04.03.2021 09:05:18] <25> Error           at Veeam.Common.Remoting.CRetryableMethod.DoInvoke[Ret](ActionDelegate`1 dlg)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ServiceLib.CViSoapMangementServiceStub.GetServiceContent(String hostId)
[04.03.2021 09:05:18] <25> Error        The underlying connection was closed: An unexpected error occurred on a receive. (System.Net.WebException)
[04.03.2021 09:05:18] <25> Error           at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
[04.03.2021 09:05:18] <25> Error           at VimApi.VimService.GetWebResponse(WebRequest request)
[04.03.2021 09:05:18] <25> Error           at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
[04.03.2021 09:05:18] <25> Error           at VimApi.VimService.RetrieveServiceContent(ManagedObjectReference _this)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CServiceImpl.RetrieveServiceContent(ManagedObjectReference _this)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CServiceImpl.RetrieveServiceContentWithRetry(CServiceImpl service, ManagedObjectReference serviceInstanceRef)
[04.03.2021 09:05:18] <25> Error        --- End of stack trace from previous location where exception was thrown ---
[04.03.2021 09:05:18] <25> Error           at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CServiceImpl.RetrieveServiceContentWithRetry(CServiceImpl service, ManagedObjectReference serviceInstanceRef)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CServiceImpl.Create(CServiceConnSpec connSpec, CookieContainer cookieContainer, ManagedObjectReference serviceInstanceRef)
[04.03.2021 09:05:18] <25> Error           at Veeam.Backup.ViSoap.CServiceSession.Create(CServiceConnSpec connSpec, CSpsServiceHolder spsServiceHolder, CPbmServiceHolder pbmServiceHolder, CInventoryServiceHolder invServiceHolder, CRawSoapInvokerHolder rawSoapInvokerHolder)
[04.03.2021 09:05:18] <25> Error        Received an unexpected EOF or 0 bytes from the transport stream. (System.IO.IOException)
[04.03.2021 09:05:18] <25> Error           at System.Net.Security._SslStream.ProcessFrameBody(Int32 readBytes, Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
[04.03.2021 09:05:18] <25> Error           at System.Net.Security._SslStream.StartFrameHeader(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
[04.03.2021 09:05:18] <25> Error           at System.Net.Security._SslStream.StartReading(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
[04.03.2021 09:05:18] <25> Error           at System.Net.Security._SslStream.ProcessRead(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
[04.03.2021 09:05:18] <25> Error           at System.Net.TlsStream.Read(Byte[] buffer, Int32 offset, Int32 size)
[04.03.2021 09:05:18] <25> Error           at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
[04.03.2021 09:05:18] <25> Error           at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)
That happens when I click the Continue button in this dialog.

Image

I have tried various forms of the ESXi login name in Veeam's credentials config:
veeam@buddy.blazing.local
veeam
buddy\veeam
buddy.blazing.local\veeam

Each time I get the same error: Received an unexpected EOF or 0 byes from the transport stream.

And I re-verified that I can login to the ESXi web interface as user "veeam" and that it is an Administrative user in ESXi just like root.

I never imagined getting a home lab running would be this difficult. But at least it's good troubleshooting experience!
=====
Jim Turner, VMCE 2020
Master Technologist & BURA Evangelist
Hewlett Packard Enterprise

soncscy
Veeam Legend
Posts: 489
Liked: 241 times
Joined: Aug 04, 2019 2:57 pm
Full Name: Harvey Carel
Contact:

Re: Received an unexpected EOF or 0 bytes form the transport stream.

Post by soncscy » 1 person likes this post

Check if Edge/IE can access it and triple check proxy settings.

That browsers cannot connect means this is not really a Veeam issue, you have some routing issue between the Windows Server and the host or an SSL issue.

I suggest reproduce the issue (with Veeam I guess) while doing a wireshark capture. Look at the communication at that time first just unfiltered, then check the SSL communication.

HannesK
Veeam Software
Posts: 8828
Liked: 1586 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Received an unexpected EOF or 0 bytes form the transport stream.

Post by HannesK »

That browsers cannot connect means this is not really a Veeam issue,
that's the point. I saw that in some support cases. It has nothing to do with Veeam.

Post Reply

Who is online

Users browsing this forum: Mildur, mriesenbeck and 13 guests