Discussions specific to the VMware vSphere hypervisor
Post Reply
pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Selected database has one or more unsupporte ESXi or vCenter

Post by pidthepiper » Sep 10, 2015 8:55 am

Hi,

I am getting this error when I try to install Veeam v8 on a new 2012 vm and direct it to use the database used by Veeam v6.5

It database is on an external SQL 2008 R2 VM.

I don't get what the error is referring to exactly?

The database is at SQL 2005 (90) compatibility Level, the error comes just after it says it will upgrade the database if needed.

Cheers,

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 9:01 am

Bilal, the error refers to the fact that the database contains some of the older VI 3.5 servers (ESX(i) 3.5, vCenter 2.5), which were supported in v6.5, however not unsupported in v8. I think if you remove those from v6.5 installation, the upgrade should go fine.

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 9:03 am

Let me investigate!

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 9:51 am

OK there is an ESX 3. host, it has a couple of VMs that I would like to backup, but I get the error "Your Veeam Backup license does not allow the processing of free ESXi."

I have an Enterprise license ? why would this be an issue?

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 10:13 am

Do you have a paid VMware license covering this ESXi host? Veeam B&R is not allowed to process free ESXi host (the message itself is somewhat confusing).

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 10:42 am

it has a valid license, either way I have removed it and the setup has started and then failed for some reason

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 10:52 am

Did it fail with the same or different error?

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 11:00 am

Well the first time it started installing and then backed out.

After a reboot I got 2 errors while it tried to install the NetApp Plugin and another vendor lugin:
Unable to connect to SQL Server the login failed.

But it finished installing

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 11:13 am

You can try to repair the installation to see whether the errors persist and contact support i case they do.

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 11:16 am

Well those plugins dont even matter to me, we run Dell Compellent

Do I have to edit each job and update the credentials ??

Do I have to readd my repositories, as I am unable to find the bit to edit the login details?

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 11:26 am

Credentials update should not be required in case of upgrade.

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 11:28 am

Well all the jobs are there and everything, well its a totally new VM pointing to the old 6.5 current database?

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 11:30 am

Could you clarify your last question, please?

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 11:32 am

Ah, sorry, in case of remote DB you would need to re-enter credentials, right (since they are encrypted with a machine-specific key).

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 11:34 am

How do I re enter the username/pass for the backup repositories? I click on their properties and I don't see anything regarding logins?

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 11:44 am

Credentials are specified while you add server that holds the repository to Veeam B&R console, not in the repository wizard.

pidthepiper
Enthusiast
Posts: 80
Liked: 7 times
Joined: Aug 11, 2015 9:10 am
Full Name: Bilal AHmed
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by pidthepiper » Sep 10, 2015 12:31 pm

dont mind me I was being stupid I have figured it all out and it seems to be running!

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Sep 10, 2015 12:38 pm

No problem, glad I could help. Feel free to ask any further questions, if required.

MaLa
Lurker
Posts: 1
Liked: never
Joined: Jun 06, 2016 7:29 am
Full Name: Mario Labella
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by MaLa » Jun 06, 2016 7:37 am

Hello everybody,

I have unfortunately the same Error "Selected database has one or more unsupporte ESXi or vCenter" while attempting to Update from Version 8 to 9. Our VCenter was launched with Version 5.5, so there can't be an older Version. Therefore I do not understand this error message ...

Maybe you have an idea what could be the cause? Unfortunately I see no error :(

Thanks in advance
Regards Mario

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Jun 06, 2016 3:03 pm

Hello Mario, any chance some of the older ESXi servers were previously added to this Veeam B&R installation? Anyway, you need to contact technical support for the database cleanup.

masonit
Service Provider
Posts: 232
Liked: 16 times
Joined: Oct 09, 2012 2:30 pm
Full Name: Magnus
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by masonit » Aug 31, 2016 2:58 pm

Hi

Trying to upgrade from v8 to v9. But get error about old esx servers. The error is correct. One of many vcenters has 4 esx hosts with version 4.0. Plan is ofcourse to either upgrade or remove these hosts. But is there a way around this? Why can't I even upgrade..? We don't backup any vms on thoose hosts..

/Masonit

foggy
Veeam Software
Posts: 18366
Liked: 1576 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by foggy » Aug 31, 2016 3:13 pm

Are you sure those hosts are not explicitly added as standalone in Veeam B&R UI? In case only vCenter is added, unsupported hosts under it shouldn't block the upgrade.

masonit
Service Provider
Posts: 232
Liked: 16 times
Joined: Oct 09, 2012 2:30 pm
Full Name: Magnus
Contact:

Re: Selected database has one or more unsupporte ESXi or vCe

Post by masonit » Sep 01, 2016 8:20 am

Ok then it should not be a problem. I got this error on a test vbr server. After that it started to look up if there was old esx servers connected to our production vbr servers. I haven't actually tried to upgrade production yet.

\Masonit

Post Reply

Who is online

Users browsing this forum: Google [Bot], hmalik and 14 guests