Discussions specific to the VMware vSphere hypervisor
Post Reply
kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

surebackup applicae IP issue

Post by kte » Aug 12, 2013 8:16 pm

We are configuring sure backup in a 10.100.1.x /255.255.254.0 environment, but the masking network in the virtual lab appliance is always a class B (172.20.x.x) in stead of /23
And if we take 10.100.2.254 /255.255.254.0 the masking IP can be 172.20.2.x.
But all the main production servers are a 10.100.1.x /255.255.254.0 range, is this a bug or another reason.
Can we modify this on the Linux appliance directly

K

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 13, 2013 9:00 am

Hi, Koen. Could elaborate on your issue a little bit? I'm asking since I’ve just tried to specify given IP/mask and returned masquerade address was 10.255.2.x, as expected. Thanks.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 13, 2013 6:11 pm

it seem it is just that range that is not working 10.100.0.x /255.255.254.0 it only proposes 172.20.x.x. So it seems it is not calculating the correct network for a 10.100.0 , the zer cause the issue
But if we use 10.100.2.x/255.255.254.0 we can use 172.20.2.x which is good. But all the main production servers are in the 10.100.0.x range so I can't do surebackup or restore AD, SQL, exchnage 2007 and uair
support case number is 00428818

K

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 14, 2013 9:28 am

Hmm. seems to be a bug, indeed; though, based on quick test I’ve done with v7, it appears to be fixed there. Anyway, let’s wait and see what support team says about it. Thanks.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 14, 2013 8:40 pm

Got support they said to try with 10.100.0.x /255.255.254.0 masked as 172.20.x.x.
It seems to work on 1 machine I tested, but I still need to test all the routing between the other subnets.
And create an actual AD / SQL /sharepoint application group and test all the functions

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 15, 2013 4:34 am

Kindly keep us updated about the results you get. Anyway, as mentioned, this bug seems to be fixed in the upcoming version of VB&R; so, stay tuned. Thanks.

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 16, 2013 7:41 am

Hi, Koen. Just checked this scenario in version 7 and everything appears to work as expected. So, it might be worth updating. Thanks.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 17, 2013 9:47 pm

Any ideaa how many nics the proxy can have in v7 because in v 6.5 it where only 3 nics for the isolated networks

Vitaliy S.
Product Manager
Posts: 23001
Liked: 1557 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: surebackup applicae IP issue

Post by Vitaliy S. » Aug 18, 2013 8:11 pm

Do you mean the proxy appliance? Just upgrade its virtual hardware version to the latest available, and you'll have more than 3 NICs to use in the setup.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 19, 2013 6:13 pm

ok so I need a version 7 or 9 ??

Vitaliy S.
Product Manager
Posts: 23001
Liked: 1557 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: surebackup applicae IP issue

Post by Vitaliy S. » Aug 19, 2013 7:11 pm

Doesn't matter, as both options will give you an ability to use more NICs.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 19, 2013 10:32 pm

because in 6.5 , no virtuall HW upgrade it said that we need to contact support to add more nics, but this means the virtual HW upgrade?

K

Gostev
SVP, Product Management
Posts: 24804
Liked: 3566 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: surebackup applicae IP issue

Post by Gostev » Aug 19, 2013 10:45 pm

Yes.

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 20, 2013 8:31 am

Actually, this trick, as well as, many other interesting ones, is mentioned in 6.5 Surebackup Configuration Guide written by Ben Milligan; so, it might be worth taking a look.
You can only add up to 4 networks here to the virtual lab, as this is the limit for VM Hardware version 4 of VMware (VI3). You can however increase this ability, by updating the virtual machine to version 7/8 hardware version of VMware. Simply right click on the virtual lab virtual machine in vSphere client after creation, and select Upgrade Virtual Hardware. This will allow you to add additional network connections to the lab, up to 10.
Thanks.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 29, 2013 4:53 pm

After upgrading to version 7 , I still have the issue with the ip masquerading and I can't define any isolated IP vlan id's , because when I add a nic all become the same

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 30, 2013 8:25 am

As mentioned, I’ve already tried several tests with version 7 and the situation with vLab proposing only B-class network shouldn’t be the case any longer:

Image

So, if you experience different behaviour, it might be worth contacting our support team and letting them investigate it directly. Thanks.

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 30, 2013 9:56 am

As to the VLAN issue, it stands to reason to recreate previously-used Virtual Lab and see whether you’re able to specify correct VLAN in the settings of newly-created Virtual Lab. Thanks.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Aug 30, 2013 1:57 pm

If i put 10.255.0.x is says 10.255.x.x but I'll change the masquerading IP

I recreate my lab and the vlan issues stays in mapped networks if I add a second network all network have the same vlan

K

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Aug 30, 2013 2:07 pm

Hmm, 10.255.0.x is an IP address, and what is the mask you’re trying to specify? 255.255.254.0? Thanks.

kte
Expert
Posts: 172
Liked: 7 times
Joined: Jul 02, 2013 7:48 pm
Full Name: Koen Teugels
Contact:

Re: surebackup applicae IP issue

Post by kte » Sep 01, 2013 10:56 pm

OK the applicance seems to be working
10.255.0.x is an IP address, and what is the mask you’re trying to specify? 255.255.254.0
correct , then I have the full rang
I changed it to use 10.255.2.x now

K

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: surebackup applicae IP issue

Post by veremin » Sep 02, 2013 8:06 am

Glad to hear that you’ve finally solved your issue. Should any additional questions arise, don’t hesitate to let us know. Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests