SureBackup VM ping error

VMware specific discussions

SureBackup VM ping error

Veeam Logoby fwiersch » Thu Sep 15, 2016 12:47 pm

Hello,

I try to test SureBackup but it failed every time with the ping test to the VM.

My setup is:

Production Network is on 10.140.0.0/24
Veeam B&R Server IP: 10.140.0.10
Virtual Lab Proxy Appliance IP: 10.140.0.50
Virtual Lab Proxy Appliance vNIC 10.10.7.254 Masquerade IP 10.255.252.x
Network mapping is PROD LAN -> Virutal Lab 1 PROD LAN VLAN ID 104
VM 10.10.4.57 from the PROD LAN 10.10.4.0/22 GW 10.10.7.254

Ping Veeam B&R Server -> Virtual Lab Proxy Appliance IP OK
Proxy vNIC1 -> VM OK
Ping VM -> Proxy vNIC1 OK
VM -> Proxy Appliance IP OK
Veeam B&R Server -> VM failed

Veeam Backup Server Routing Table:
10.255.252.0/22 GW 10.140.0.50 NIC 10.140.0.10

Hearthbeat test of the VM is OK.

Hope somebody can give my a hint whre the problem is.
fwiersch
Novice
 
Posts: 5
Liked: never
Joined: Wed Jun 01, 2016 7:53 am

Re: SureBackup VM ping error

Veeam Logoby fwiersch » Thu Sep 15, 2016 1:50 pm

10.140.0.0/24 is the produktion network for the B&R Server, VMWare Host, etc.
10.10.4.0/22 is the network of the VM.
fwiersch
Novice
 
Posts: 5
Liked: never
Joined: Wed Jun 01, 2016 7:53 am

Re: SureBackup VM ping error

Veeam Logoby PTide » Thu Sep 15, 2016 2:47 pm

Hi,

Just to make sure I got everything right:

1.You can ping 10.10.4.57 (production VM) from VBR (10.140.0.10)

2. You can ping 10.140.0.50 (proxy appliance) from VBR (10.140.0.10)

3. You can ping 10.10.4.57 (production VM) from proxy appliance

4. You can ping 10.255.252.57 (VM inside vLab) from proxy appliance

5. You can ping 10.10.7.254 (GW) from VM that is located inside the vLab

6. You cannot ping 10.255.252.57 (VM inside vLab) from VBR.

Is that correct?

Also what IP have you specified as a default gateway in "Proxy" step in vLab settings?

Thanks
PTide
Veeam Software
 
Posts: 3017
Liked: 245 times
Joined: Tue May 19, 2015 1:46 pm

Re: SureBackup VM ping error

Veeam Logoby fwiersch » Thu Sep 15, 2016 2:58 pm

Yes thats correct except nr 4.

I can't ping 10.255.252.57 (VM inside vLab) from proxy appliance

GW for the proxy appliance is 10.140.0.1
fwiersch
Novice
 
Posts: 5
Liked: never
Joined: Wed Jun 01, 2016 7:53 am

Re: SureBackup VM ping error

Veeam Logoby PTide » Thu Sep 15, 2016 3:18 pm

Could you please post the output of route print from VBR and the output of iptables -L -t nat -nv from proxy appliance?

Thanks
PTide
Veeam Software
 
Posts: 3017
Liked: 245 times
Joined: Tue May 19, 2015 1:46 pm

Re: SureBackup VM ping error

Veeam Logoby fwiersch » Thu Sep 15, 2016 4:05 pm

iptables output:

Code: Select all
Chain PREROUTING (policy ACCEPT 1 packets, 326 bytes)
pkts bytes target prot opt out source destination
0 0 NETMAP all -- * 0.0.0.0/0 10.255.252.0/22 10.10.4.0/22

Chain INPUT (policy ACCEPT 1 packets, 326 bytes)
pkts bytes target prot opt out source destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt out source destination

Chain POSTROUTING (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt out source destination
0 0 ACCEPT all -- * 0.0.0.0/0 0.0.0.0/0 mark match 0x2
0 0 MASQUERADE all -- eth1 0.0.0.0/0 0.0.0.0/0


With tcpdump at the proxy appliance i can see:

icmp echo request from 10.140.0.10 to 10.255.252.57 in eth0

icmp echo request from 10.10.7.254 to 10.10.4.57 out eth1
fwiersch
Novice
 
Posts: 5
Liked: never
Joined: Wed Jun 01, 2016 7:53 am

Re: SureBackup VM ping error

Veeam Logoby PTide » Thu Sep 15, 2016 6:26 pm

One thing confuses me a little bit - there is no in column in the iptables output that you've provided. Apart from that everything looks good and should work, so I suggest you to contact support team. Please don't forget to post your case ID.

Thank you
PTide
Veeam Software
 
Posts: 3017
Liked: 245 times
Joined: Tue May 19, 2015 1:46 pm

Re: SureBackup VM ping error

Veeam Logoby fwiersch » Fri Sep 16, 2016 7:41 am

Case #01906863
fwiersch
Novice
 
Posts: 5
Liked: never
Joined: Wed Jun 01, 2016 7:53 am


Return to VMware vSphere



Who is online

Users browsing this forum: Bing [Bot] and 19 guests