Discussions specific to the VMware vSphere hypervisor
Post Reply
dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

[SOLVED] Veam B&R - First backup success but no vmdk backupe

Post by dood » Jan 15, 2013 4:29 pm

Hi everyone,

I setup a Veeam B&R 6.5 backup solution.

Here is quickly the configuration :

Site A : vSphere (a 2 hosts failover)
Site B : One physical backup deicated server (Windows 2008 R2).
Site A and B are communicating through VPN.

I configure Veeam B&R, add my first backup job and run it.
Everything went fine but it takes less than 1 minute to complete a 20GB backup through a WAN connection ! (so powerfull !! :mrgreen: ).

When i try "Restore VM files", only .vmx, .vmxf and .nvram are checked. If i check the .vmdk i get the following error :
"file "xxx.vmdk" is not present in the backup at this restore point".

It seems that the vmdk is not included in the backup.
I start the backup with "Active Full"
The total size indicated in the Virtual Machine to backup in the Job are 22GB.
I try with another VM, same problem

I try many things, check Google and Forums but can't find what i miss (i'm sure it's something stupid :| ).

So if someone get an idea, you're welcome.

dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by dood » Jan 15, 2013 4:52 pm

For information, Veeam Server is not integrated in the Active Directory domain (running as a stand-alone "workgroup" server)

foggy
Veeam Software
Posts: 18263
Liked: 1561 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by foggy » Jan 15, 2013 5:29 pm

dood wrote:Everything went fine but it takes less than 1 minute to complete a 20GB backup through a WAN connection ! (so powerfull !! :mrgreen: ).
Obviously, the virtual disk was not copied during VM processing for some reason. Could you please check the job session for possible reasons? Do you have a support case open for this issue?

Gostev
SVP, Product Management
Posts: 24789
Liked: 3523 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by Gostev » Jan 15, 2013 6:02 pm

What type of virtual disk this VM is using?

dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by dood » Jan 15, 2013 6:28 pm

I just double check everything, i can't find any error logs.
Can't open a support case today as my paid licence doesn't appear on my Veeam account, should contact my reseller which is not available today ... (Murphy's law).

Expected size [574] of the file [[PROD-A] BES/BES.vmdk] ... the file is 20GB :roll:

Gostev : thick eager zeroed for this VM

dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by dood » Jan 15, 2013 6:52 pm

It seems to work on another VM (linux - thin provisioning) which is running on the same vSphere ...

EDIT : Note that some years ago we were in ESX 3.5, the first VM i try to backup was already existing at this time, not the second one which seems to work.
All VM are in version 8.

foggy
Veeam Software
Posts: 18263
Liked: 1561 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by foggy » Jan 15, 2013 9:04 pm

Please avoid posting log snippets, as it is explained when you click New Topic.

I was talking about the job session log, which can be found under the History node. Right-click the required session and select Statistics to display particular job run details. You can also select the VM to the left to see its processing steps outlined. Usually, if some disk has unsupported type and is skipped (physical RDM, independent or connected via in-guest iSCSI initiator), corresponding event is logged there.

dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by dood » Jan 15, 2013 10:01 pm

Sorry about log snippets.

In session log everything is fine, server's backup is "successfull". (no error)

The backup of other VM (linux) complete successfully (right size, everything is fine).
I just tried a third VM (a Windows 2003 Server which already exists in the old ESX 3.5 / thick provision eager zeroed) and it seems to be ok too.

The issue seems to appear only on the first VM I try (I'll try tomorrow the other 8 vm to confirm).

I can see under vSphere creating/removing snapshots for backuped VM (the all 3).
I see a VMNAME-ctk.vmdk (~1MB) next to the VMNAME.vmdk in the datastore, this is for Change Block Tracking, should i try to remove it ?

Gostev
SVP, Product Management
Posts: 24789
Liked: 3523 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by Gostev » Jan 16, 2013 8:34 am

Make sure the disk is not set to Independent, and contact our support for further troubleshooting.

dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by dood » Jan 16, 2013 11:45 am

Damn, you're right the option "independent" was checked (only on this VM i don't know why, maybe since many years ...) !
foggy said to check that yesterday, i missed it.

So everything is fine now.

Thanks a lot for your help !!

dood
Enthusiast
Posts: 28
Liked: 4 times
Joined: Aug 23, 2010 12:32 pm
Contact:

Re: Veam B&R - First backup success but no vmdk backuped

Post by dood » Jan 16, 2013 11:46 am

Can someone add "solved" in the topic title ?

Post Reply

Who is online

Users browsing this forum: No registered users and 42 guests