Discussions specific to the VMware vSphere hypervisor
Post Reply
liviui
Novice
Posts: 5
Liked: 2 times
Joined: Oct 19, 2010 8:42 am
Full Name: Liviu Ianasi
Contact:

Veeam 6.5 cannot view vms on ESXi 5

Post by liviui » Dec 21, 2012 10:56 am

I've upgraded to version 6.5 and since ESXi 5.0 are no longer accessible. I can add a standalone host but the discovery process failes to display any virtual machines with error "Object reference not set to an instance of an object".
I've installed a brand new virtual machine, put Veeam on it and tried again with same result.

Anyone know what could be?

Edit: ESXi 4.1 and 5.1 host are ok.

Vitaliy S.
Product Manager
Posts: 23005
Liked: 1560 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by Vitaliy S. » Dec 21, 2012 11:29 am

I haven't heard any similar issues reported on our forums. Maybe the upgrade process didn't go as expected? What is your support ticket number?

liviui
Novice
Posts: 5
Liked: 2 times
Joined: Oct 19, 2010 8:42 am
Full Name: Liviu Ianasi
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by liviui » Jan 07, 2013 11:51 am

Hello and sry for not getting back sooner as i've been on holiday.
So the problem seems to be with communication between Veeam 6.5 and ESXi 5.1 hosts installed with Dell custom image. Servers are Dell R720 and because of the Broadcom network adapters I could not install the standard ESXi 5.1 from Vmware (no drivers for this adapter) but this custom dell esxi 5.1.

So version 6.5 does not like the custom esxi from Dell. Have no idea what could be - still searching.
Opened a support case 00170978 - don't know if Veeam Technical support can help.

liviui
Novice
Posts: 5
Liked: 2 times
Joined: Oct 19, 2010 8:42 am
Full Name: Liviu Ianasi
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by liviui » Jan 08, 2013 7:53 am

Update.
After troubleshooting with support the veeam backup database with no results (cleaned up some duplicated hosts) i decided to do an experiment.
Installed a fresh machine with Veeam 6.1 (my previous version) and pointed it to 2 of my ESXi 5.1 hosts. Both host are discovered ok and can view and add vms to jobs.
Second installed a fresh machine with Veeam 6.5 and pointed it to same ESXi hosts. On host installed with standard Vmware ESXi iso everything ok, but on dell server installed with custom Dell iso same error "Object reference not set to an instance of an object" - veeam 6.5 cannot view my NFS datastores.

Anyone out there using dell servers that might share if they've seen something like this?

bgbGsy
Influencer
Posts: 18
Liked: 2 times
Joined: Sep 10, 2009 7:40 pm
Full Name: Brendan Bougourd
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by bgbGsy » Jan 08, 2013 8:23 am

Hi Liviui.

Are you accessing the esxi host thru a vcenter or directly? Intertesting that 6.1 works becuase I didnt think that what supported on 5.1

Is it possible that the dell image has some the the firewall ports etc closed that the standard image does not?

What build of the Dell image are you using? Build 799733 is dated 26/12/12.

I am in the process of testing an R720 with the dell 5.1 custom image, so will try and replicate your findings if you can give me as much detail as possible.

liviui
Novice
Posts: 5
Liked: 2 times
Joined: Oct 19, 2010 8:42 am
Full Name: Liviu Ianasi
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by liviui » Jan 08, 2013 9:13 am

Hi bgbGsy,

All Dell servers are using build 914609 - that is Dell iso 799733 and 5 more updates with UpdateManager.
When i try to access thru vcenter error pops up. When i access individual esxi hosts the non-dell are accessible.
Firewall was my first thought too but checked several times and then disabled it completely but no go. Manually tested the 3 ports veeam needs to use 902, 443, 22 - all ok.

liviui
Novice
Posts: 5
Liked: 2 times
Joined: Oct 19, 2010 8:42 am
Full Name: Liviu Ianasi
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by liviui » Jan 08, 2013 4:14 pm 2 people like this post

Ok. After 4h with support we managed to find the problem and i'm writing it here maybe someone else will run into it.

So our Dell R720 servers were specifically customized for ESXi and NFS datastores (no sas adapters, cd-rom, and hypervizor on flashcard).
So the host ended up with no Storage Adapters.

Seems new version 6.5 searches for some storage adapter and if it finds none it will not display NFS datastores and crash the host discovery process.
Older hosts that had some kind of storage adapter were just fine.

The solution (workaround) was to add the software iSCSI adapter and voila the host discovery ran fine and all vms were available.

Maybe a patch or hotfix will be released in the future. If an admin reads this the workaround could get to the FAQ section.

foggy
Veeam Software
Posts: 18287
Liked: 1568 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Veeam 6.5 cannot view vms on ESXi 5

Post by foggy » Jan 09, 2013 1:16 pm

Liviu, thanks for updating the thread with the workaround. I've forwarded the information to the dev team.

Post Reply

Who is online

Users browsing this forum: charley.hinton and 14 guests