Discussions specific to the VMware vSphere hypervisor
Post Reply
balma01
Certified Trainer
Posts: 26
Liked: 3 times
Joined: Jan 01, 2006 1:01 am
Contact:

veeam 9 always use NBD transport mode

Post by balma01 » Feb 19, 2016 4:40 pm

Hi, my proxy is a windows 2012 machine that can access via iscsi my HP VSA iscsi volumes: if I open the disk manager I see all the HP VSA volumes in offline mode.
When I start a backup job, that has to backup some VMs stored in one of those volumes, using this proxy, I see that the proxy is using NBD transport mode. I tried to force the DIRECT STORAGE ACCESS without the failover to network mode option but the proxy always uses the NBD transport mode. I've tried to use MANUAL SELECTION to connect the datastores to the proxy but the resukts is always the same: the proxy uses the NBD transport mode and not the direct access.

foggy
Veeam Software
Posts: 18024
Liked: 1530 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: veeam 9 always use NBD transport mode

Post by foggy » Feb 19, 2016 4:51 pm

There should be the reason of why direct SAN mode cannot be used (access issues, for example) in the job debug logs, so I encourage you to contact technical support for logs review. Thanks.

haslund
Veeam Software
Posts: 532
Liked: 94 times
Joined: Feb 16, 2012 7:35 am
Full Name: Rasmus Haslund
Location: Denmark
Contact:

Re: veeam 9 always use NBD transport mode

Post by haslund » Feb 21, 2016 12:45 pm

Does the Backup Proxy have multiple paths to the iSCSI storage?
Did you enable MPIO/multipathing software?
Rasmus Haslund
Principal Technologist, Global Education Services @ Veeam Software
Veeam Certified Architect #1 | Veeam Certified Trainer #4 [v7,v8,v9] | Veeam Certified Trainer Mentor #1
Twitter: @haslund
Blog: www.perfectcloud.org

balma01
Certified Trainer
Posts: 26
Liked: 3 times
Joined: Jan 01, 2006 1:01 am
Contact:

Re: veeam 9 always use NBD transport mode

Post by balma01 » Feb 25, 2016 11:02 am 1 person likes this post

I've investigated the issue and it was caused by an iscsi misconfiguration. Now it works as designed.

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests