Discussions specific to the VMware vSphere hypervisor
Post Reply
slakic
Novice
Posts: 5
Liked: never
Joined: Jan 31, 2014 6:48 am
Full Name: Slobodan Lakic
Contact:

Veeam Backup and replication causes vSphere HA error

Post by slakic » Jan 31, 2014 6:57 am

Hi All,

I am having problem with backing up couple of VMs using Veeam Backup and replication 7. From the Veeam perspective, everything is without error, and backup is done, but vSphere HA monitoring error is generated, which caused VM restart. After the restart some of the services cannot start properly e.g. Mysql (It is a CentOS machine). Also, during the process, connection to the VM is down for about 10 minutes.

Any ideas

Vitaliy S.
Product Manager
Posts: 23880
Liked: 1754 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by Vitaliy S. » Jan 31, 2014 8:52 am

Hi Slobodan,

What kind of VMs are affected by this behavior? Does this error occur when VM snapshot is being committed (you can correlate that by the time stamps of snapshot commit events and HA errors)?

Thanks!

veremin
Product Manager
Posts: 17633
Liked: 1594 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by veremin » Jan 31, 2014 8:59 am

Also, can this issue be reproduced manually by taking the snapshot of VM manually, keeping the snapshot open for the same time as backup normally takes, and then deleting it? Thanks.

slakic
Novice
Posts: 5
Liked: never
Joined: Jan 31, 2014 6:48 am
Full Name: Slobodan Lakic
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by slakic » Jan 31, 2014 7:37 pm

HA monitoring error is generated at the end of the process, during snapshot removal.

Gostev
SVP, Product Management
Posts: 26119
Liked: 4067 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by Gostev » Jan 31, 2014 11:42 pm

Then this is by VMware snapshot design. Either increase monitoring timeouts, or get a faster storage to reduce VM stun times during snapshot commit.

slakic
Novice
Posts: 5
Liked: never
Joined: Jan 31, 2014 6:48 am
Full Name: Slobodan Lakic
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by slakic » Feb 10, 2014 7:40 am

I would thing so, but what's interesting, it only happens with one virtual machine. I increased the timeout, and now vSphere HA doesn't restarts the machine, but still during snapshot removal process, virtual machine is unavailable 7 - 10 minutes, and during that time I am not able to do anything with it, not even restart. I have other virtual machines which are more demanding in perspective of disk space, and don't have similar problems.

veremin
Product Manager
Posts: 17633
Liked: 1594 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by veremin » Feb 10, 2014 8:37 am

Seems like some VM specific issue. I recommend you to reproduce this issue manually, using procedure described above, and, then, open a ticket with VMware support and let them confirm your environment, or, more specifically, VM in question.

Thanks.

dellock6
Veeam Software
Posts: 5893
Liked: 1715 times
Joined: Jul 26, 2009 3:39 pm
Full Name: Luca Dell'Oca
Location: Varese, Italy
Contact:

Re: Veeam Backup and replication causes vSphere HA error

Post by dellock6 » Feb 10, 2014 1:16 pm

Any chance you are using guest monitoring, and the missing heartbeat from VMtools is intercepted by HA launching e restart? Just a guess...

Luca.
Luca Dell'Oca
Principal EMEA Cloud Architect @ Veeam Software

@dellock6
https://www.virtualtothecore.com/
vExpert 2011 -> 2020
Veeam VMCE #1

Post Reply

Who is online

Users browsing this forum: gabbas and 28 guests