Veeam V9 update 1 Component Upgrade still present

VMware specific discussions

Veeam V9 update 1 Component Upgrade still present

Veeam Logoby abelliniSIBA » Fri Aug 05, 2016 2:20 pm 1 person likes this post

Hi,
after the upgrade to the last version 9.0.0.1491, i restarted the server and upgraded all component to the last version with the standard procedure proposed.
Even after the upgrade the component upgrade window still appears new i connect to the console and no component are listed inside the window.
I opened i support case with Veeam and with shared a webex session, we installed an update 2 pack 9.0.0.1751.
This update haven't resolved this problem and they ask me to:
1.try to reinstall the server on a new VM to check if the problem persist;
2.send to them the backup of the server DB.

As it is the 7/8 server that i upgraded to this version and this is the first time that appears, i decided to keep the first option as the last option to try (i have a full backup of this server, with backup configuration as well); I studied a little bit the Veeam Database and i was sure it was just a dirty record on the DB, i found a mistake under one table of the Dabatase under the dbo.HostComponents table:
2 records under this table was not updated, DeploySvcClientOption and TransportClientOption,DataTransferOption was set to last version 8 with the correspondant field "is_up_to_date" set to 0 (False);
i made a backup of this table and checked the version of the mismatched updated component based on the SID of the referred machine:
1.%ProgramFiles%\Veeam\Backup and Replication\VSS\sql\VeeamTransportDll_x64.dll --> 9.0.0.1715
2.%ProgramFiles%\Veeam\Backup and Replication\Packages\VeeamDeploymentDll.dll --> 9.0.0.1715

I made the change on the table and set "is_up_to_date" to 1 (True).
I restarted the Veeam Backup service and the component upgrade window does not appear anymore!
Performed a test of backup for 3 VMs, and it works fine. Probably somethings goes wrong during the update process? (no errors were listed on logs..)
I don't suggest you to do it directly on your server under production as my server was a DEV server for virtual lab :P

I posted this article just to share with you my experience not to replace the support expertise!
Have a nice summer guys!

Regards from rainy day in Paris :(
Alessandro
abelliniSIBA
Novice
 
Posts: 9
Liked: 5 times
Joined: Wed Nov 19, 2014 2:01 pm
Full Name: Alessandro Bellini

Re: Veeam V9 update 1 Component Upgrade still present

Veeam Logoby PTide » Fri Aug 05, 2016 2:57 pm

Hi,

Glad that you've resolved it! Could you post an ID of the support case that you've opened please, so we have a reference?

Thanks
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm

Re: Veeam V9 update 1 Component Upgrade still present

Veeam Logoby abelliniSIBA » Fri Aug 05, 2016 8:22 pm

Case # 01870900

Best Regards

Alessandro Bellini
abelliniSIBA
Novice
 
Posts: 9
Liked: 5 times
Joined: Wed Nov 19, 2014 2:01 pm
Full Name: Alessandro Bellini


Return to VMware vSphere



Who is online

Users browsing this forum: Google [Bot] and 33 guests