Discussions specific to the VMware vSphere hypervisor
Titanmike
Enthusiast
Posts: 65
Liked: never
Joined: Apr 16, 2010 1:52 pm
Full Name: ZeGerman
Contact:

vSphere hosts updates - UUID error

Post by Titanmike » Dec 21, 2010 1:30 pm

Hiya,

I just updated all the hosts using the update manager and now the backup failed with
Checking the license for the source host 'xxx'
Failed to validate license for the VM "xxx".
Host with uuid "10201248-00b4-f9d9-9b22-003048f5af08" was not found
This was quite odd. First thing I tried was re-adding the VM inside the task which failed again.
Although I was able to to browse the hosts and they also showed as licensed, I had to remove the whole vCenter from the Veeam server and re-add it which obviously deleted the backup task as well etc.

What would cause this issue ? Does this mean that every time we update the hosts (which might changed the build number) we'd have to re-create every task ?

Titanmike
Enthusiast
Posts: 65
Liked: never
Joined: Apr 16, 2010 1:52 pm
Full Name: ZeGerman
Contact:

Re: vSphere hosts updates - UUID error

Post by Titanmike » Dec 21, 2010 1:44 pm

I just remember I also removed a few snapshots at the same time .. is that related ?

Gostev
SVP, Product Management
Posts: 24793
Liked: 3536 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: vSphere hosts updates - UUID error

Post by Gostev » Dec 21, 2010 2:01 pm 1 person likes this post

No, updating hosts hosts should not affect jobs. There were no changes in licensing code since version 1, and this issue was never reported in all these years, so I think it is safe to assume that the issue is specific to your environment - something went wrong with the update you have performed. More likely though, this issue is completely unrelated to host update at all, but performing some other operation with this host (for example, removing/readding host to vCenter, or something like it - hard to guess). Thank you.

flakpyro
Influencer
Posts: 20
Liked: 5 times
Joined: Feb 08, 2010 10:15 pm
Full Name: David M
Contact:

Re: vSphere hosts updates - UUID error

Post by flakpyro » Feb 01, 2011 10:18 pm

Had the same thing happen today when swapping out hosts for new hardware, the new hardware was named the same as the old and when the first backup job ran the same UUID error was thrown. Solved this by removing references to the old hosts in the database under the table "dbo.hosts", this caused them to be recreated and re licensed and now jobs are running perfectly. :)

Vitaliy S.
Product Manager
Posts: 22991
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: vSphere hosts updates - UUID error

Post by Vitaliy S. » Feb 01, 2011 11:12 pm

David, thank you for finding time to share this information.

Gostev
SVP, Product Management
Posts: 24793
Liked: 3536 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: vSphere hosts updates - UUID error

Post by Gostev » Apr 17, 2011 6:03 pm 1 person likes this post

Recommended & supported way of doing the same thing is Revoke button on About > License dialog. Thanks.

simm0
Novice
Posts: 8
Liked: never
Joined: Nov 16, 2009 9:12 am
Full Name: Simon Thomson
Contact:

Backups fail with "Failed to validate license for the VM "

Post by simm0 » May 23, 2011 5:12 am

This is resolved but I didn't find a lot of reference to it here so I thought I'd post the resolution.

After some issues we had with an ESXi host recently the Veeam jobs backing up VM's on that host started to fail with the following error:

Checking the license for the source host '192.168.xxx.xxx'
Failed to validate license for the VM "VMname".
Host with uuid "080020ff-ffff-ffff-ffff-xxxxxxxxxxxx" was not found


To resolve this issue do the following in Veeam Backup and Replication 5:

1. Click Help --> License Information --> Licensed Hosts --> Select Host --> Revoke.
2. In vSphere create an "empty" VM on the affected host.
3. In Veeam create a backup job to backup the new "empty" VM, run the job.

Once the new backup job has run your other jobs should run successfully again.

Credits:

Nathan Simon
Gostev

Vitaliy S.
Product Manager
Posts: 22991
Liked: 1556 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: vSphere hosts updates - UUID error

Post by Vitaliy S. » May 23, 2011 7:35 am

Hello Simon, thanks for finding time to share this info with the Community. I've merged your topic to the existing discussion. Thanks.

DavidStankard
Lurker
Posts: 2
Liked: never
Joined: Feb 22, 2012 7:51 pm
Full Name: David Stankard

Re: vSphere hosts updates - UUID error

Post by DavidStankard » Jun 13, 2012 5:34 pm

This just happened to me. I removed an old host from vCenter, added the new host (different IP), and everything worked fine. Added my VM's to the new host, went to Veeam, removed the VM's that were on the old host, re-added them from the new host, and thought all was good.

Jobs failed last night, so I looked in the license file. It showed the old host, so I revoked just that one host, and all three disappeared. Re-added the license - no love.

Found this post, did as suggested and ran an "empty" job on all three hosts, and the license file is happy again.

lnmn249
Lurker
Posts: 2
Liked: 2 times
Joined: Jan 05, 2013 1:42 pm
Full Name: Dale Hartung
Contact:

Re: vSphere hosts updates - UUID error

Post by lnmn249 » Jan 05, 2013 1:54 pm 2 people like this post

I updated my hosts last night via update manager and all my backups failed after everything was back to normal. After reading through this post my solution to the problem was simply revoking the licenses for the hosts and restarting the backup and replication jobs with success. I'm glad this post was here else I would have been pulling my hair out for three days. Thanks all!

On a side note my errors contained no licensing reference. I simply happen chanced on this article and it worked,

Dale

cyberfed
Influencer
Posts: 11
Liked: 2 times
Joined: Nov 03, 2011 11:59 am
Contact:

Re: vSphere hosts updates - UUID error

Post by cyberfed » Jan 08, 2013 3:16 pm

FYI this is related to updating your VMware Hosts.

I just updated our hosts with the December 20th ESXi 5.0 Update 2 package that VMware released.
After this one of my VM's would not backup throwing the UUID error. Until now I had never seen or gotten this error doing my Veeam backups.

What I found odd is that only 1 of my VM's encountered this and not all of them. Weird.

Like someone else posted I did NOT have the following messages in my error:
Checking the license for the source host '192.168.xxx.xxx'
Failed to validate license for the VM "VMname".


Mine only had the following error for 1 VM out of 5 in the backup job:
Host with uuid "0404.....ect ect.." was not found

I revoked my hosts and re-ran the jobs. My jobs then worked.

jjblaster
Influencer
Posts: 12
Liked: 2 times
Joined: Apr 03, 2012 3:03 pm
Full Name: Jeremy Scott
Contact:

Re: vSphere hosts updates - UUID error

Post by jjblaster » Jan 08, 2013 8:26 pm 2 people like this post

We experience the same exact issue as cyberfed after updating hosts to 5.0U2. Revoking the license from Enterprise manager resolved the issue for us. Thanks for the update cyberfed.

AndyGDIT
Enthusiast
Posts: 47
Liked: 2 times
Joined: Nov 14, 2011 3:15 pm
Full Name: Andrew Frye
Contact:

Re: vSphere hosts updates - UUID error

Post by AndyGDIT » Jan 09, 2013 1:55 pm

I have also seen this error, revoking the license on the host worked for some of my jobs, but I also re-scanned the vCenter under infrastructure.

Infrastructure --> Managed Servers --> vCenter Servers --> Right Click your vCenter and click Rescan. Took a few minutes but I got it to work.

dellock6
Veeam Software
Posts: 5734
Liked: 1625 times
Joined: Jul 26, 2009 3:39 pm
Full Name: Luca Dell'Oca
Location: Varese, Italy
Contact:

Re: vSphere hosts updates - UUID error

Post by dellock6 » Jan 09, 2013 2:25 pm

Also remember, rescan happens once every 24 hours. I never found when is scheduled to run, but I've trained myself to run a manual rescan everytime a do changes in my environment.
Somewhere else in these forums I already proposed to Veeam to let us change rescan options: in rapidly-changing environments, there are often new ESXi servers, and one cannot always remember to run a rescan everytime. It would be enough to ask for a more frequent rescan.

Luca.
Luca Dell'Oca
Principal EMEA Cloud Architect @ Veeam Software

@dellock6
https://www.virtualtothecore.com/
vExpert 2011 -> 2019
Veeam VMCE #1

nicold
Service Provider
Posts: 13
Liked: 5 times
Joined: Sep 08, 2011 12:47 am
Full Name: Donny Nicol
Contact:

Re: vSphere hosts updates - UUID error

Post by nicold » Jan 16, 2013 2:31 am

I also had the "Host with uuid "080020ff-ffff-ffff-ffff-xxxxxxxxxxxx" was not found" error following a series of ESXi 5.0 VUM updates. Revoking the Veeam licenses and re-running the backup jobs fixed my issue as well.
:D
Wherever you go there you are.

KiwiJJ
Expert
Posts: 105
Liked: 2 times
Joined: Feb 16, 2010 8:05 pm
Full Name: John Jones
Location: New Zealand
Contact:

Re: vSphere hosts updates - UUID error

Post by KiwiJJ » Jan 17, 2013 10:05 pm

I also had this error after applying Update 2 to ESXi 5.0, Have revoked the licenses and will see if the backups run ok tonight.

JeffHengesbach
Novice
Posts: 4
Liked: never
Joined: Mar 08, 2011 4:26 pm
Full Name: Jeff hengesbach
Contact:

Re: vSphere hosts updates - UUID error

Post by JeffHengesbach » Feb 01, 2013 1:31 am

+1 Experienced the same here after applying 5.0 U2. Revoking via Help-> License, then re-running worked.

kevinnaughton
Enthusiast
Posts: 56
Liked: 3 times
Joined: Jun 05, 2012 4:02 pm
Full Name: Kevin Naughton
Contact:

Re: vSphere hosts updates - UUID error

Post by kevinnaughton » Feb 03, 2013 7:44 pm

Chalk me up as another. Applied updates via VUM. Then got this error. Revoking license fixed.

TheJourney
Influencer
Posts: 13
Liked: 2 times
Joined: Dec 10, 2009 8:44 pm
Full Name: Sam Journagan
Contact:

Re: vSphere hosts updates - UUID error

Post by TheJourney » Feb 12, 2013 3:12 pm

Had the same issue as well with 5.0 U2 via VUM. But only on one host, not sure what level it was before the update, sorry...

evmpr
Novice
Posts: 3
Liked: never
Joined: May 20, 2011 2:49 pm
Full Name: Eugene
Contact:

Re: vSphere hosts updates - UUID error

Post by evmpr » Feb 12, 2013 4:23 pm

Had the same issue after applying the latest patches including U2 for our 5.0 environment. Revoking licenses seemed to do the trick. Looks like the jobs are running again.

Cokovic
Expert
Posts: 295
Liked: 59 times
Joined: Sep 06, 2011 8:45 am
Full Name: Haris Cokovic
Contact:

Re: vSphere hosts updates - UUID error

Post by Cokovic » Feb 14, 2013 12:17 pm

Did the trick here too. After revoking licenses backups started working again.

Cyrix619
Novice
Posts: 3
Liked: 1 time
Joined: Dec 08, 2011 12:35 am
Full Name: Loren Hudson
Contact:

Re: vSphere hosts updates - UUID error

Post by Cyrix619 » Mar 14, 2013 10:26 pm 1 person likes this post

Just wanted to add my 2 cents. This issue is real, and it happen to me with vsphere 5.0.0 update 2 was applied. The recommended revoke solution does resolve the issue.

stuartmacgreen
Expert
Posts: 109
Liked: 20 times
Joined: May 01, 2012 11:56 am
Full Name: Stuart Green
Contact:

[MERGED] KB1063 - ESX Host with bios uuid ... was not found

Post by stuartmacgreen » Apr 04, 2013 2:14 pm

Attempted to perform a restore of VM Hard Disks. At point to select datastore [Change] get a dialog.

Esx host with bios uuid ....not found.

Background
Recently we upgraded our vsphere from 5.0 to 5.1 (vcenter server and esxi hosts) one of the hosts had to be rebuilt however - but the others an upgrade performed.

We have performed restores since the upgrades.

We had initial problems with Veeam licenses after the upgrades but that was resolved by revoking the licenses. This was related to the hosts that time. They still were in Veeam as 5.0 hosts.

Anyway,
I found the KB1063 article, performed revoke of all Veeam licenses. Even restarted all Veeam services and the Veeam SQL Express service. Also migrated the VM I am attempting the restore with. The same message only except a different uuid, possibly because of the migrate.

I have checked my Backup Infrastructure and I see all my ESXi hosts (detail summary shows 5.10 builds) and have rescanned the vcenter server.

Still same message.
My request via this forum post however, is how do I issue the SQL statement in the KB1063 article when I dont have SQL Studio Manager installed. (I am not a DBA of any level - really). Should I just install it?



Using Veeam B&R 6.5.0.128
vSphere 5.1
vCenter Server 5.1.0
ESXi Hosts 5.1.0
Backup Infrastructure: Veeam B&R 9.5 U4 • vSphere 6.5 u2 • HPE MSA 2040 [FC] (Backup Target) • HPE MSL6480 LTO-6 (Tape Storage)
(Veeam Agent for Windows protecting Veeam Proxy / Tape / Repository servers)

Dima P.
Product Manager
Posts: 10537
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: KB1063 - ESX Host with bios uuid ... was not found

Post by Dima P. » Apr 04, 2013 2:49 pm

Hello,

Have you looked in to this topic?

Regarding the KB1063, there are three workarounds mentioned, as you tried to revoke licenses and there is no SQL Studio on your side, did you try to recreate jobs?

Cheers!

foggy
Veeam Software
Posts: 18264
Liked: 1561 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: [MERGED] KB1063 - ESX Host with bios uuid ... was not fo

Post by foggy » Apr 04, 2013 3:00 pm

stuartmacgreen wrote:My request via this forum post however, is how do I issue the SQL statement in the KB1063 article when I dont have SQL Studio Manager installed. (I am not a DBA of any level - really). Should I just install it?
Yes, there is even a download link to SQL Server Management Studio Express given at the bottom of the article especially for that case.

Frosty
Expert
Posts: 174
Liked: 36 times
Joined: Dec 22, 2009 9:00 pm
Full Name: Stephen Frost
Contact:

[MERGED] Upgrading ESXi 5.0 U1 to 5.1 with VBR 6.5

Post by Frosty » Apr 08, 2013 5:11 am

I upgraded my VBR 6.0 to 6.5 a month or so ago and it has all been smooth sailing.
I'm now ready to consider upgrading vCenter/ESXi 5.0 U1 to 5.1,
so am just wondering whether there is anything special I need to know before starting?
e.g. will I need to re-create backup jobs? (we don't do any replication stuff, just backups)
e.g. will VBR need any special treatment to recognise the upgraded vCenter?

veremin
Product Manager
Posts: 16897
Liked: 1437 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Upgrading ESXi 5.0 U1 to 5.1 with VBR 6.5

Post by veremin » Apr 08, 2013 7:23 am

Please be aware that upgrade process will set a different UUID to your ESXi server. Since Veeam uses the UUID to distinguish objects, your jobs are likely to fail with the following error:

Host with uuid was not found

However, the fix is actually quite simple, and should be done right after the upgrade and before the next backup to avoid a failure. Simply revoke the Veeam licenses assigned to the hosts.

Go to Menu -> Help -> Licence -> Licensed host -> Select the server that have been upgraded to 5.1 -> Revoke.

Hope this helps.
Thanks.

veremin
Product Manager
Posts: 16897
Liked: 1437 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Upgrading ESXi 5.0 U1 to 5.1 with VBR 6.5

Post by veremin » Apr 08, 2013 7:25 am

Additionally, don’t forget to upgrade vCenter before the hosts. Otherwise, you’ll face vCenter inability to see/administer properly ESXi hosts with newer version.

Hope this helps.
Thanks.

Frosty
Expert
Posts: 174
Liked: 36 times
Joined: Dec 22, 2009 9:00 pm
Full Name: Stephen Frost
Contact:

Re: vSphere hosts updates - UUID error

Post by Frosty » Apr 08, 2013 11:09 pm

Sweet ... thanks for the tips ... sounds like a smooth upgrade path (fingers crossed!).

stuartmacgreen
Expert
Posts: 109
Liked: 20 times
Joined: May 01, 2012 11:56 am
Full Name: Stuart Green
Contact:

Re: vSphere hosts updates - UUID error

Post by stuartmacgreen » Apr 11, 2013 3:52 pm

Revoked licenses - still same message.
Issued the delete sql statement and the dbo HostsByJob table is now empty - same message. Stopped all Veeam services - same message.

- remaining option to recreate all my jobs! REALLY!

Note: I am trying to perform a RESTORE.
Going to get in touch with support.
Backup Infrastructure: Veeam B&R 9.5 U4 • vSphere 6.5 u2 • HPE MSA 2040 [FC] (Backup Target) • HPE MSL6480 LTO-6 (Tape Storage)
(Veeam Agent for Windows protecting Veeam Proxy / Tape / Repository servers)

Post Reply

Who is online

Users browsing this forum: tcranger and 23 guests