vSphere Veeam PlugIn connection problems

Discussions specific to VMware vSphere hypervisor

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby Tarook » Tue Jun 27, 2017 12:13 am

I have just logged a support job with this issue. I keep getting an error message, "Server error:Session Expired" when I try to fill in the details for the veeam plugin in Vcentre web client. It' won't save the details and therefore is not working. I now await a reply from Veeam support. The case ID is: 02201507.
Tarook
Novice
 
Posts: 8
Liked: never
Joined: Thu Sep 03, 2015 2:16 am
Full Name: Chris Koop

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby kletool » Thu Jul 06, 2017 4:31 pm

Hi!
Same here: Server error: Session expired, when entering settings into Veeam B&R Plugin. Veeam Backup & Replication 9.5 U2 (9.5.0.1038) on vCenter Server Appliance 6.0.0.30200 Build Number 5326079
Is it possible to test the connectivity somehow?
All the best, Kletool
kletool
Lurker
 
Posts: 1
Liked: never
Joined: Thu Jul 06, 2017 4:21 pm
Full Name: Klemens Untner

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby dxm765 » Thu Sep 07, 2017 3:29 pm

Did anyone ever have a resolution to this? I tried multiple times installing and removing, rebooting between each, but I always get Server Error: Session Expired. I have tried installing it with multiple users and signing in as the same users.

I am on vCenter Appliance version 6.0.0.30200
dxm765
Novice
 
Posts: 4
Liked: never
Joined: Fri Jul 17, 2015 6:00 pm
Full Name: Darren M.

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby DGrinev » Thu Sep 07, 2017 4:56 pm

It seems like a known issue on the vCenter Appliance 6.0 but I will check with the QA team and come back soon. Thanks!
DGrinev
Veeam Software
 
Posts: 678
Liked: 73 times
Joined: Thu Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby DGrinev » Fri Sep 08, 2017 11:45 am 1 person likes this post

After a brief discussion QA team confirmed the bug and told me it has been fixed in the upcoming update 3.
However, if you don't want to wait till next update, you can contact the support team, they should have a workaround. Thanks!
DGrinev
Veeam Software
 
Posts: 678
Liked: 73 times
Joined: Thu Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby dxm765 » Sat Sep 09, 2017 2:40 am

DGrinev wrote:After a brief discussion QA team confirmed the bug and told me it has been fixed in the upcoming update 3.
However, if you don't want to wait till next update, you can contact the support team, they should have a workaround. Thanks!

Greatly appreciate the response, I will be anxiously awaiting update 3!
dxm765
Novice
 
Posts: 4
Liked: never
Joined: Fri Jul 17, 2015 6:00 pm
Full Name: Darren M.

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby cheesyboofs » Wed Sep 27, 2017 12:15 pm

Hi DGrinev,

Please could you enlighten us as to what they did to fix this issue for you?
Did they supply you an interim patch or some instructions to get it working?

I am not apposed to getting my hands dirty and would like to get it working..

Many Thanks
cheesyboofs
Lurker
 
Posts: 2
Liked: never
Joined: Wed Sep 27, 2017 12:12 pm

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby DGrinev » Wed Sep 27, 2017 12:36 pm

Hi and welcome to the community!

There is no way to fix it by the instructions, but as I mentioned before, our technical support has a workaround.
Do not hesitate to contact them and ask for a "fix". Thanks!
DGrinev
Veeam Software
 
Posts: 678
Liked: 73 times
Joined: Thu Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby cheesyboofs » Thu Sep 28, 2017 10:45 am

Hi DGrinev

Yes I had detailed instruction back from Support yesterday evening and I have just successfully applied the fix they provided.

Many Thanks for your time.
cheesyboofs
Lurker
 
Posts: 2
Liked: never
Joined: Wed Sep 27, 2017 12:12 pm

Re: vSphere Veeam PlugIn connection problems

Veeam Logoby estd » Wed Nov 15, 2017 4:57 pm 2 people like this post

Hi
How To Fix This bug:
VMware vCenter Server Appliance 6.0.0.30000
1. After install u get:
Server error: Session expired.
Image
Server error: Failed to get application settings.
Image
Open SSH vcenter ->
vcenter:~ # cat /storage/vsphere-client/vwc/veeam.plugin.appsettings.properties
Code: Select all

this file is empty
vcenter:~ # vi /storage/vsphere-client/vwc/veeam.plugin.appsettings.properties
Code: Select all
#Application settings
veeam.reporter.dummypage.relurl=/static/404/reporter.html   
veeam.backup.restapi.username=veeam\\admin
veeam.backup.restapi.url=https\://veeam.local\:9398/api/
veeam.reporter.site.url=https\://veeamone.local\:1239     
veeam.backup.restapi.usebasicauth=true
veeam.backup.site.url=https\://veeam.local\:9443/
veeam.backup.restapi.password=
veeam.backup.site.cert.subjectname=
veeam.backup.site.cert.thumbprint=A31CC4798830075D405BB9ACB54D745C52AA0687
veeam.plugin.version=9.5.0.711

open Enterprise Manager http://dns or IP :9080/Configuration.aspx#configurationcontent/about
Image
After this u need disable and enable plugin and logout -> login vcenter
Image
https://bp.veeam.expert/networking/veeam_backup_enterprise_manager.html
https://www.veeam.com/blog/controlling-backup-infrastructure-with-veeams-vmware-vsphere-web-client-plug-in.html
https://helpcenter.veeam.com/docs/backup/em/configure_web_plugin.html?ver=95
https://www.veeam.com/kb1849
estd
Lurker
 
Posts: 1
Liked: 2 times
Joined: Wed Nov 15, 2017 4:22 pm

Previous

Return to VMware vSphere



Who is online

Users browsing this forum: No registered users and 1 guest