Discussions specific to the VMware vSphere hypervisor
Post Reply
webstyler
Enthusiast
Posts: 34
Liked: never
Joined: Dec 16, 2011 3:20 pm
Full Name: Simon
Contact:

VSS on not standard rdp port

Post by webstyler » May 08, 2014 1:09 pm

Hi

I need to work with VSS but the windows server is not a standard port (3389) .. how to change on backup job ?

Thanks

foggy
Veeam Software
Posts: 18251
Liked: 1558 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: VSS on not standard rdp port

Post by foggy » May 08, 2014 1:50 pm

Simon, do you mean RPC port instead of RDP? Do you have any issues with running backup jobs with that configuration?

webstyler
Enthusiast
Posts: 34
Liked: never
Joined: Dec 16, 2011 3:20 pm
Full Name: Simon
Contact:

Re: VSS on not standard rdp port

Post by webstyler » May 08, 2014 5:43 pm

foggy wrote:Simon, do you mean RPC port instead of RDP? Do you have any issues with running backup jobs with that configuration?
I have enable VSS on a job, but get error:

06/05/2014 15:01:05 :: Processing 'MYVM' Error: Failed to connect to guest agent. Errors:
'Cannot connect to the host's administrative share. Host: [192.xx.xx.11]. Account: [].
Win32 error:The network path was not found.
Code: 53
Cannot connect to the host's administrative share. Host: [77.xx.xx.90]. Account: [].
Win32 error:The network path was not found.
Code: 53'

I have tried to connect on RDP from Veeam server to VM windows with credential created for VSS and work fine

RDP work on NOT standard port (3389), may be this ?

Thanks

dellock6
Veeam Software
Posts: 5732
Liked: 1622 times
Joined: Jul 26, 2009 3:39 pm
Full Name: Luca Dell'Oca
Location: Varese, Italy
Contact:

Re: VSS on not standard rdp port

Post by dellock6 » May 08, 2014 6:09 pm

No, as Alexander asked you, we connect via RPC, not RDP, the remote desktop is only used by you, we don't ;)
At least your RDP test is a confirmation that it's not a credential problem, but sounds more like some network issue, maybe a firewall on the VM preventing Veeam to reach RPC? Can you connect to the same vm via file eplorer opening \\machine_name\admin$ ?
Luca Dell'Oca
Principal EMEA Cloud Architect @ Veeam Software

@dellock6
https://www.virtualtothecore.com/
vExpert 2011 -> 2019
Veeam VMCE #1

webstyler
Enthusiast
Posts: 34
Liked: never
Joined: Dec 16, 2011 3:20 pm
Full Name: Simon
Contact:

Re: VSS on not standard rdp port

Post by webstyler » May 09, 2014 10:15 am

dellock6 wrote:No, as Alexander asked you, we connect via RPC, not RDP, the remote desktop is only used by you, we don't ;)
At least your RDP test is a confirmation that it's not a credential problem, but sounds more like some network issue, maybe a firewall on the VM preventing Veeam to reach RPC? Can you connect to the same vm via file eplorer opening \\machine_name\admin$ ?
Hi Luca

Yes, we can connect via network share

There is a KB about what are rules RPC that veeam required enable ?

Thanks

foggy
Veeam Software
Posts: 18251
Liked: 1558 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: VSS on not standard rdp port

Post by foggy » May 09, 2014 10:42 pm

All the required ports are outlined in the corresponding user guide section.

webstyler
Enthusiast
Posts: 34
Liked: never
Joined: Dec 16, 2011 3:20 pm
Full Name: Simon
Contact:

Re: VSS on not standard rdp port

Post by webstyler » May 12, 2014 8:42 am

Hello

If I disable Windows Firewall on VM guest all work fine.

I've create rules with port indicated in your link (49152-65535 ) but still have same issue

any idea ?

Thanks

veremin
Product Manager
Posts: 16884
Liked: 1433 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: VSS on not standard rdp port

Post by veremin » May 12, 2014 8:52 am

What about TCP, UDP: 135, 137-139, 445? Have you opened them, as well? Have you changed the default dynamic RPC port range on this VM previously? Thanks.

webstyler
Enthusiast
Posts: 34
Liked: never
Joined: Dec 16, 2011 3:20 pm
Full Name: Simon
Contact:

Re: VSS on not standard rdp port

Post by webstyler » May 12, 2014 1:19 pm

v.Eremin wrote:What about TCP, UDP: 135, 137-139, 445? Have you opened them, as well?
Yes, open in the same rule
v.Eremin wrote: Have you changed the default dynamic RPC port range on this VM previously? Thanks.
No

foggy
Veeam Software
Posts: 18251
Liked: 1558 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: VSS on not standard rdp port

Post by foggy » May 12, 2014 1:27 pm

If all the required ports are open and you can connect to admnistrative share on this VM, but VSS still fails, feel free to open a case with technical support to take a closer look at your environment.

Post Reply

Who is online

Users browsing this forum: No registered users and 26 guests