Guest processing skipped (check guest OS VSS state and integ

Hyper-V specific discussions

Guest processing skipped (check guest OS VSS state and integ

Veeam Logoby antspants77 » Fri Feb 14, 2014 5:11 pm 3 people like this post

Hi,
Tried to add this as a potential sticky, to another ticket, but got something about needing a Support case ID


Error
Processing 'Servername' Error: Guest processing skipped (check guest OS VSS state and integration components version)
On a Domain Controller & 2 x Exchange 2010 DAG Servers

Config - Hosts
Windows 2008 R2 + Hyper-V Role + all recommended Hyper-v & cluster hotfixes

Config - VM
Windows 2008 R2 + all windows updates
Basic Disks (Dynamic disks ca't be done this way

Config - Backup Server
Windows 2012 R2
Veeam 7.0 R2a

Config - Job
"Hyper-V guest Quiescence" disabled (should matter as "Application Aware Image Processing" setting will disable this anyway)
"Application Aware Image Processing" Disabled
NB. Just having "Hyper-V guest Quiescence" without "Application Aware Image Processing" will probably work without issues but will be a crash consistent. ie a bit like cold booting the server, so restored VM may not be exactly what you want.

First thing checked was that Integration Services were indeed installed.
NB. These don't come up under Control Panel, Programs.
You can check by getting the driver version of "Microsoft Virtual Network Adapter" in Device Manager, Network Adapters.
Mine was V6.1.7601.17514

Next, as this was a Windows 2008 R2 VM, running on Windows 2008 R2 Hyper-v, the registry key fix did not apply.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\ DWORD: ScopeSnapshots Value: 0
(Included here to help those who have Windows 2012 VMs running on Windows 2008 R2 Hyper-v)
No relevant Application Event Log errors either.

This machine used to be backed up by Commvault, so uninstalled all Commvault components to ensure that the VSS providers weren't conflicting.
Rebooted and ran VSSADMIN LIST WRITERS (elevated cmmd prompt)
All showed "No Error"

Checked shadow Storage on guest VM that was having issues
vssadmin list shadowstorage (elevated cmd prompt)
Ensure the "For Volume:" and "Shadow Copy Storage Volume:" were the same for all partitions.

Then because of this thread, check Shadow copy locations.
My DC only had 1 disk, but also had the system partition.
Each of these has to pint to itself for shadow copies.

To check;
Open Computer
Right click on C drive.
Select "Configure Shadow Copies"
In here I could see 2 drives
C Drive
& \\?\Volume{dfbdc5bb-4b67-11df-81ff-806e6f6e6963}\

NB. You do not need to enable shadow copies for a drive for them to work, but their settings need to pint to themselves.
i.e. C point to C
& \\?\Volume{dfbdc5bb-4b67-11df-81ff-806e6f6e6963}\ points to \\?\Volume{dfbdc5bb-4b67-11df-81ff-806e6f6e6963}\

If you have previously enable shadow copies, then you will have to delete any that you have here to change them
As you are deleting something here, you should be careful, but I didn't have any issues.

I found that even after I deleted and disabled shadow copies and even rebooted, I found that it still showed as having 300mbs in the \\?\Volume{dfbdc5bb-4b67-11df-81ff-806e6f6e6963}\ volume, so couldn't change it.

Got the error
Failed to create the storage area association.
Error 0x8004231d: The specified shadow copy storage association is in use and so can't be deleted.

Googled this error and found this method best to delete all shadow copies.

From elevated cmd prompt, run
diskshadow
You should see a diskshadow> prompt.
(You can run help to get a full list of command)

To List all volume shadow copies on the computer:
list shadows all
(I had heaps)

To list diskshadow command options:
delete shadows

Delete all shadow copies of the given volume or shared folder E.g. D:
delete shadows volume d:

As mine were on a volume without a drive letter I ran;
delete shadows all

When I went back to check the shadow copies through the interface, this now showed no value for shadow copies on all volumes.

And the backup with settings above worked perfectly.
Thanks for the heads up.
antspants77
Influencer
 
Posts: 20
Liked: 5 times
Joined: Wed Mar 16, 2011 3:15 pm
Full Name: Tony Spencer

Re: Guest processing skipped (check guest OS VSS state and i

Veeam Logoby spgsit5upport » Thu Aug 07, 2014 9:16 pm

Honestly, what kind of C**P is that? Nere ever had such idiotic errors with Vmware. Hyper-V is elevated till all new level of stupidity.
One day it works, next day it does not. And please do NOT ask me for logs, have no time for another time wasting session!

Seb
spgsit5upport
Expert
 
Posts: 182
Liked: 14 times
Joined: Fri May 28, 2010 10:25 am
Full Name: Seb


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 6 guests