No offhost Hyper-V backup proxies are available

Hyper-V specific discussions

No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Fri Apr 06, 2012 8:42 pm

Hi all,

We have a three node Hyper-V cluster connected to an HP EVA P6300, that we want to backup with Veeam B&R. We also have a physical server with lots of storage, acting as the repository and another phsyical machine with Hyper-V role that I want to use as a backup proxy. I have installed the VSS hardware provider on the backup proxy and all three Hyper-V nodes. I also have selected this VSS hardware provider to use within Veeam B&R (right click on cluster nodes --> manage volumes).

In the backup job I deselected the option to failover to on-host backup if no off-host proxy is available. I want to be sure that the off-host proxy is being used. However, the job fails because "there is no offhost Hyper-V backup proxy available". What steps do I need to take to make sure the offhost backup proxy is being used?
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby Gostev » Fri Apr 06, 2012 10:08 pm

Hi Leo,

Sounds like you nailed it, and did everything absolutely right except one thing. Did you actually add your physical backup proxy server to Veeam using the Add Hyper-V Proxy wizard?

Thanks.
Gostev
Veeam Software
 
Posts: 21503
Liked: 2379 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Sat Apr 07, 2012 7:36 am

Hi Gostev,

Thanks for your reply. Yes, I have added the proxy through the add proxy wizard. In my job properties, I see an offhost backup proxy available...
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Sat Apr 07, 2012 9:08 am

One other question: Do I need to present the cluster shared volume LUN's to the backup proxy server? If I review the properties of the backup proxy in Veeam, I do not see any connected volume it can backup VM's from. If I need to present my CSV LUN, isn't there a chance they get corrupted?
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby collinp » Mon Apr 09, 2012 9:50 pm

In terms of your question i n presenting the cluster share volume LUN's to the backup proxy server, I am not seeing many posts about this. I don't know how many people are successfully doing hardware vss backups with hyper-v. I have the same questions as you. I have an open to EMC, and am trying to explain how all of this works and they are at a loss. They want to throw it back to the backup vendor to figure out. Apparently transportable snapshots have been around for a long time but I don't see a lot of step by step articles on this. I have gotten to the point where Veeam initiates a backup through the offhost proxy using the EMC VSS provider. I see the snapshot being created on my array. But that is about it. I am assuming that Veeam is sending instructions to the EMC array on how to present the snapshot to the offhost proxy and then copy the files over. But that part isn't happening yet.

I don't think you present the storage to both the Hyper-v host and the offhost proxy. As you said, that would cause problems. I am assuming that the offhost proxy is zoned to the storage array but no LUNS are presented to the offhost proxy 'yet'. I am assuming that the Veeam backup process creates a snapshot of the Hyper-v CSV and then temporarily presents this snapshot to the offhost proxy and when the backup is done, unmounts it. How all of this happens on the storage array automatically, I do not know.
collinp
Expert
 
Posts: 115
Liked: 10 times
Joined: Tue Feb 14, 2012 8:56 pm
Full Name: Collin P

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby Gostev » Tue Apr 10, 2012 10:44 am

Sorry for delayed response, I have been traveling. Please check to see if you possibly have automount disabled on your offhost backup proxy server. Thanks!
Gostev
Veeam Software
 
Posts: 21503
Liked: 2379 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Wed Apr 11, 2012 9:04 am

Gostev,

I have checked the settings of the backup proxy, but I can't find an option 'automount' or something like that. Where can I find it?

Is there something I need to do on my EVA, before the VSS hardware provider will work? Is there anyone who can tell me more about doing hardware vss snapshots on an HP EVA system?
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby foggy » Wed Apr 11, 2012 9:17 am

LinkeLoe wrote:I have checked the settings of the backup proxy, but I can't find an option 'automount' or something like that. Where can I find it?

Open command prompt on backup proxy server and type "diskpart" and then "automount". This will display the automount status.
foggy
Veeam Software
 
Posts: 15081
Liked: 1110 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Wed Apr 11, 2012 9:37 am

I have enabled automount on the backup proxy, but I still get the error message...

Like I wrote, are there additional steps required to enable vss hardware snapshots of my EVA system?
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby Gostev » Wed Apr 11, 2012 1:59 pm

No additional steps are required typically, but there might be device-specific requirements. I recommend you open a support case and let our technical staff take a look at this in live.
Gostev
Veeam Software
 
Posts: 21503
Liked: 2379 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby collinp » Wed Apr 11, 2012 9:48 pm

Hopefully I am not hijacking this thread but the subject matter seemed similar enough. I have a case open with EMC on hardware VSS snapshots. I also just opened a case with Veeam (5184531) since EMC would like to talk with Veeam. What we are seeing is interesting. From an EMC perspective, the EMC logs are blank on the offhost proxy, even though I have the Veeam job specifically set to use the offhost proxy. All of the SAN activity is happening on the Hyper-v host itself. If you look at the Hyper-v host, the coordination of the EMC SAN snapshot, etc is happening from the Hyper-v host. The snapshot is getting created on the SAN successfully but isn't getting mounted on the offhost proxy. The EMC technician said that every other backup product that they have worked with use the Backup Proxy to coordinate all of the snapshot activity. Is this how it is supposed to work?

Not that anyone would understand these EMC logs. But you can get an idea of the activity happening on the Hyper-v host. The SAN lun is PhysicalDrive3. Again, the EMC logs are blank on the offhost proxy.

Code: Select all
15:48:02 04/10/2012 UnmaskLUNS: AddAccessToDev failed ...
15:48:02 04/10/2012 UnmaskLUNS: Failed to add access to the device <Device uid="600601607760250008d8810f5f83e111" <Array type="CLARiiON" encoding="String" value="APM00092503853" /> />.
15:48:02 04/10/2012 UnmaskLUNS:Sym is non Tigon, proceed with StorMaskSessionEnd...
15:48:02 04/10/2012 UnmaskLUNS: Leaving with FAILURE.
15:48:02 04/10/2012 LocateLuns: Failed to perform pre unmasking tasks. Returning with failure!
15:48:02 04/10/2012 OnLunEmpty: Entering.
15:48:02 04/10/2012 IsLocalHostVM: Entering...
15:48:02 04/10/2012 IsLocalHostVM: Leaving with success.
15:48:02 04/10/2012 ::ExtractPairingFromLUNInfo: Entering.
15:48:02 04/10/2012 ::ExtractPairingFromLUNInfo: Leaving with SUCCESS.
15:48:02 04/10/2012 OnLunEmpty: Calling iArraySync for <Array type="CLARiiON" encoding="String" value="APM00092503853" />.
15:48:02 04/10/2012 iArraySync: Entering.
15:48:02 04/10/2012 iArraySync: StorArraySync(-1) for <Array type="CLARiiON" encoding="String" value="APM00092503853" />.
15:48:20 04/10/2012 iArraySync: Leaving with SUCCESS.
15:48:20 04/10/2012 OnLunEmpty: Calling StorDevShow for <Device uid="600601607760250008d8810f5f83e111" <Array type="CLARiiON" encoding="String" value="APM00092503853" /> /> on Array <Array type="CLARiiON" encoding="String" value="APM00092503853" />.
15:48:20 04/10/2012 OnLunEmpty: Removing access to .
15:48:20 04/10/2012 RemoveAccessToDev: Entering.
15:48:20 04/10/2012 RemoveAccessToDev: Calling StorDevShow(2593) for <Device uid="600601607760250008d8810f5f83e111" /> on Array <Array type="CLARiiON" encoding="String" value="APM00092503853" />.
15:48:20 04/10/2012 RemoveAccessToDev: Calling StorDeviceIdConvert to get name of device = <Device uid="600601607760250008d8810f5f83e111" />.
15:48:20 04/10/2012 RemoveAccessToDev: Found that <Device uid="600601607760250008d8810f5f83e111" /> is not in a storage group, so returning successfully.
15:48:20 04/10/2012 OnLunEmpty: Calling StorSnapControl for SRC=<Device name="00035" <Array type="CLARiiON" encoding="String" value="APM00092503853" /> /> and TGT=<Device name="VSS_SEHYPERVA_00035_154719_04102012" /> on <Array type="CLARiiON" encoding="String" value="APM00092503853" />.
15:48:40 04/10/2012 OnLunEmpty: StorSnapControl failed to terminate <Device name="00035" <Array type="CLARiiON" encoding="String" value="APM00092503853" /> />-><Device name="VSS_SEHYPERVA_00035_154719_04102012" /> in Array <Array type="CLARiiON" encoding="String" value="APM00092503853" />.
ERROR: [1100007]:A device attribute makes its use invalid for the requested operation. [4580]:The device specified cannot be used as it is in a storage group. The device specified cannot be used as it is in a storage group. 
15:48:40 04/10/2012 AbortSnapshots: Entering.
15:48:40 04/10/2012 CancelSnapshotSet: Entering.
15:48:40 04/10/2012 ~CSnapshotSet: Entering destructor.
15:48:40 04/10/2012 CSnapshotSet::FreeArrayData() entering.
15:48:40 04/10/2012 CSnapshotSet::FreeArrayData() exiting.
15:48:40 04/10/2012 CSnapshotSet::FreeLunData() entering.
15:48:40 04/10/2012 CSnapshotSet::FreeLunData() exiting.
15:48:40 04/10/2012 ~CSnapshotSet: Leaving destructor with success.
15:48:40 04/10/2012 CancelSnapshotSet: Leaving with SUCCESS.
collinp
Expert
 
Posts: 115
Liked: 10 times
Joined: Tue Feb 14, 2012 8:56 pm
Full Name: Collin P

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby collinp » Thu Apr 12, 2012 6:10 am

I was able to clean some things up on the EMC side and now I am down to the same error message that everyone is getting.

"Unable to allocate processing resources. Error: No offhost Hyper-V backup proxies are avaliable."

My offhost proxy is available and has 2008 r2 with the hyper-v roll and has been added as an offhost proxy. automount was enabled in diskpart.

How are we all getting this error across different arrays and environments? We must be missing something
collinp
Expert
 
Posts: 115
Liked: 10 times
Joined: Tue Feb 14, 2012 8:56 pm
Full Name: Collin P

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Thu Apr 12, 2012 6:28 am

In the meantime I have opened a support case with Veeam. I will post any updates on this matter in this thread. It's good to see that I'm not the only one with this problem. We surely must be missing here... Is there anyone who has setup an Hyper-V proxy succesfully?
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby foggy » Thu Apr 12, 2012 2:48 pm

Guys, just to confirm - can you see the LUNs in Disk Management on offhost proxy machine? You need to present the LUNs to the backup proxy server (they will not get corrupted if you won't bring them online, just get them in Disk Management snap-in).
foggy
Veeam Software
 
Posts: 15081
Liked: 1110 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: No offhost Hyper-V backup proxies are available

Veeam Logoby LinkeLoe » Thu Apr 12, 2012 2:58 pm

LUN's are not presented at the moment, but I have tried making a backup with the LUN's presented without any success. I keep getting the same error message...
LinkeLoe
Enthusiast
 
Posts: 35
Liked: never
Joined: Fri Apr 06, 2012 8:31 pm
Full Name: Leo Schroer

Next

Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 17 guests