Red Hat 7.3 Backup failed

Hyper-V specific discussions

Red Hat 7.3 Backup failed

Veeam Logoby max0664 » Tue Mar 07, 2017 7:55 am

Hi,

i have a Hyper-v 2012 R2 Cluster with 4 Nodes and a Red Hat 7.3 VM.
I want backup the the Red Hat 7.3 VM in Hyper-V child partion snapshot mode. But it failed all time with this error:
Code: Select all
Failed to create snapshot (Microsoft CSV Shadow Copy Provider) (mode: Hyper-V child partition snapshot) Details: Writer 'Microsoft Hyper-V VSS Writer' is failed at 'VSS_WS_FAILED_AT_PREPARE_SNAPSHOT'.
The writer experienced a non-transient error.  If the backup process is retried,
the error is likely to reoccur.
--tr:Failed to verify writers state.
--tr:Failed to perform pre-backup tasks. 


So i try the backup in Brash consistent mode it work fine.
I have CentOS 7 and update it to 7.3 with manual installed LIS. Here the Backup work fine on a other 2012 R2 Cluster in Hyper-V child partition snapshot mode.
Have someone a Idea or a similarly problem?

Case 02061996
max0664
Influencer
 
Posts: 17
Liked: never
Joined: Tue Sep 04, 2012 4:30 pm
Full Name: Max

Re: Red Hat 7.3 Backup failed

Veeam Logoby Mike Resseler » Tue Mar 07, 2017 8:00 am

Hi Max,

1. Any change you have an attached iSCSI device or direct-attached storage (also known as a pass-through disk) to that VM?
2. Are you using the built-in LIS or downloaded and installed the Microsoft integration components?

Mike
Mike Resseler
Veeam Software
 
Posts: 3382
Liked: 384 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: Red Hat 7.3 Backup failed

Veeam Logoby max0664 » Tue Mar 07, 2017 8:51 am

Hi Mike,

1. Any change you have an attached iSCSI device or direct-attached storage (also known as a pass-through disk) to that VM?
I have a VM Gen 2 with 2 SCSI VHDX Disks and 1 DVD-Drive.

2. Are you using the built-in LIS or downloaded and installed the Microsoft integration components?
I am using the built-in LIS.
max0664
Influencer
 
Posts: 17
Liked: never
Joined: Tue Sep 04, 2012 4:30 pm
Full Name: Max

Re: Red Hat 7.3 Backup failed

Veeam Logoby Mike Resseler » Tue Mar 07, 2017 9:08 am

What I can think off is that the flush command is failing inside the VM and that it could potentially be the reason why this is not possible. But I am afraid I can't really help you there further. You might want to take that up with MSFT or your distro support

Sorry
Mike Resseler
Veeam Software
 
Posts: 3382
Liked: 384 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 1 guest