Discussions specific to the Microsoft Hyper-V hypervisor
Post Reply
veehexx
Influencer
Posts: 12
Liked: never
Joined: Nov 19, 2015 10:00 am
Contact:

VSS not registered

Post by veehexx » Mar 26, 2019 4:33 pm

We've recently re-implimented our Lefthand SAN and is coming up with a warning on backup jobs where the guest data resides on the SAN.
Failed to create snapshot (LeftHand Networks VSS Provider) (mode: Veeam application-aware processing) Details: Failed to add volume [\\?\Volume{f1ef5d90-92ed-4786-9b07-ea60bea8af22}\] to the VSS snapshot set
The volume shadow copy provider is not registered in the system.
--tr:Failed to add volumes to the snapshot set.
--tr:Failed to perform pre-backup tasks.
any guest on local storage is fine so as it says, seems to be down to the Lefthand VSS Provider not being installed. Problem is i cant find any downloads from HPE to resolve this. I assume i need to install something to fix this problem.

Any tips to getting VSS registered correctly and fix this warning? thanks!

ejenner
Expert
Posts: 435
Liked: 69 times
Joined: Mar 23, 2018 4:43 pm
Full Name: EJ
Location: London
Contact:

Re: VSS not registered

Post by ejenner » Mar 27, 2019 10:14 am

Setting up a VSS Provider is quite an involved process. Usually you would know whether or not this had been done and so the error would be unexpected if you've setup a VSS hardware provider.

If you have not setup a VSS Provider that means you can't directly address the storage. You have to request the data at OS level instead. Going in via the OS it does not matter where the data is stored as the VSS operation is handled by Windows.

ejenner
Expert
Posts: 435
Liked: 69 times
Joined: Mar 23, 2018 4:43 pm
Full Name: EJ
Location: London
Contact:

Re: VSS not registered

Post by ejenner » Mar 27, 2019 10:16 am 1 person likes this post

By the way... when I wanted to find the HPE software for setting up VSS Hardware Provider I had to raise a support ticket with HPE as I couldn't find the relevant downloads through their normal search on their website. I think I had to setup a login and provide a serial number as well.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests