Alarm does not work

Real-time performance monitoring and troubleshooting

Alarm does not work

Veeam Logoby inforhunter » Thu Aug 06, 2009 1:30 am

I installed monitor 4.0 free edition on my xp sp2 box. The DB is sql server 2005 standard.
the installation process encounter no error,and all the function of the veeam monitor work also ok
except the alarm component.
I definited a email alarm for a VM's CPU usage,and then triggered it for some times.but have never received
a mail.(SMTP setting is ok.i have tested it)
In the log file,i found something unnomal like below:

----------------------------------------------------------------
08/05/09 17:30:43 Inform 0x0B50 alarms"A database error (code:0x80040E37, ) has occured in context of { CALL sp_getdatastorevmwithdev;1 (?, ?) }. Error information follows"
08/05/09 17:30:43 Inform 0x0B50 alarms"Error record 1 of 2: Invalid object name 'infrastructure'."
08/05/09 17:30:43 Inform 0x0B50 alarms"Error record 2 of 2: Invalid column name 'DeviceName'."
08/05/09 17:30:43 Inform 0x0B50 alarms"Throwing exception."
08/05/09 17:30:43 Error 0x0B50 alarms"IDispatch error #3127 (Code: 0x80040E37, Source: Microsoft SQL Native Client, Description: Invalid column name 'DeviceName'.)"
08/05/09 17:30:43 Inform 0x0B50 alarms"Detect Alarm: 0.109"
08/05/09 17:31:03 Inform 0x0B50 alarms"A database error (code:0x80040E37, ) has occured in context of { CALL sp_getdatastorevmwithdev;1 (?, ?) }. Error information follows"
08/05/09 17:31:03 Inform 0x0B50 alarms"Error record 1 of 2: Invalid object name 'infrastructure'."
08/05/09 17:31:03 Inform 0x0B50 alarms"Error record 2 of 2: Invalid column name 'DeviceName'."
08/05/09 17:31:03 Inform 0x0B50 alarms"Throwing exception."
08/05/09 17:31:03 Error 0x0B50 alarms"IDispatch error #3127 (Code: 0x80040E37, Source: Microsoft SQL Native Client, Description: Invalid column name 'DeviceName'.)"
08/05/09 17:31:03 Inform 0x0B50 alarms"Detect Alarm: 0.093"

Thanks for your help in advance
inforhunter
Novice
 
Posts: 5
Liked: never
Joined: Thu Aug 06, 2009 1:12 am
Full Name: inforhunter

Re: Alarm does not work

Veeam Logoby inforhunter » Mon Aug 24, 2009 7:44 am

It's hard and long time work until I cover it

The reason is very simple,my database is case-sensitive.and the store procedure sp_getdatastorevmwithdev()

is not ,I have modified the store procedure
inforhunter
Novice
 
Posts: 5
Liked: never
Joined: Thu Aug 06, 2009 1:12 am
Full Name: inforhunter


Return to Monitoring



Who is online

Users browsing this forum: No registered users and 2 guests