Discussions specific to the Nutanix AHV hypervisor
Post Reply
hlmaldona
Lurker
Posts: 2
Liked: never
Joined: Jul 17, 2017 7:43 pm
Full Name: Hector Maldonado
Contact:

Explorer for Exchange Server Fails as advertised

Post by hlmaldona »

Problem: Explorer for Exchange Server Fails as advertised
Platform: Nutanix AHV
Case #04776063 — Veeam Explorer for Microsoft Exchange unmounts as soon try to mount

Response: unacceptable outcome, not even a good news.

This is the reply:
"The Exchange Explorer is dismounting the disks. It has been determined that this is expected behavior at the moment. There were some changes made to address a couple of other issues, and this is a consequence of those changes. It is possible the behavior may be changed in the future, but for now it needs to stay as is."
Basically, it is broke, we will not fix it at this time, use a workaround.

And the main reason I have Veeam is because 2 only factors: Explorers and Tape functionality.

The case automatically close and I refuse to accept to pay for something that is not performing as advertised.

Any assistance?

HannesK
Veeam Software
Posts: 9104
Liked: 1663 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Explorer for Exchange Server Fails as advertised

Post by HannesK »

Hello,
and welcome to the forums.

As quick fix I see two options
1) you use agent-based backup with application aware image processing for the exchange server
2) as far as I understood, everything worked fine with V10. So going back to V10 might also be a workaround. I tend to go with 1 until the issue is fixed.

Best regards,
Hannes

Mildur
Veeam Legend
Posts: 1699
Liked: 687 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: St. Gallen, Switzerland
Contact:

Re: Explorer for Exchange Server Fails as advertised

Post by Mildur »

I recommend to use the agent for all applications on Nutanix.
There isn‘t any application aware processing from veeam with Nutanix AHV Backups. You need to relay on Nutanix own vss integration for that. I don‘t like it, because veeam cannot interfere or doing something at that process.

If you need application consistency, Log truncation or Guest file indexing, use Agent Backups. It will not cost you another license. You can backup the same Nutanix VM with image baes backup jobs and agent Backup jobs with the same license.
VMCE 2021 | Veeam Legends 2021
Working with Veeam since 2017 for a VCSP in Switzerland

Coldfirex
Enthusiast
Posts: 59
Liked: 8 times
Joined: May 22, 2015 1:41 pm
Full Name: Alan Shearer
Contact:

Re: Explorer for Exchange Server Fails as advertised

Post by Coldfirex »

I would be curious when (if?) application aware processing will be supported without having to fallback to the agent backups.

HannesK
Veeam Software
Posts: 9104
Liked: 1663 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Explorer for Exchange Server Fails as advertised

Post by HannesK »

for the foreseeable future, agents are the way to go for full application aware processing support. For VMs where simple VSS is enough, you can stay with Nutanix guest tools quiescing.

Fixing the explorer issue is a matter of time. Workarounds are mentioned above.

Coldfirex
Enthusiast
Posts: 59
Liked: 8 times
Joined: May 22, 2015 1:41 pm
Full Name: Alan Shearer
Contact:

Re: Explorer for Exchange Server Fails as advertised

Post by Coldfirex »

HannesK: Is that a Veeam or Nutanix limitation at this point (application aware processing support)?

hlmaldona
Lurker
Posts: 2
Liked: never
Joined: Jul 17, 2017 7:43 pm
Full Name: Hector Maldonado
Contact:

Re: Explorer for Exchange Server Fails as advertised

Post by hlmaldona »

Hi Coldfirex, at the moment I have no problem restoring. My current problem is one of handling and complexity to restore using the Explorers for both Exchange and Active Directory.

Apparently something is missing or bugged somewhere in the programming that as soon as it mounts the files, it immediately unmounts them and a second later the explorer opens and gives an error because it cannot find the mounting points.

Something that worked in the past version and in this version is broken.

An user deleted a folder by mistake in his mailbox, week later he requests the restoration of that folder.

I needed to mount 7 restore points in order to get the correct point in time. It was a time consuming process.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest