Discussions specific to object storage
Post Reply
agrob
Expert
Posts: 181
Liked: 19 times
Joined: Sep 05, 2011 1:31 pm
Full Name: Andre
Contact:

problems adding azure blob storage account

Post by agrob » Feb 13, 2019 2:23 pm

Good Day

When i try to add a new object storage repository -> azure blob storage, i get the following error message under the account settings:

"Azure Cloud Connection has returned an untrusted certificate"

Veeam does not display the certificate. Time on the Server is correct.
How can i troubleshoot/fix this?
Thanks

v.eremin
Product Manager
Posts: 16333
Liked: 1343 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: problems adding azure blob storage account

Post by v.eremin » Feb 13, 2019 2:55 pm

We will need to see debug logs first. Can you open a ticket with our support team and provide its number here? Thanks!

agrob
Expert
Posts: 181
Liked: 19 times
Joined: Sep 05, 2011 1:31 pm
Full Name: Andre
Contact:

Re: problems adding azure blob storage account

Post by agrob » Feb 14, 2019 9:35 am

Thanks, Case ID 03415333

agrob
Expert
Posts: 181
Liked: 19 times
Joined: Sep 05, 2011 1:31 pm
Full Name: Andre
Contact:

Re: problems adding azure blob storage account

Post by agrob » Feb 18, 2019 9:27 am 1 person likes this post

Problem solved. Veeam Backup Server was not able to connect to Microsoft PKI site to check Certificate. I thought that proxy server specified in the azure blob storage repository would do all the needed connections. once veeam backup server was able to check the certificate, it worked

v.eremin
Product Manager
Posts: 16333
Liked: 1343 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: problems adding azure blob storage account

Post by v.eremin » Feb 18, 2019 4:34 pm

Glad to hear that the problem has been solved. Thanks for taking the time and updating the topic with the resolution; much appreciated!

silviaspera
Lurker
Posts: 2
Liked: never
Joined: May 24, 2019 9:42 am
Contact:

Re: problems adding azure blob storage account

Post by silviaspera » May 24, 2019 9:46 am

How did you solve the problem?
What does it mean "once veeam backup server was able to check the certificate"?

Where is the proxy specified?

I can't undertsand how to solve it!

Many thanks for your support
Silvia

wishr
Veeam Software
Posts: 767
Liked: 75 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: problems adding azure blob storage account

Post by wishr » May 24, 2019 9:54 am

Hi Silvia,

The initial poster did not mention resolution details during the conversation with our support engineer, so please open a support case (don't forget to let us know your support case ID) and work with them since your root cause may differ.

Thanks

silviaspera
Lurker
Posts: 2
Liked: never
Joined: May 24, 2019 9:42 am
Contact:

Re: problems adding azure blob storage account

Post by silviaspera » May 24, 2019 10:51 am

Sure, it may differ however is it possible to know the most common cause? I think it could be the same in many cases.
Thanks anyway

wishr
Veeam Software
Posts: 767
Liked: 75 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: problems adding azure blob storage account

Post by wishr » May 24, 2019 11:16 am

As I mentioned, we do not have detailed information about resolution steps performed by the initial poster since they have not been shared with our support team in the support case. The only information available is this.

agrob
Expert
Posts: 181
Liked: 19 times
Joined: Sep 05, 2011 1:31 pm
Full Name: Andre
Contact:

Re: problems adding azure blob storage account

Post by agrob » May 27, 2019 5:54 am 1 person likes this post

The solution in our case was to grant the veeam backup server access to the internet to check crl. if first thought that the server which acts as gateway server for the azure repository just need access to it and to check the crl. but this was not enough -> just make sure that the backup server itself (management gui) has internet access. hope this helps

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest