Find-VBRViEntity command takes 5-10mins for each command

PowerShell script exchange

Find-VBRViEntity command takes 5-10mins for each command

Veeam Logoby cloud00hawk » Tue Aug 09, 2016 3:37 pm

We had a script that finds a VM in vCenter using Find-VBRViEntity command and adds it to a backup job. It was working all fine until vCenter was upgraded to vCenter 6.0 a month back. Since then this command takes 5-10mins for each command and fails. Any idea on why does it take more time ?
cloud00hawk
Novice
 
Posts: 5
Liked: never
Joined: Tue Mar 17, 2015 2:38 pm

Re: Find-VBRViEntity command takes 5-10mins for each command

Veeam Logoby nefes » Tue Aug 09, 2016 3:40 pm

Have you already opened support case? Please post a number here.
What error do you see on the fail? It could explain the reason of issue.
nefes
Veeam Software
 
Posts: 534
Liked: 125 times
Joined: Mon Dec 10, 2012 8:44 am
Full Name: Nikita Efes

Re: Find-VBRViEntity command takes 5-10mins for each command

Veeam Logoby tsightler » Fri Aug 12, 2016 1:12 pm

At least at first glance I would say this implies that it is attempting to communicate with a vCenter that is no longer responding. When you say you upgraded vCenter, did you do an in-place upgrade, or install a new vCenter and migrate hosts? If the later, is there any chance that the old vCenter never removed from the Veeam console? The other common reason I've seen is hosts that are offline, etc. Some additional details of the failure would certainly be useful. Are you running Find-VBRViEntity with a -Server parameter specified?
tsightler
Veeam Software
 
Posts: 4768
Liked: 1737 times
Joined: Fri Jun 05, 2009 12:57 pm
Full Name: Tom Sightler


Return to PowerShell



Who is online

Users browsing this forum: No registered users and 3 guests