Management reporting and documentation
Post Reply
tvbc
Lurker
Posts: 1
Liked: never
Joined: Nov 25, 2010 1:50 pm
Contact:

Veeam Reporter SSRS settings

Post by tvbc » Nov 25, 2010 1:57 pm

Hi,

I am trying to point Veeam to a SSRS server which is a different server from where the database resides. For the URL I have enterred

http://myssrsserver/Reports

and then

mydomain\myusername
mypassword

But I keep getting 404 not found, or 401 unauthorized. I have tried using the SA account, and have the same issue. If I browse to that URL, I can successfully access the reports page.

Has anybody else experienced these problems?

Many Thanks,
Tvbc

Vitaliy S.
Product Manager
Posts: 22697
Liked: 1498 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Veeam Reporter SSRS settings

Post by Vitaliy S. » Nov 25, 2010 5:07 pm

Hello, could you please tell what version of SSRS are you trying to point to? Have you used this SSRS server with Reporter installation before?

jeremy
Lurker
Posts: 2
Liked: never
Joined: Feb 25, 2011 10:28 pm
Full Name: Jeremy Lacey

Re: Veeam Reporter SSRS settings

Post by jeremy » Feb 25, 2011 10:32 pm

I am having the same issue.....what is the fix please

jeremy
Lurker
Posts: 2
Liked: never
Joined: Feb 25, 2011 10:28 pm
Full Name: Jeremy Lacey

Re: Veeam Reporter SSRS settings

Post by jeremy » Feb 25, 2011 11:12 pm

Using SQL 2008R2

Gostev
SVP, Product Management
Posts: 24302
Liked: 3332 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veeam Reporter SSRS settings

Post by Gostev » Feb 26, 2011 11:25 am

Please make sure you follow system requirements. The product requires SQL 2008 (not R2), so this might be a problem.

Pavel Shterlyaev
Novice
Posts: 3
Liked: never
Joined: Jul 03, 2009 2:16 pm
Full Name: Pavel Shterlyaev
Contact:

Re: Veeam Reporter SSRS settings

Post by Pavel Shterlyaev » Mar 22, 2011 11:25 am


Libran_Dragon
Lurker
Posts: 1
Liked: never
Joined: Mar 30, 2011 1:20 pm
Full Name: Sean Naidoo
Contact:

Re: Veeam Reporter SSRS settings

Post by Libran_Dragon » Mar 30, 2011 2:16 pm

Hi,

You need to add your LAN account to either one of the following groups on the SSRS box..

Veeam Reporter Administrators (Members of this group can manage Veeam Reporter data collection jobs and other settings, and generate the reports)

or

Veeam Reporter Viewers (Members of this group can generate the reports)

Hope this helps :P

ddan
Lurker
Posts: 1
Liked: never
Joined: May 25, 2011 4:09 am
Full Name: Diyan Danikumar
Contact:

Re: Veeam Reporter SSRS settings

Post by ddan » May 25, 2011 4:16 am

I had the issue where ssrs was configured fine and could browse to it via browser, but then from Veeam Reporter when i'd try to connect via 'configuration' > 'settings' > 'SSRS Server' > 'test' I would get: The request failed with HTTP status 401: Unauthorized. This fixed it for me:

On the Reporting Services Server, open the config file rsreportserver.config (you find it in the Reporting Services folder)
Look for the Autentication configuration node
Remove the RSWindowsNegotiate setting
The config section in question should now look like this:

<Authentication>
<AuthenticationTypes>
<!-- <RSWindowsNegotiate/> -->
<RSWindowsNTLM/>
</AuthenticationTypes>
<EnableAuthPersistence>true</EnableAuthPersistence>
</Autentication>

That way, only NTLM is used for authentication. This fixed it for me

Vitaliy S.
Product Manager
Posts: 22697
Liked: 1498 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Veeam Reporter SSRS settings

Post by Vitaliy S. » May 25, 2011 8:18 am

Hello Diyan,

Thank you for finding time to update this topic with the resolution.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest