GET cloud/tenant BackupCount 0

RESTful knowledge exchange

GET cloud/tenant BackupCount 0

Veeam Logoby vcirrus » Thu Jul 28, 2016 3:49 am

Case ID# 01865103

I'm trying to get a count of VMs backed up by a tenant (known as VMCount in powershell when using the Get-VBRCloutTenant cmdlet)

There appears no way to get this through the RESTful API. The XML returned by the API call includes a <BackupCount>0</BackupCount> element that I was hoping would be the number of VMs backed up, but this has always been 0 in my testing, even if the tenant has backed up VMs.

Code: Select all
GET https://host:9398/api/cloud/tenants/b367de72-5396-4ea4-94a3-e14d83e540b0?format=Entity

<?xml version="1.0" encoding="utf-8"?>
<CloudTenant Type="CloudTenant" Href="https://host:9398/api/cloud/tenants/b367de72-5396-4ea4-94a3-e14d83e540b0?format=Entity" Name="VCC_1746234-OWN-MEL" UID="urn:veeam:CloudTenant:b367de72-5396-4ea4-94a3-e14d83e540b0" xmlns="http://www.veeam.com/ent/v1.0" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <Password />
  <Description>Created by at 27/07/2016 4:12:50 PM</Description>
  <Enabled>true</Enabled>
  <LeaseOptions Enabled="false" />
  <Resources>
    <CloudTenantResource Type="CloudTenantResource" Href="https://host:9398/api/cloud/tenants/b367de72-5396-4ea4-94a3-e14d83e540b0/resources/3b322ce1-dd4e-40d5-8158-2d40d4277828" Id="3b322ce1-dd4e-40d5-8158-2d40d4277828">
      <RepositoryQuota>
        <DisplayName>VCC_1746234-OWN-MEL</DisplayName>
        <RepositoryUid>urn:veeam:Repository:aa7441e1-f466-495b-9302-db0034979516</RepositoryUid>
        <Quota>512000</Quota>
        <UsedQuota>30</UsedQuota>
      </RepositoryQuota>
    </CloudTenantResource>
  </Resources>
  <LastResult>Success</LastResult>
  <LastActive>2016-07-27T08:22:18Z</LastActive>
  <ComputeResources />
  <ThrottlingEnabled>false</ThrottlingEnabled>
  <ThrottlingSpeedLimit>1</ThrottlingSpeedLimit>
  <ThrottlingSpeedUnit>MBps</ThrottlingSpeedUnit>
  <PublicIpCount>0</PublicIpCount>
  <BackupCount>0</BackupCount>
  <ReplicaCount>0</ReplicaCount>
</CloudTenant>
vcirrus
Novice
 
Posts: 5
Liked: never
Joined: Thu Jul 28, 2016 2:57 am
Full Name: Mathew Quinn

Re: GET cloud/tenant BackupCount 0

Veeam Logoby v.Eremin » Thu Jul 28, 2016 2:16 pm

It's a known issue fixed in Update 2. You can request it via your support ticket.

Also, you seem to be a Cloud Provider. Are you already in VCSP program? If so, kindly, apply to Cloud & Service Providers forum group to get access to the dedicated VCSP forum section.

Thanks.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: GET cloud/tenant BackupCount 0

Veeam Logoby dellock6 » Fri Jul 29, 2016 7:30 am

I've got the application but the email in the account is not linked to any information we have. Kindly, change it to the one used also in propartner and re-apply.
Luca Dell'Oca
EMEA Cloud Architect @ Veeam Software

@dellock6
http://www.virtualtothecore.com
vExpert 2011-2012-2013-2014-2015-2016
Veeam VMCE #1
dellock6
Veeam Software
 
Posts: 5047
Liked: 1330 times
Joined: Sun Jul 26, 2009 3:39 pm
Location: Varese, Italy
Full Name: Luca Dell'Oca

Re: GET cloud/tenant BackupCount 0

Veeam Logoby vcirrus » Wed Nov 09, 2016 7:13 am

More recently I'm getting <BackupCount>3</BackupCount> for a tenant that has only two VMs backed up. This is with update 2. I can see backup count of two in the Veeam GUI.

Any word on a fix for this?

Thanks
vcirrus
Novice
 
Posts: 5
Liked: never
Joined: Thu Jul 28, 2016 2:57 am
Full Name: Mathew Quinn

Re: GET cloud/tenant BackupCount 0

Veeam Logoby v.Eremin » Wed Nov 09, 2016 8:53 am

Looks unexpected, since there should not be any discrepancy between GUI and RESTful API for this matter. It stands to reason to reach our support team.

Thanks.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin


Return to RESTful API



Who is online

Users browsing this forum: No registered users and 2 guests